Network manager gnome not working anymore

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 9
Joined: Wed Aug 03, 2011 2:26 pm

Network manager gnome not working anymore

Postby Gabriele_Angelo » Sat Mar 02, 2013 8:55 am

Hello, since I installed LMDE i had problem with my wireless network card

Code: Select all

Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315]
so I looked for some solution here on forum, but i wasn't lucky, even on other forums. Recently i found this topic and followed what written, but I deleted those directories instead of renaming. Then I deleted network manager and reinstalled. On start up system says that

Code: Select all

is missing, so i manually created directory and file but it didn't work. Now i can't connect my laptop even if wired. How can i make an arrangement?
Thank you for help.
Nothing is impossible. Not if you can imagine it! (Professor Hubert Farnsworth)

Level 1
Level 1
Posts: 3
Joined: Tue Mar 05, 2013 12:00 pm

Re: Network manager gnome not working anymore

Postby kcozens » Thu Mar 07, 2013 3:05 am

Re-installing network-manager should have restored the files and directories you had previously removed. If that did not restore the NetworkManager.conf file you could ask dpkg to reconfigure the package (using its --configure option).

I have one machine with a wired connection and one with WiFi. Both have the following contents in the NetworkManager.conf file as shown below.

Code: Select all



Once you have the configuration file set up you should be able to configure your network connections. You may see two different menu entries for this. Based on my experience trying to get my laptop working I have learned that you should not use the "Network" menu under the System-Administration menu. Instead, you should use "Network Connections" menu located under System->Preferences.

If you use "Network" you will find that you see "Waiting for network connection" at boot time. Once you log in a network connection may exist but you can't manage it properly. If you do see the "Waiting" message at boot time check the file /etc/network/interfaces and remove any lines other than 'auth lo' and 'iface lo inet loopback'.

I would also suggest you edit your menus to hide the "Network" entry under System->Preferences so you don't use it by mistake later on and inadvertently break your network setup.

Return to “Archive”