No AMD ATI Hdmi sound Mint 14 Cinnamon (SOLVED)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
JDinAZ
Level 1
Level 1
Posts: 30
Joined: Sat Nov 05, 2011 5:07 pm

No AMD ATI Hdmi sound Mint 14 Cinnamon (SOLVED)

Post by JDinAZ »

So, I have a ATI HD 4xxx series card on my laptop and I guess the Catalyst drivers wont work with Mint 14 for some reason. Is there any possible way to get sound through Hdmi with the open source drivers? I really like Mint 14 so would rather not have to go back to 13.
Last edited by JDinAZ on Wed Nov 14, 2012 10:46 pm, edited 1 time in total.

remoulder
Level 17
Level 17
Posts: 7626
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: No Hdmi sound Mint 14 Cinnamon

Post by remoulder »

Mint 14 is not released yet, see http://blog.linuxmint.com/?p=2205 for reporting problems on the RC.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

JDinAZ
Level 1
Level 1
Posts: 30
Joined: Sat Nov 05, 2011 5:07 pm

Re: No Hdmi sound Mint 14 Cinnamon

Post by JDinAZ »

This problem isn't really unique to Mint 14 its been around for as many versions as I can remember. In the past the only way around this was to install the AMD proprietary drivers however those drivers no longer work in Mint 14 because of the newer kernel and some other things as I understand it. So my question is there any work around or alternative that anyone knows of to get HDMI sound working with the opensource drivers that anyone knows of? Otherwise I guess those of us with AMD HD 2xxx, 3xxx, 4xxx series cards have no choice but to stay with Mint 13 or older and install the now legacy proprietary drivers from here on out. A rather disappointing alternative :(

JDinAZ
Level 1
Level 1
Posts: 30
Joined: Sat Nov 05, 2011 5:07 pm

Re: No Hdmi sound Mint 14 Cinnamon

Post by JDinAZ »

Well I finally found a solution to this long time annoying problem! I just wish I would have found this sooner. The fix was to add a custom kernel boot parameter. I changed GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" TO GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
This will enable the support for AMD ATI HDMI sound which I guess from what I've read has been around since kernel 3.3 but is not on by default (I don't know why?) Anyways I hope this helps somebody as I know I've spent many hours trying to get this working. Good Luck!

Mandler
Level 1
Level 1
Posts: 5
Joined: Tue Jun 05, 2012 1:09 pm

Re: No AMD ATI Hdmi sound Mint 14 Cinnamon (SOLVED)

Post by Mandler »

@JDinAZ: Thank you. Your solution worked for me.

I had a different situation caused by the same problem. I'm using Mint Mate 14 and discovered that my sound was flaky. Whenever I would adjust the volume, I heard screeching and static that persisted until I made a random change in the sound properties.

Sometimes the distortion returned on its own. Other times, my sound hardware was not recognized at all. I would only see Dummy Output listed under the output devices.

Implementing your suggestion and rebooting solved the problem. (Running update-grub didn't work for me.)

Thank you for the research and for taking the time to share it.

spnoe
Level 1
Level 1
Posts: 14
Joined: Wed Aug 05, 2009 5:47 pm

Re: No Hdmi sound Mint 14 Cinnamon

Post by spnoe »

JDinAZ wrote:Well I finally found a solution to this long time annoying problem! I just wish I would have found this sooner. The fix was to add a custom kernel boot parameter. I changed GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" TO GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
This will enable the support for AMD ATI HDMI sound which I guess from what I've read has been around since kernel 3.3 but is not on by default (I don't know why?) Anyways I hope this helps somebody as I know I've spent many hours trying to get this working. Good Luck!
This sounds like the answer I have been looking for but how do you edit the Grub??

Help much appreciated.
Steve

uzbad
Level 1
Level 1
Posts: 1
Joined: Fri Mar 08, 2013 10:45 am

Re: No AMD ATI Hdmi sound Mint 14 Cinnamon (SOLVED)

Post by uzbad »

Hi,
You need to edit it with e.g.

Code: Select all

sudo nano /etc/default/grub
sudo update-grub
Good Luck!

Post Reply

Return to “Hardware Support”