enable MESA 9?

Archived topics about LMDE 1
Forum rules
lrx
Level 1
Level 1
Posts: 2
Joined: Sat Mar 09, 2013 11:36 am

enable MESA 9?

Postby lrx » Sat Mar 09, 2013 12:01 pm

Hello

I am using LMDE for quite some time. I'm running it on IvyBridge laptop and decided to check how steam for linux works...
Turns out it doesn't, I've heard that mesa 9 is best to run it. inxi -G returns:

Code: Select all

Graphics:  Card Intel 3rd Gen Core processor Graphics Controller X.Org 1.12.4 Res: 1600x900@60.0hz
           GLX Renderer Mesa DRI Intel Ivybridge Mobile x86/MMX/SSE2 GLX Version 3.0 Mesa 8.0.4


So I've built and installed latest libdrm, installed all other required dependencies. Built Mesa 9.0.3 (osmesa enabled) -> success, make install -> reboot.
Nothing changed inxi -G and glxinfo still returns old mesa version.
Same deal if I used checkinstall instead of make install, aptitude returns package as installed yet inxi -G/glxinfo returns old version.

Is there anything else I've to do to enable mesa 9?

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: enable MESA 9?

Postby bigj231 » Sat Mar 09, 2013 12:39 pm

Did you reboot and load the drivers properly? There is a repository that has the latest MESA drivers for Ubuntu, not sure if there is one for Debian.
Here is a blog post I found. http://verahill.blogspot.com/2012/11/mesa-901-64-bit-on-debian-wheezy.html Seems that you need to build libdrm too.
EDIT: another thing: to run TF2 comfortably, you need at least an i5. It runs extremely poorly on my i3 (<15 FPS on any server), regardless of graphics settings.
Running on a 4-slot toaster @ 60Hz

lrx
Level 1
Level 1
Posts: 2
Joined: Sat Mar 09, 2013 11:36 am

Re: enable MESA 9?

Postby lrx » Sat Mar 09, 2013 2:34 pm

Did you reboot and load the drivers properly?
-I did reboot, I don't know anything about loading drivers, so unless it's done automatically then I did not

I did use that blog post as my base, and I did build and install libdrm

I have highest model of i5, TF2 doesn't run at all, I am getting black screen and few broken parts of buttons.
Other linux steam games even if 'works' looks weird, models are not loaded properly and are not animated etc.

after failing with step by step instruction from that blog I've tried compiling mesa with this config

Code: Select all

--prefix=/usr --with-dri-driverdir=/usr/lib/xorg/modules/dri --with-dri-drivers=i965,swrast --with-egl-platforms=x11,drm --enable-texture-float --enable-glx-tls --enable-shared-glapi --enable-gles1 --enable-gles2 --enable-gbm --enable-xvmc --enable-osmesa --enable-xorg --enable-dri --enable-glx --enable-egl --enable-vdpau --enable-xa


which have not changed result

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: enable MESA 9?

Postby bigj231 » Sat Mar 09, 2013 10:34 pm

It seems like this thread is climbing up the google search results, and nobody else has it figured out either.
You could try building the debian package and forcing it over the other one. I would make a full system before I did that though since it will most likely break your system.
Running on a 4-slot toaster @ 60Hz


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest