Sound Only Works with Headphones

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 3
Joined: Mon Mar 11, 2013 10:24 pm

Sound Only Works with Headphones

Postby marky1991 » Mon Mar 11, 2013 10:35 pm

As said in the title, I can't get sound to work properly with my speakers. It works properly if I use headphones. I've tried several things that I've seen via google, but nothing that I've read thus far has fixed it. Any suggestions would be appreciated.

Some system info:

Code: Select all

mark@kirby-linux ~ $ inxi -Fxz
System:    Host: kirby-linux Kernel: 3.5.0-17-generic i686 (32 bit, gcc: 4.7.2)
           Desktop: KDE 4.9.4 (Qt 4.8.3) Distro: Linux Mint 14 Nadia
Machine:   System: HP-Pavilion product: KQ437AA-ABA IQ506
           Mobo: PEGATRON . model: EVE version: 1.04 Bios: American Megatrends version: 5.10 date: 01/16/2009
CPU:       Dual core Intel Core2 Duo CPU T5850 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 8666.46
           Clock Speeds: 1: 2167.00 MHz 2: 2167.00 MHz
Graphics:  Card: NVIDIA G98 [GeForce 9300M GS] bus-ID: 05:00.0
           X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau Resolution: 1680x1050@59.9hz
           GLX Renderer: Gallium 0.4 on NV98 GLX Version: 3.0 Mesa 9.0 Direct Rendering: Yes
Audio:     Card: Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Sound: ALSA ver: 1.0.25
Network:   Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: d800 bus-ID: 02:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Ralink RT2790 Wireless 802.11n 1T/2R PCIe driver: rt2800pci ver: 2.3.0 bus-ID: 04:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 750.2GB (2.2% used) 1: id: /dev/sda model: ST3750630AS size: 750.2GB
Partition: ID: / size: 60G used: 16G (28%) fs: ext4 ID: swap-1 size: 2.51GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 166 Uptime: 13 min Memory: 535.5/4037.1MB Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4

Code: Select all

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code: Select all

lspci -v
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
        Subsystem: Hewlett-Packard Company Device 2a74
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at f9bf8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel

Level 1
Level 1
Posts: 3
Joined: Mon Mar 11, 2013 10:24 pm

Re: Sound Only Works with Headphones

Postby marky1991 » Wed Mar 13, 2013 10:52 pm

In case someone has similar problems in the future, see this:

It turns out that my card had a model name specific to my computer's product family. (touchsmart)

I ended up adding these two lines to the end of /etc/modprobe.d/alsa-base.conf :

Code: Select all

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=touchsmart probe_mask=1

I'm not sure it's all necessary: I didn't bother whittling it down to the bare minimum.

Level 2
Level 2
Posts: 50
Joined: Mon Jun 24, 2013 2:11 pm

Re: Sound Only Works with Headphones

Postby eddie3000 » Mon Jul 08, 2013 4:38 am

I had a similar problem and this worked for me. Thanks you.

Return to “KDE”

Who is online

Users browsing this forum: No registered users and 0 guests