How to disable xscreensaver [solved]

Forum rules
Before you post please read how to get help
graeme
Level 3
Level 3
Posts: 106
Joined: Sat Feb 14, 2009 3:38 am
Location: Far away from proper beer.
Contact:

How to disable xscreensaver [solved]

Postby graeme » Sat Sep 11, 2010 7:03 am

Using Mint 9 XFCE, I want to disable xscreensaver, and user gnome-screensaver, because switch user does not work with xscreensaver (xscreensaver needs a minor change to be compatible with the current gdmiflexiserver).

I cannot find how to stop xscreensaver. Its not in autostart list, or the session and even if I stop it and save the session its still there.
Last edited by graeme on Sat Sep 11, 2010 5:41 pm, edited 1 time in total.

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How to disable xscreensaver.

Postby merlwiz79 » Sat Sep 11, 2010 2:02 pm

It's in the script that starts the session.
Xscreensaver is used because gnome-screensaver is now incompatible with Xfce.
Image

graeme
Level 3
Level 3
Posts: 106
Joined: Sat Feb 14, 2009 3:38 am
Location: Far away from proper beer.
Contact:

Re: How to disable xscreensaver.

Postby graeme » Sat Sep 11, 2010 5:41 pm

xscreensaver is now incompatible with GDM, and that was more of a problem with me (it was not possible to switch user/new login from a locked screen).

I installed gnome-screensaver and uninstalled xscreensaver. The script starts gnome-screensaver if it cannot find xscreensaver, so that is now OK.

The gnome-screensaver incompatibility was easily worked around by using xautolock to start gnome-screensaver

Code: Select all

xautolock -time 5 -locker "gnome-screensaver-command --lock"


and add it to XFCE' autostart config

The only real issue is that because the GUI does not let you edit autostart entries, I have to delete the xautolock entry and add it again if I change my mind about how long it should start the screensaver after.

User avatar
oddhack
Level 1
Level 1
Posts: 9
Joined: Fri Feb 19, 2010 5:18 pm
Location: UK
Contact:

Re: How to disable xscreensaver [solved]

Postby oddhack » Tue May 17, 2011 11:45 am

Hi thanks for these responses, I am trying to get this to work in order to be able to use the fast user switcher.
I have uninstalled xscreensaver and installed gnome-screensaver.

I am unsure how to implement graeme's fix - please could someone let me know which autostart file is being referred to?
What should this edited file look like once I have added the xautolock line please?

Thanks.

Smiff2
Level 3
Level 3
Posts: 119
Joined: Sat Jan 16, 2010 11:53 am

Re: How to disable xscreensaver [solved]

Postby Smiff2 » Mon Mar 18, 2013 8:21 pm

2 years later, can anyone tell me if this still works please?

just realised XFCE Mint13 still has this issue i think, you can't switch users from the lockscreen.

disabling xscreensaver just means users can switch with no security at all!


also the xfce panel switch user dialogue is confusing, with it's "open new display" "switch to existing display" buttons.

i guess what i want is to always go back to the Login screen (ideally with screensaver). not sure how to acheive this.

i might have to try Xubuntu to see how that handles it.


Return to “XFCE”

Who is online

Users browsing this forum: No registered users and 2 guests