Python Uninstall reinstall problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
paalaak
Level 1
Level 1
Posts: 1
Joined: Tue Mar 26, 2013 11:25 am

Python Uninstall reinstall problem

Postby paalaak » Tue Mar 26, 2013 11:36 am

I tried to uninstall python by following the instructions in this link
http://stackoverflow.com/questions/3544378/uninstall-python-built-from-source

now everytime I try to use

Code: Select all

sudo apt-get install
command, i get the following error

Code: Select all

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apt-xapian-index : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 aptoncd : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 duplicity : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 gufw : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 hplip : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 mint-common : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintbackup : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintdesktop : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintinstall : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintmenu : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintnanny : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintupdate : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintupload : Depends: python (< 3) but 3.3.0-1 is to be installed
 mintwelcome : Depends: python (< 3) but 3.3.0-1 is to be installed
 python-appindicator : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-apt : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-aptdaemon : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-beautifulsoup : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-cairo : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-chardet : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-configglue : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-crypto : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-cups : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-cupshelpers : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-dbus : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-debian : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-debtagshw : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-defer : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-dirspec : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-feedparser : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gconf : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gi : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gi-cairo : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-glade2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gnome2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gnomekeyring : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gnupginterface : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gobject-2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gst0.10 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gtk2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-gtksourceview2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-httplib2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-imaging : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-libxml2 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-lxml : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-mako : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-markupsafe : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-notify : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-oauth : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-openssl : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pam : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-paramiko : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pexpect : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-piston-mini-client : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pkg-resources : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-protobuf : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pycurl : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pyicu : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pyinotify : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-pyorbit : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-qt4 : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-qt4-dbus : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-renderpm : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-reportlab : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-reportlab-accel : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-rpm : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-serial : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-simplejson : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-sip : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-six : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-smbc : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-sqlite : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-sqlitecachec : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-twisted-bin : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-twisted-core : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-twisted-names : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-twisted-web : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-uno : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-urlgrabber : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-utidylib : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-vte : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-webkit : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-xapian : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-xdg : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 python-zope.interface : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 sessioninstaller : Depends: python (< 2.8) but 3.3.0-1 is to be installed
 ubuntu-system-service : Depends: python (< 2.8) but 3.3.0-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


I tried reinstalling python3.3.0 exactly as before but it didn't work. Please help me get rid of this error.

User avatar
renatov
Level 2
Level 2
Posts: 81
Joined: Mon Mar 25, 2013 8:45 am

Re: Python Uninstall reinstall problem

Postby renatov » Wed Mar 27, 2013 2:32 am

A lot of packages use python, it's a really bad idea to remove it :D

I didn't understand why you did that... do you have 2 python installations?


Return to “Newbie Questions”

Who is online

Users browsing this forum: austin.texas, rayluv and 7 guests