LinuxMint 14 Internet Issues RealTek card

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
rsoto2
Level 1
Level 1
Posts: 1
Joined: Thu Mar 28, 2013 12:00 pm

LinuxMint 14 Internet Issues RealTek card

Postby rsoto2 » Thu Mar 28, 2013 12:02 pm

For the past month and a half or so I've been trying to rid myself of my windows dependency. I have tried Fedora, Ubuntu, and now LinuxMint. Everything works great. Except the internet. This is usually how it goes:

Install distro Everything works great for about two days, no issues at all.

Then my internet connection starts to fail, every single time. It will connect to the internet, then lose connectivity and not be able to reconnect at all. I'll do a restart, and the internet connection will come back, only to be lost again after fifteen minutes. I've looked into this extensively, and I believe it has something to do with the drivers for my card, it is a RealTek type card.

I've tried doing the solution I've found for similar problems on my own but I've always ended up doing more harm than good. I think the best way to do this would be to use the windows driver for the card in linux, do you guys think this is possible? and how to do it?

You guys are the best. Thanks for reading.

User avatar
turboscrew
Level 3
Level 3
Posts: 148
Joined: Sat Sep 26, 2009 2:13 pm

Re: LinuxMint 14 Internet Issues RealTek card

Postby turboscrew » Fri Mar 29, 2013 1:11 pm

Did Linux identify the card right (lspci lshw)?
Do you have the right driver?
Also, how's the power saving settings? I hope the power isn't switched off from the network card.

(Just thoughts...)


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 11 guests