Sound stops suddenly

Questions about applications and software
Forum rules
Before you post please read how to get help
Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Sound stops suddenly

Postby Tuchkata » Tue Apr 02, 2013 1:17 am

Hi. I have a pretty annoying problem. Sometimes, when I'm watching a movie or listening music, when the sound from the movie or the song is too loud the sound suddenly stops and don't want to work before a restart. The strange thing here is, that when I plug headphones, everything works just find but only with headphones. It doesn't happen every day or every time, but sometimes it happens. Any ideas what the problem is and how can I fix it? Thank you in advance :)

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Tue Apr 02, 2013 11:44 am

Too loud meaning your speakers are overheating? I've had this problem with guitar and bass amps, but never with computers. It's usually only when it's been playing for a while at high volume in a warm environment. It's just the overheat protection mechanism coming on and staying on until you power cycle the amp. I have no idea if that can happen in computers, but it seems plausible to me.
Running on a 4-slot toaster @ 60Hz

homerscousin
Level 5
Level 5
Posts: 531
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Sound stops suddenly

Postby homerscousin » Tue Apr 02, 2013 2:20 pm

Yup, that above post does sound logical. Some over temp, over volt, over current protection in your system. Maybe if you post your hardware details someone may know a bit more.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Fri Apr 05, 2013 4:29 am

I am using Lenovo ThinkPad T410 and Linux Mint 14 Nadia. I don't think it is overheating because it happens not only when I'm listening loud for example for 10 or more minutes but also when I just volume up my player and then it happens. Maybe it is over voltage.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Fri Apr 05, 2013 2:10 pm

Next time it stops, can you press [ALT]+[F2] and type in

Code: Select all

pulseaudio -k


Let us know if that works.
Running on a 4-slot toaster @ 60Hz

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Fri Apr 05, 2013 2:47 pm

Yes, I'll try it and say if it works :)

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Mon Apr 29, 2013 1:52 pm

Hi again. The problem still exists and when I type "pulseaudio -k" and the I try "pulseaudio" I receive the following error :

Code: Select all

tuchkata@tuchkata ~ $ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Any ideas?

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Mon Apr 29, 2013 2:49 pm

In a terminal:

Code: Select all

sudo killall pulseaudio
should kill any running instance.
See this thread: http://ubuntuforums.org/showthread.php?t=816159 It's old, but it's still valid.

Also, pulseaudio should restart itself after you kill it. That would explain your error.
Running on a 4-slot toaster @ 60Hz

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Wed May 01, 2013 5:27 pm

The problem still exists. I tried to delete .pulse directory in my home directory, but still no result. Any other ideas? Killing pulseaudio doesn't work.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Wed May 01, 2013 7:57 pm

Maybe purge and reinstall? Make sure to write down exactly what uninstalls and install it again.
Running on a 4-slot toaster @ 60Hz

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Thu May 02, 2013 2:22 am

On the screen below it can't be seen but the scale under Front Left and Fron Right of the built in speakers is moving when I watch youtube video for example. Which means, Pulseaudio should be working, but the problem is in my speakers. I still have sound on headphones. Any new ideas?
Edit: Another thing that I figured out is that when I plug my Power supply a sound that the supply is plugged in comes FROM the speakers?! So again any ideas?
Attachments
screen.png

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Fri May 03, 2013 2:59 am

Some new things that I mentioned today and yesterday. With Alsa the problem still exists and I think it is really something like overvoltage from the speakers because it always happens when the sound is loud. Any ideas what can I do to fix the problem?

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Sun May 05, 2013 1:03 pm

So it has problems after you've been playing loud audio for any length of time. But while the sound isn't working, if you plug in your power supply it plays the chime. Is that correct?
Do the speakers start to buzz or distort before they quit? Also, could you try another distro (preferably not ubuntu-based) and see if the issue persists? Knoppix might be a good option since it's a small download. Puppy Linux is also another consideration.

If there's a warranty on the laptop, and it has the same problem in another distro, I would see about getting it repaired or replaced. I've never heard of a laptop overvolting speakers, and the speakers surviving. They should distort and blow soon after if it's overvolting, not immediately stop working and resume randomly.
Running on a 4-slot toaster @ 60Hz

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Wed May 08, 2013 10:47 am

So it has problems after you've been playing loud audio for any length of time. But while the sound isn't working, if you plug in your power supply it plays the chime. Is that correct?

Exactly! I say overvoltage but it can as well be any other type of over-something. The strange thing is that in Windows or with older distros there is no such problems and it is strange that every time when I restart my system the sound is back. I would say the problem is connected with the software and only with the speakers. Today I talked with a friend who is using Ubuntu and he told me he has the same problem ( I think he has a HP or Dell notebook). Any new ideas? There is no buzz or some "signal" before the speakers quit.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Sound stops suddenly

Postby bigj231 » Wed May 08, 2013 2:42 pm

I would recommend updating to Mint 15 when it comes out in a few weeks. See if it fixes your issue.
Running on a 4-slot toaster @ 60Hz

Tuchkata
Level 1
Level 1
Posts: 17
Joined: Fri Jan 04, 2013 3:11 am

Re: Sound stops suddenly

Postby Tuchkata » Wed May 08, 2013 3:23 pm

Yes, this is exactly what I'm waitin for :)


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 4 guests