Mint 14.1 Mate and X1200 HDMI audio

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Grossmeister
Level 1
Level 1
Posts: 3
Joined: Sun Mar 31, 2013 6:05 pm

Mint 14.1 Mate and X1200 HDMI audio

Postby Grossmeister » Mon Apr 01, 2013 2:59 pm

Hi, I'm enough new to Linux and Mint in particular.

Trying to connect an old PC with X1200 integrated graphics to FullHD TV. Currently I'm happy with the performance I received on Mint Mate when plaing 1080p videos. But I can't get audio via HDMI. I've red some threads about ATI HDMI audio problems in Mint and Ubuntu, but still couldn't solve the problem.
For example, I tried to follow these instructions, but step 7 (playing .wav using aplay) failed. Also tried this.

From the beginning I went to Sound Preferences in Control Center and on Output tab set Radeon X1200 device.
Here is info about PC configuration:
aplay -l

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

User avatar
catweazel
Level 7
Level 7
Posts: 1652
Joined: Fri Oct 12, 2012 9:44 pm

Re: Mint 14.1 Mate and X1200 HDMI audio

Postby catweazel » Mon Apr 01, 2013 3:36 pm

If it's a Radeon card you'll need a propietary driver to get sound working over HDMI.
Mint Testing Team & Mint Donor #3606
Intel i7 4820K @ 4.7GHz, 32GB Corsair Vengeance Pro
2133MHz XMP, 4 Samsung 850 PRO 512GB SSDs in
RAID0, 12TB HW RAID10, 3 x 24" Samsung UlHD,
Dual R290X

Grossmeister
Level 1
Level 1
Posts: 3
Joined: Sun Mar 31, 2013 6:05 pm

Re: Mint 14.1 Mate and X1200 HDMI audio

Postby Grossmeister » Mon Apr 01, 2013 4:53 pm

This one, or fglrx?

Grossmeister
Level 1
Level 1
Posts: 3
Joined: Sun Mar 31, 2013 6:05 pm

Re: Mint 14.1 Mate and X1200 HDMI audio

Postby Grossmeister » Sun Apr 07, 2013 1:41 am

Can someone give more details on how to install proprietary driver for this chip?

I tried

Code: Select all

sudo apt-get install fglrx

it installed something, CCC appeared on control center, but when I try to open it I get a message that "no AMD driver is installed".
During installation it gave such message, don't know is it important or not:

Code: Select all

fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.5.0-17-generic/kernel/drivers/char/drm/


Also I couldn't install any of .run drivers downloaded from AMD website.
Version 13.1, 12.10 start GUI that gives such message:

Code: Select all

Your graphics adapter is not supported by this driver. Installation will not proceed.

11.2, 10.2, 9.3 could'nt start GUI with a message in terminal:

Code: Select all

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib32::none:3.5.0-17-generic:; make sure that the version is being
correctly set by --iscurrentdistro


So, I assume I should somehow install some of old versions. I checked --listpkg output, there are some options for Debian and Ubuntu, like Ubuntu/source, Debian/stable.
Which package should I choose for Mint 14.1 for --buildandinstallpkg option?

diletant
Level 1
Level 1
Posts: 1
Joined: Sun Apr 14, 2013 2:10 pm

Re: Mint 14.1 Mate and X1200 HDMI audio

Postby diletant » Sun Apr 14, 2013 2:11 pm

I have the same problem.
Does anyone has it working?


Return to “Hardware Support”

Who is online

Users browsing this forum: Google [Bot] and 3 guests