Yet Another Hibernate Post?

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 3
Joined: Tue Apr 09, 2013 9:37 am

Yet Another Hibernate Post?

Postby Locosway » Thu Apr 11, 2013 5:29 am

Yes, after reading dozens of threads and articles on how to get hibernate working, I'm going to post my own. Why? Because I've tried everything and I'm stuck. Any advice on what to look at next or anything else would be helpful. Currently my laptop will suspend and resume correctly, and it will hibernate, but it will not resume from hibernate. The error I am getting from resume is:

Code: Select all

(process:316) GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)
Scanning for Btrfs filesystems
resume: libgcrypt version: 1.5.0
Looking for splash system... none
Cannot open input directory: No such file or directory
resume: Compressed image
Loading image data pages (710632 pages)... 100% done
wrote 2775.9 MB in 8.5 seconds (326.1 MB/s)
read 2775.9 MB in 7.8 seconds (354.7 MB/s)

And this is where my laptop hangs. Nothing else happens, no HDD activity, and I can't switch back to the LMDE splash screen by using 'esc'. From here I need to hit ctrl-alt-del to reboot, or do a hard reset.

Here is the config I have.

Code: Select all

greg@moniker ~ $ sudo blkid
/dev/sda2: UUID="e6bf8958-015a-4c3d-b442-0d50c788dbf7" TYPE="swap"
/dev/sdb1: LABEL="Storage" UUID="196779fe-33d2-4fe6-a478-267aaa3e4e79" TYPE="ext4"
/dev/sda1: UUID="e76a502c-1c82-4602-9c3f-855d25241f95" TYPE="ext4"

Now, for the resume file I've tried both "RESUME=UUID=" and the current setting. Each time I've changed this file I run 'sudo update-initramfs -u'.

Code: Select all

greg@moniker ~ $ cat /etc/initramfs-tools/conf.d/resume

I have enough swap space for my RAM

Code: Select all

greg@moniker ~ $ free -m
             total       used       free     shared    buffers     cached
Mem:          7750       1772       5977          0         56        469
-/+ buffers/cache:       1247       6503
Swap:         7999          0       7999

I installed uswsusp and then ran dpkg-reconfigure to go through the setup

Code: Select all

# /etc/uswsusp.conf(5) -- Configuration file for s2disk/s2both
resume device = /dev/disk/by-uuid/e6bf8958-015a-4c3d-b442-0d50c788dbf7
splash = y
compress = y
early writeout = y
image size = 3738599260
RSA key file = /etc/uswsusp.key
shutdown method = platform

Even as a last resort I've tried editing grub, and then running 'sudo update-grub'.

Code: Select all


However, at this point I don't believe it's an issue with the RAM being copied to the swap because the laptop hibernates fine, but it just won't resume. I know my hardware is capable of suspend/hibernate/resume because every other distro has worked correctly. The only two that have not are LMDE Cinnamon and MATE. So something that Debian has done is different from everyone else. This is something I really need to get working in order for me to really stay on LMDE.

Thanks in advance.

Note: There aren't any logs for resume, even when I turn on debug for pm-utils. However, my full logs are here:

Here's my fstab and mount:

Code: Select all

greg@moniker ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc   /proc   proc   defaults   0   0
# /dev/sda1
UUID=e76a502c-1c82-4602-9c3f-855d25241f95   /   ext4   noatime,rw,errors=remount-ro   0   1
UUID=196779fe-33d2-4fe6-a478-267aaa3e4e79   /media/Storage   ext4   rw,errors=remount-ro   0   1
# /dev/sda2
UUID=e6bf8958-015a-4c3d-b442-0d50c788dbf7   swap   swap   sw   0   0

tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
tmpfs /var/run tmpfs defaults 0 0
tmpfs /var/lock tmpfs defaults 0 0

Code: Select all

greg@moniker ~ $ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=981996,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=793692k,mode=755)
/dev/disk/by-uuid/e76a502c-1c82-4602-9c3f-855d25241f95 on / type ext4 (rw,noatime,errors=remount-ro,user_xattr,barrier=1,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=3225780k)
/dev/sdb1 on /media/Storage type ext4 (rw,relatime,errors=remount-ro,user_xattr,barrier=1,data=ordered)
tmpfs on /tmp type tmpfs (rw,nosuid,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
cgroup on /dev/cgroup/cpu type cgroup (rw,relatime,cpu,release_agent=/usr/local/sbin/cgroup_clean)

Level 1
Level 1
Posts: 5
Joined: Mon Oct 07, 2013 6:46 am

Re: Yet Another Hibernate Post?

Postby Lukasz_Cholewa » Mon Oct 07, 2013 7:29 am

I know the topic is old, but still maby usefull to someone with similar problem.
I had almost identical issue. I have found answer here: ... esume-fail

The answer was to remove "hibernate" and "uswsusp" programs

Code: Select all

sudo apt-get remove hibernate uswsusp

The rest of cited tutorial is quite informative too.
Hope this helps

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests