Properly switching to multiarch

Archived topics about LMDE 1
Forum rules
dclement
Level 4
Level 4
Posts: 236
Joined: Thu Apr 19, 2012 9:59 am

Properly switching to multiarch

Postby dclement » Wed Apr 17, 2013 12:57 pm

Hello,

I have read this useful thread by zerozero and I tried to follow the instructions. It work, but I ended up with a small inconvenient.

Here are two packages that I need:
- libstdc++2.10-glibc2.2_2.95.4-24_i386 (desperately needed by a program that I have to use professionally);
- nlittre2007_1.3.6-2_i386 (nice but outdated standalone dictionary program).

Of course I had to install them manually with dpkg. They don't appear in Synaptic.

But after enabling multiarch, they become visible, and Synaptic reports them as broken. I don't mind, but I get a warning, every time I start Synaptic, about 2 broken packages. How could I tell Synaptic to ignore them and turn off the warning?

(For now I have reversed the steps and disabled multiarch.)

TIA for any suggestion - Daniel

millpond
Level 2
Level 2
Posts: 61
Joined: Tue Jan 31, 2012 6:34 pm

Re: Properly switching to multiarch

Postby millpond » Fri Apr 19, 2013 10:43 pm

You can try dpkg -a --configure (I believe thats the right syntax...) but I have found it usually does not work in those situations. .

The only thing that works for obstinate packages is to edit
/var/lib/dpkg/status

Search the packages and change the top lines to
install ok installed
(like the others)

dclement
Level 4
Level 4
Posts: 236
Joined: Thu Apr 19, 2012 9:59 am

Re: Properly switching to multiarch

Postby dclement » Mon Apr 22, 2013 9:38 am

Hmm... I tried re-enabling multiarch:

Code: Select all

sudo dpkg --add-architecture i386
(I did not modify the sources.list).

The warning message was back in Synaptic.

Then I had a look at
/var/lib/dpkg/status

The offending packages were already "install ok installed". I'm confused...


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests