scratchy sound in Skype

Archived topics about LMDE 1
Forum rules
mr.acid
Level 1
Level 1
Posts: 3
Joined: Wed Feb 08, 2012 5:48 pm

scratchy sound in Skype

Postby mr.acid » Fri Sep 28, 2012 4:40 pm

Code: Select all

System:    Host fx8120 Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Audio:     Card Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver snd_hda_intel
           Sound: Advanced Linux Sound Architecture Version 1.0.24


Hi!

In Skype 4.0.0.8 (deb/amd64) the sound is completely scratchy most of the times. The rest of the applications using the sound device are running perfect (e.g VLC etc.). The soundserver is PULSE.

Someone here experienced same probs and have a solution to this?

Thx for input!

best regards,
Acid

Bonsaii
Level 2
Level 2
Posts: 85
Joined: Sat Oct 09, 2010 8:49 am

Re: scratchy sound in Skype

Postby Bonsaii » Wed Oct 03, 2012 9:40 am

Hi,

Yep, I had that too. The "usual suspects" are:

In Skype Options --> Sound Devices --> un-check "Allow Skype to automatically adjust mixer levels"

In Sound & Video --> Volume Control --> Recording --> make sure "Digital" is muted or down to zero

Good luck!

Otyugh
Level 3
Level 3
Posts: 120
Joined: Wed Jan 02, 2013 9:52 pm

Re: scratchy sound in Skype

Postby Otyugh » Fri Apr 19, 2013 7:59 pm

Despite of that, scratch is continuing :(

jjaythomas
Level 5
Level 5
Posts: 603
Joined: Sun Mar 07, 2010 12:52 pm

Re: scratchy sound in Skype

Postby jjaythomas » Sat Apr 20, 2013 1:20 am

Have on different computers. All were remastersys from same initial 'master'.
On one (my wifes) skype (shes the primary user of app to sons (uses win 8 I belive) sound was scratchy also, but all other sound apps seemed fine.
Only solution found was to totally purge 'pulseaudio' from system. :wink:

Even telling system to not boot 'pulseaudio' in system service wouldn't work. PURGE only thing work (because a desktop ALSA was all thats really needed anyways).

J.Jay

P.S. same with other distros (Only that computer) Sound card (maybe :roll: )

Otyugh
Level 3
Level 3
Posts: 120
Joined: Wed Jan 02, 2013 9:52 pm

Re: scratchy sound in Skype

Postby Otyugh » Sat Apr 20, 2013 5:19 am

Purge totally ? Hard.
I must admit that pulsaudio is quite strange, considering that he is sometimes using a lot of processor, but it is doing his job quite good as well.

I don't see myself lose it just for some skype abomination. Thought mumble is quite more complicated for set up instant informall meetings. I'll certainly try jabber for text messages now x)


Ho, and wait. Sometimes the sounds works greats. What the... O.o

jjaythomas
Level 5
Level 5
Posts: 603
Joined: Sun Mar 07, 2010 12:52 pm

Re: scratchy sound in Skype

Postby jjaythomas » Sat Apr 20, 2013 11:54 am

Ya purging pulseaudio is drastic measure and wouldn't do if could or somebody find correct solution!

But my wife uses skype to video call son (and some other relatives) would like to get them to use 'gmail' where their 'gtalk' with video seems to work great with video calls in linux. Can't force other to use gmail just for are (wife's) benefit.

J.Jay

P.S. can install other distro (that don,t use pulse) but end up looking like LMint anyways! So save time install 'Mint' and uninstall pulseaudio on one computer.

Otyugh
Level 3
Level 3
Posts: 120
Joined: Wed Jan 02, 2013 9:52 pm

Re: scratchy sound in Skype

Postby Otyugh » Sat Apr 20, 2013 12:26 pm

But this is weird. I'll search further on Ubuntu's forum. - We don't change car when we need to change a light, come on !

Also i can say, skype sound works perfectly 1/3 of the time. So I don't think it's too far to work perfectly someday :D

> "/etc/pulse/default.pa", change "load-module module-udev-detect" by "load-module module-udev-detect tsched=0" && reboot


...Gosh, seem to work O_o

jjaythomas
Level 5
Level 5
Posts: 603
Joined: Sun Mar 07, 2010 12:52 pm

Re: scratchy sound in Skype

Postby jjaythomas » Sat Apr 20, 2013 6:49 pm

We don't change car when we need to change a light, come on !


Nope but if need car and light keeps flickering I might take the bulb out! :roll:

not got rid of car just the problem/anoyance. Can always replace blub if find fix.
/etc/pulse/default.pa", change "load-module module-udev-detect" by "load-module module-udev-detect tsched=0" && reboot

Haven't seen that one will try it. If not will keep the 'light bulb out of socket' :oops:

J.Jay

Otyugh
Level 3
Level 3
Posts: 120
Joined: Wed Jan 02, 2013 9:52 pm

Re: scratchy sound in Skype

Postby Otyugh » Sun Apr 21, 2013 5:59 am

I'd really want to see a free alternative to Skype. Because this software is a rape of every standards ;O

NikosPG
Level 1
Level 1
Posts: 6
Joined: Wed Jul 03, 2013 10:02 am

Re: scratchy sound in Skype

Postby NikosPG » Wed Jul 03, 2013 10:15 am

So? any solution? i am on Olivia

Otyugh
Level 3
Level 3
Posts: 120
Joined: Wed Jan 02, 2013 9:52 pm

Re: scratchy sound in Skype

Postby Otyugh » Thu Aug 15, 2013 1:18 pm

As said just before :
"gedit /etc/pulse/default.pa", change "load-module module-udev-detect" by "load-module module-udev-detect tsched=0".
Then reboot.
Worked for me.

mircsicz
Level 1
Level 1
Posts: 4
Joined: Wed Oct 09, 2013 7:40 pm

Re: scratchy sound in Skype

Postby mircsicz » Thu Oct 10, 2013 4:29 am

THX a ton, fixed it for me too!!!

Greetz
Mircsicz

ozzyjr
Level 1
Level 1
Posts: 1
Joined: Wed May 20, 2015 2:31 pm

Re: scratchy sound in Skype

Postby ozzyjr » Wed May 20, 2015 2:33 pm

My config file default.pa was a bit different so i fixed by entering " tsched=0" into it, as below;

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect use_ucm=0 tsched=0
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 9 guests