[Solved] cinnamon & gnome-shell crash on login

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 7
Joined: Mon Mar 14, 2011 1:09 am

[Solved] cinnamon & gnome-shell crash on login

Postby pseudomorph » Tue Nov 27, 2012 2:18 am

Hi all,

I have an issue very similar to that described by suicidejack over in this thread: viewtopic.php?f=90&t=87629

The symptoms are that since this morning when I put my laptop into hibernate I've not been able to log into either gnome-shell, gnome-fallback or cinnamon. Each desktop crashes with the error message "Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again."

I can, however, log into & use Mate and a newly created test account does not suffer from the issue. This indicates to me that the problem is local to my account & most likely something to do with gnome3

After much googling, I've not come up with a solution that works for me.

Things I have tried include:
Ensuring compiz is not attempting to start on boot.
Removal of any gnome-shell or cinnamon extensions/applets that might be causing a problem.
Resetting gsettings as described in this bug: https://bugs.launchpad.net/linuxmint/+bug/982051

And much more that I've not documented.

Looking for a little help on where to go from here.

Edit: For the record this LMDE installation is on a Macbook 2,1 that uses Intel graphics that appear to be working correctly.

Code: Select all

[pseudomorph@blackbook:~]$ inxi -F

System:    Host blackbook Kernel 3.2.0-3-486 i686 (32 bit) Distro Linux Mint Debian Edition
CPU:         Single core Intel Core2 T7200 (-UP-) cache 4096 KB flags (lm nx sse sse2 sse3 ssse3 vmx) bmips 3990.05 clocked at 1000.00 MHz
Graphics:  Card Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller X.Org Res: 1280x800@59.9hz
           GLX Renderer Mesa DRI Intel 945GM x86/MMX/SSE2 GLX Version 1.4 Mesa 8.0.3 Direct Rendering Yes
Audio:     Card Intel N10/ICH 7 Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card-1 Atheros AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) driver ath9k BusID: 02:00.0
           Card-2 Marvell 88E8053 PCI-E Gigabit Ethernet Controller driver sky2 v: 1.30 at port 1000 BusID: 01:00.0
Disks:     HDD Total Size: 750.2GB (36.3% used) 1: /dev/sda SAMSUNG_HN 750.2GB
Partition: ID:/ size: 44G used: 8.1G (20%) fs: rootfs ID:/ size: 44G used: 8.1G (20%) fs: ext4
           ID:/boot size: 485M used: 38M (9%) fs: ext2 ID:/home size: 550G used: 254G (49%) fs: ext4
           ID:swap-1 size: 3.14GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes 128 Uptime 27 min Memory 285.9/2006.9MB Runlevel 2 Client Shell inxi 1.4.23

Level 1
Level 1
Posts: 7
Joined: Mon Mar 14, 2011 1:09 am

Re: [Solved] cinnamon & gnome-shell crash on login

Postby pseudomorph » Thu Dec 06, 2012 11:08 pm

I finally got some time to troubleshoot this issue and have manged to solve it reasonably easily.

~/.xession-errors showed up a number of errors, none of which was particularly helpful.

After a little more digging I thought the error may lie in dconf, so tried removing ~/.config/dconf/ and managed to log in fine.

Removing dconf did mean that a few of my Cinnamon tweaks (themes, etc) needed to be redone.

Hope this helps someone in future.

Level 1
Level 1
Posts: 3
Joined: Sun May 15, 2011 12:06 am

Re: [Solved] cinnamon & gnome-shell crash on login

Postby linucksrox » Fri May 17, 2013 8:16 pm

Thanks! This also worked for me.

I attempted the "upgrade" from Nadia to Olivia RC, but somehow botched the cinnamon config causing the same issues upon login. I then installed a "fresh" copy of Olivia RC, forgetting to realize that when it mounted my unformatted /home partition it would keep trying to use the old config files. After deleting that dconf directory it booted right up with no issues.

Code: Select all

sudo rm -rf ~/.config/dconf

Return to “Archive”