SOLVED! disable CTRL-ALT-F1...F6

Forum rules
Before you post please read how to get help
ccc
Level 3
Level 3
Posts: 100
Joined: Sat Jul 23, 2011 7:40 pm

SOLVED! disable CTRL-ALT-F1...F6

Postby ccc » Mon May 20, 2013 7:47 am

hi

Howto disable CTRL-ALT-F1...F6 on Mint with LXDE?
Last edited by ccc on Mon May 20, 2013 4:54 pm, edited 1 time in total.

User avatar
xenopeek
Level 23
Level 23
Posts: 19222
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: disable CTRL-ALT-F1...F6

Postby xenopeek » Mon May 20, 2013 8:03 am

Depends on which Linux Mint version you are using. Assuming you are using a supported version of Linux Mint (13 or above), configure the Upstart services for these to not start automatically. I recommend you keep at least one virtual console functioning so you can use that in case you run into problems with your graphical desktop. In any case, this will not save you any significant amount of RAM or CPU if that was your intent.

To disable the virtual console at Ctrl+Alt+F1:

Code: Select all

echo manual | sudo tee -a /etc/init/tty1.override

Repeat the command for the other 5 as desired, replacing 'tty1' with 'tty2', 'tty3', and so on.
Image

ccc
Level 3
Level 3
Posts: 100
Joined: Sat Jul 23, 2011 7:40 pm

Re: disable CTRL-ALT-F1...F6

Postby ccc » Mon May 20, 2013 4:54 pm

Create as root in /usr/share/X11/xorg.conf.d/50-novtswitch.conf with these entries:

Code: Select all

Section "ServerFlags"
Option "DontVTSwitch" "true"
EndSection


Return to “Others”

Who is online

Users browsing this forum: No registered users and 0 guests