error: attempt to read or write outside of disk 'hd0'

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 3
Joined: Wed Mar 23, 2011 2:05 pm

error: attempt to read or write outside of disk 'hd0'

Postby kexo » Thu Feb 14, 2013 1:34 pm

Hi guys,

i have Lenovo thinkpad T420s with 120GB SSD disk and Core i5. I tried to install linux mint 14 KDE and happened really strange problem. :?

I used the Live mint 14 KDE and everything worked OK. Drivers were find, everything worked. So i installed him to laptop and after instalation i rebooted the laptop... it is normally.... Laptop started and worked OK (after restart).... BUT when i turned off this laptop ... he didn't boot again just showed me grub and when i chose OS he wrote this error.

Code: Select all

error: attempt to read or write outside of disk 'hd0'
press any key to continue...

Laptop is not working now.... i tried reinstall and happened again. I installed ubuntu 12.10 and everything working ok without problem. So it is problem only this distribution.

This problem is really funny :D because when i am using only restart and sleep everything is working but when i turn off him... he doesn't start again. :D

Have you encountered this problem????

Sorry for my english i am from slovakia.
Bye Kexo.

Arthur Dent
Level 1
Level 1
Posts: 1
Joined: Wed May 08, 2013 8:39 pm

Re: error: attempt to read or write outside of disk 'hd0'

Postby Arthur Dent » Wed May 08, 2013 8:53 pm

I am getting the same error. Downloaded the latest 32bit Cinnamon version, Nadia. Booted from disc just fine. Ran the installer with no issues. When I rebooted, I got this error. I thought it might have been because I had Ubuntu on the disc originally (Mint saw this and I told it to get rid of it) so I booted back into the live disc and ran gparted to delete all partitions. Reran the install and got the same results. Laptop is a HP nc6320 with 250GB hard drive.

Downloading the Mate version now just to see if I get different results.

User avatar
Level 1
Level 1
Posts: 2
Joined: Thu Jun 14, 2012 6:16 am
Location: South Africa

Re: error: attempt to read or write outside of disk 'hd0'

Postby MJ-meo-dmt » Wed May 22, 2013 4:46 am

Hi, same here with Mint Mate 64Bit (Nadia). On a HP Compaq nc8430, 250 GB HDD.

I tried with and without Sata Native mode(I know windows usually have problems with that), I also tried moving the boot loader to be installed on a different partition. Also tried making a /boot part. the usual way I setup my Partitions is 1: (main) / which is 248GB, and then a 2GB swap... I have crunchbang atm and that works just fine. I had mint 13 awhile back and that worked fine, both 32/64 bits...

So i have no idea confused is wrong. Booting into Live works fine. Oh to mention when i tried the install with a / (main) /boot (1GB) and a swap. with the bootloader on the main drive it complained that the partition does exist. (when it gets to the grub after install)

- Linux Mint 13 - Maya

" Dream what you want to dream, go where you want to go, be what you want to be. Because you have only one life and
one chance to do all the things you want to do. "

Return to “Installation & Boot”