[Mint 15] Cinnamon running in software rendering mode

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Pustul
Level 1
Level 1
Posts: 5
Joined: Tue Mar 19, 2013 6:31 am

[Mint 15] Cinnamon running in software rendering mode

Post by Pustul » Thu May 23, 2013 6:38 pm

Hi guys,
I have a problem with Cinnamon, I just installed Mint 15 on my Desktop (with a HD7970) where I usually run only Windows for games, but I mainly use Mint on my laptop for work and I want it on a bigger screen now, But when I boot there is a message of Cinnamon complaining that it's running in software rendering mode, without video hardware acceleration,... I search a lot on Google but basically what I found was that Cinnamon doesn't like amd drivers, no solution whatsoever...

I tried the latest 13.4 amd proprietary driver, but there is no more transparency. What I mean is that when I use "expo" or the "Workspace switcher", the windows are on a black screen, or conky is on a black background instead of repeating the current background. WIth radeon open source drivers I don't have those problems, but it's running on software rendering mode, that means very slowly and laggy.

Any help would be greatly appreciated, many thanks in advance :wink:

Some infos:

Code: Select all

P8Z77 ~ $ inxi -Gx
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI Tahiti XT [Radeon HD 7970] bus-ID: 01:00.0 
           X.Org: 1.13.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits) GLX Version: 2.1 Mesa 9.1.1 Direct Rendering: Yes

P8Z77 ~ $ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Tahiti XT [Radeon HD 7970]

P8Z77 ~ $ uname -a
Linux P8Z77 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

P8Z77 ~ $ X -version

P8Z77 ~ $ glxinfo | grep rendering
direct rendering: Yes

P8Z77 ~ $ lspci -vk | grep -iA13 vga | grep -i Kernel
	Kernel driver in use: radeon

X.Org X Server 1.13.3
Release Date: 2013-03-07
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
Current Operating System: Linux P8Z77 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.8.0-21-generic root=UUID=81f99157-ca6e-40d1-9ae6-df9527d7efa9 ro quiet splash vt.handoff=7
Build Date: 17 April 2013  10:43:13PM
xorg-server 2:1.13.3-0ubuntu6 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.28.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.

Pustul
Level 1
Level 1
Posts: 5
Joined: Tue Mar 19, 2013 6:31 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by Pustul » Sat May 25, 2013 8:39 am

Nobody has an idea? Or maybe the same problem as me?

aztec
Level 1
Level 1
Posts: 6
Joined: Mon Aug 27, 2012 10:39 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by aztec » Sun May 26, 2013 10:24 am

Hi Pusful,
this probably won't help a bit but I just logged in myself to find out what the 'log-in' option 'software rendering' was all about.
Could it be if you chose another option at 'log-in' that it would sort things out for you. Probably not.
Graphics cards can be a pain.

Pustul
Level 1
Level 1
Posts: 5
Joined: Tue Mar 19, 2013 6:31 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by Pustul » Sun May 26, 2013 6:44 pm

I don't think it has something to do with that because when I install the ati proprietary driver the warning disappear. Yeah graphic card drivers are the worst problem with linux... Even on my laptop which has a nvidia card, there is problems :S

Pustul
Level 1
Level 1
Posts: 5
Joined: Tue Mar 19, 2013 6:31 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by Pustul » Wed May 29, 2013 2:48 pm

Up :wink:

kenter
Level 1
Level 1
Posts: 2
Joined: Fri May 31, 2013 11:39 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by kenter » Fri May 31, 2013 11:45 am

I have the same problem.

I've just installed Mint15 on a Dell Latitude 2120 for my mother to use. If I boot normally into Mint15, the screen goes black and stays black. I can blindly hit Ctrl-Alt-F1, followed by a Ctrl-Alt-Delete to reboot the computer, and at the Grub menu, choose the Rescue option. At the first text-based screen that gives me an option, I can then choose to resume a normal boot, and X starts up as expected, but I get the "Running in software rendering mode" message.

So, Mint15 is useless for my mother, as she's not going to know how to get around these issues. It's a shame, too, because Mint has made it easy to autologin and to turn off the lock-screen, although I still haven't found a way to force the mobile broadband to autoconnect without her input, so that'll be a deal-breaker too, if I can't get that figured out.

/Kent

austincurr
Level 1
Level 1
Posts: 1
Joined: Sat Jun 01, 2013 10:27 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by austincurr » Sat Jun 01, 2013 10:54 am

I also have this problem. Only software rendering and the fallback mode have worked correctly. None of the options for drivers work- neither open-source nor fgrlx (Or however it's spelled) (or fgrlx-updates).

<Basic Info>
Graphics:
Radeon HD 6570
(Specifically, http://www.newegg.com/Product/Product.a ... 6814150580 )

There's also a basic NVIDIA integrated graphics chip but it's disabled through bios at the moment so that's probably not it, right?

Os version:
Mint 15 Cinnamon 64 bit

This seems to be a common problem- at least, I think it is. A computer isn't nearly as usable when its cpu as to do the job of the graphics card. Is this going to be fixed, or are we just *inclined plane wrapped around an axle*ed?

FireSoul
Level 3
Level 3
Posts: 147
Joined: Mon Jan 28, 2013 5:15 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by FireSoul » Sat Jun 01, 2013 1:19 pm

[quote="Pustul"]Hi guys,
I have a problem with Cinnamon, I just installed Mint 15 on my Desktop (with a HD7970) where I usually run only Windows for games, but I mainly use Mint on my laptop for work and I want it on a bigger screen now, But when I boot there is a message of Cinnamon complaining that it's running in software rendering mode, without video hardware acceleration,... I search a lot on Google but basically what I found was that Cinnamon doesn't like amd drivers, no solution whatsoever...

Hello.
I have AMD prosessor and drivers ,all works well.
Be sure your DVD is from Mint sites http://www.linuxmint.com/.
Test with live DVD Linux Mint 15.iso .Start only with DVD and test how movies works and other things,don't install any drivers if all works,only if computer ask to install.
There are drivers from mint on DVD,if problems then ask and tell which your computer 32bit/64bit,memory,drivers.Here are lot of peoples who want help and know many things.

Nice time with Mint for you.

kenter
Level 1
Level 1
Posts: 2
Joined: Fri May 31, 2013 11:39 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by kenter » Mon Jun 03, 2013 10:31 am

I did test it, from a USB thumbdrive (my laptop has no CD drive). It worked fine from the thumbdrive; but once installed to the hard drive, this problem manifested itself.

Cinnamon Version: 1.8.6
Distribution LinuxMint 15 : Olivia (x86-64)
Kernel/Build 3.8.0-19-generic / #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013
Processor Intel Atom CPU N455 @ 1.66GHz x 0
Memory 1.0 GiB
Disk Size 119.1 GB
Graphics Card Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])

aurelian
Level 1
Level 1
Posts: 3
Joined: Mon Jun 10, 2013 5:00 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by aurelian » Mon Jun 10, 2013 5:48 am

Hi
I have the same problem with an Acer aspire s3 intel i5 with intel 4000 hd graphics?
aurelian@aurelian-Aspire-S3-391 ~ $ inxi -Gx
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
X.Org: 1.13.3 drivers: vesa (unloaded: fbdev) FAILED: intel Resolution: 1368x768@0.0hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits) GLX Version: 2.1 Mesa 9.2.0-devel (git-f8df73f raring-oibaf-ppa) Direct Rendering: Yes

CPU usage very high when idle 60-70% and i can only boot in recovery mode?

impuwat
Level 1
Level 1
Posts: 2
Joined: Tue Dec 06, 2011 10:26 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by impuwat » Tue Jun 11, 2013 11:23 pm

Same problem here. Went to see about replacing Fedora on my wife's little laptop. Running live DVD from USB stick. Started up with the same warning screen you guys are talking about. CPU running around 98% according to System Monitor.

Acer Aspire One...Model ZA3

Processor- little Intel Atom 1.33Ghz
Memory- 1 Gig
Integrated graphics

Mark Phelps
Level 7
Level 7
Posts: 1852
Joined: Mon Jun 10, 2013 4:39 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by Mark Phelps » Thu Jun 13, 2013 1:53 pm

impuwat wrote:Same problem here. Went to see about replacing Fedora on my wife's little laptop. Running live DVD from USB stick. Started up with the same warning screen you guys are talking about. CPU running around 98% according to System Monitor.
Have been struggling all day with getting to a desktop from Mint15 LiveUSB. As I don't have one of the NEW AMD cards, I also got the sofware rendering problem.

What worked for me was the following:
1) When the countdown timer starts in the Mint loading screen, press a TAB key
2) That will put the GRUB boot line on screen for editing
3) Tab back over the command line, delete "quiet", replace that with "xforcevesa"
4) Press the Enter key to continue booting

You will see lots of boot progress messages, and in my case, it took over 38 second to finally see the Mint logo -- which appeared gradually in the center of the screen.

But eventually, if this works for you, you should get to a working desktop with no software rendering disclaimer -- and performance should be OK.

nightcap
Level 1
Level 1
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by nightcap » Sun Jun 16, 2013 3:37 am

Same minor irritant here. Hardware includes AMD HD7750 grafx card. Interestingly when one checks Mint's pre-selected system drivers following installation, all appears OK. So this could be as simple as modifying a single boot-up instruction. Will check grub syntax later.

Overall, given recent nasty challenges associated with Gnome 3.8, this is another evolutionary step forward for Cinnamon/Mint. Clean, trim, functional.
inject linux /reject M$

frogy
Level 1
Level 1
Posts: 3
Joined: Sun Jun 16, 2013 11:53 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by frogy » Sun Jun 16, 2013 12:26 pm

I have the same problem -Cinnamon running in software rendering mode- on an Acer aspire 1600 with ATI Radeon 9000. CPU is running at 100% . The strange thing is that when I first booted from the live DVD everything was ok. After the installation and the updates the problem came up. Just from curiosity I try again the live DVD and cinnamon couldn't boot so it came in fallback mode!!! I check the DVD in my other laptop and everything was ok. It is the first time since Felicia that I face a problem that can not be solved :( . I don't want to give up.

User avatar
Llilah
Level 1
Level 1
Posts: 1
Joined: Sun Jun 16, 2013 2:52 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by Llilah » Sun Jun 16, 2013 3:11 pm

I had the same problem. I also have an AMD Radeon Graphic card, but I have my Linux installed in VMware. I fixed it by first opening my VMware, the I selected my Virtual Machine (LinuxMintCinnamon15) then went to the VMware virtual machine settings, then to the display option, I put a check-mark on the 3D graphics option. Launched Linux Mint Cinnamon 15, and Viola!! :D
Last edited by Llilah on Sun Jun 16, 2013 3:26 pm, edited 1 time in total.

nightcap
Level 1
Level 1
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by nightcap » Sun Jun 16, 2013 9:29 pm

No luck with a solution yet. My CPU (quad) cores idle at 30-40%!!! Several questions arise:

1. Has anyone from the Mint Cinnamon 15 development team responded in any way?
2. Has anyone tried either of the two optional Ubuntu AMD fglrx drivers, and found instant success?
3. What is it with apparent lack of AMD grafx support? Wasn't it Nvidia who thumbed their noses at Linux for an eternity? And our beloved founding father, Linus T., certainly had some choice words for Nvidia, didn't he?!!!
4. It also appears other grafx hardware suffers this issue from time to time. How come?
inject linux /reject M$

stem
Level 1
Level 1
Posts: 2
Joined: Sun Jun 16, 2013 5:19 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by stem » Tue Jun 18, 2013 2:11 pm

Experiencing similar problems as above. I have a Samsung RF711 laptop with Nvidia Optimus graphics. Everything worked fine in Mint 14 Cinnamon, now with Mint 15 Cinnamon it's a mess. Nvidia does not seem to work. No X-Server settings in Menu??? Loaded Bumblebee, but then Cinnamon started crashing. Now in software rendering mode. Scoured the web and can find no solutions to this.
A point of interest the device manager sees my Broadcom network card, but nothing for Nvidia?? Any help would be much appreciated? Cheers

nightcap
Level 1
Level 1
Posts: 23
Joined: Mon May 10, 2010 1:10 am

Re: [Mint 15] Cinnamon running in software rendering mode

Post by nightcap » Sat Jun 22, 2013 6:42 pm

Was hoping latest system update would cure this pest. But no. Software rendering message lingering like a bad smell. Awfully quiet from the Mint developers' sandbox end, isn't it? (Must be something to do with Gnome 3.8. Maybe an entire Cinnamon grafx interface has to be re-coded?) :?
inject linux /reject M$

berndvondemberg
Level 1
Level 1
Posts: 3
Joined: Thu Jun 27, 2013 2:16 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by berndvondemberg » Thu Jun 27, 2013 2:30 pm

Same problem over here. I've successfully set up a dual boot system (OS X + LM 15, 64bit) on my MacMini (late 2012, Intel HD4000) employing rEFInd.

Initially I evaluated the LM Live USB (32bit & 64bit) which at that time ran smoothly, i.e. hardware acceleration worked. However, after having decided to install the 64bit version, the hardware acceleration became defunct. I did not do anything post-install besides immediately updating the system (Ironically, this fixed the known Broadcom wireless issue.)
Tried to install the latest Intel drivers following this advice for LM15: [url]http://www.webupd8.org/2013/04/how-to-use-intel-linux-graphics-drivers.html[/url]
Didn't help.

I've tried Manjaro Linux 0.8.6 Cinnamon Edition and Ubuntu 13.04. No hardware acceleration issues here.

Cheers

b7fLuid
Level 1
Level 1
Posts: 1
Joined: Sat Jun 29, 2013 2:00 pm

Re: [Mint 15] Cinnamon running in software rendering mode

Post by b7fLuid » Sat Jun 29, 2013 2:09 pm

Hey guys,

I just installed Mint15, but I'm having the same problems as you guys.

My system specs:
Intel I7875K
AMD 7850
8gb Ram

I should've suspected that I would run into problems since the LiveUSB I used gave me the "Running in software rendering mode" message when testing it.

I'm kinda dissappointed cause I heard that Mint was a breeze to use. I've used Ubuntu on a number of occasions but like the Mint setup since it closely resembles Windows.

Are earlier versions of Mint experiencing the same issues?

Locked

Return to “Cinnamon”