No wifi since the last update

Archived topics about LMDE 1
Forum rules
dzsobacsi
Level 1
Level 1
Posts: 7
Joined: Thu Jun 28, 2012 9:57 am
Location: Frankfurt, Germany

No wifi since the last update

Postby dzsobacsi » Mon Jun 24, 2013 3:49 am

Dear All,

Since I have updated the computer of my wife there is no wireless connection available. Last update contained also a kernel upgrade from 3.2 to 3.9. (Can it cause this problem?) There is a BCM4313 wireless card in there.

Now, if I boot the new kernel the inxi -N shows that no driver has been loaded for the wireless card at all.

Code: Select all

Network:   Card-1 Broadcom BCM4313 802.11b/g/n Wireless LAN Controller BusID: 44:00.0
           Card-2 Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI at port 2000 BusID: 45:00.0


I have tried to load a driver manually with "modprobe wl" then I get the following error message:

Code: Select all

root@rita_hp:/etc/apt# modprobe wl
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='wl'
ERROR: could not insert 'wl': Function not implemented
libkmod: ERROR ../libkmod/libkmod-module.c:925 command_do: Error running install command for wl
ERROR: could not insert 'wl': Operation not permitted


If I boot the old kernel, then wireless works properly and the driver called "wl" is used.

Any idea, how to resolve this?
Last edited by dzsobacsi on Mon Jun 24, 2013 3:09 pm, edited 1 time in total.

kurotsugi
Level 6
Level 6
Posts: 1056
Joined: Fri Jan 25, 2013 3:54 am

Re: No wifi since the last update

Postby kurotsugi » Mon Jun 24, 2013 3:08 pm

I'm currently using liquorix kernel and it seems that it tends to more stable than debian's kernel. you might want to try it.


Return to “Archive”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests