irritating loss of permissions

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Fri Jun 28, 2013 12:17 am

irritating loss of permissions

Postby billollib » Fri Jun 28, 2013 12:30 am

I am running the KDE version of Linux Mint 14. Uname -a returns Linux mybox 3.5.0-34-generic #55-Ubuntu SMP Thu Jun 6 20:18:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

It worked great when installed, but a few days ago, after doing apper- recommended upgrades (there were a zillion of them, so I don't remember which they were), I started getting a bunch of errors. These include:

I no longer can attach to networks or manage connections using the KDE network applet as a user. The error I get is that I have "insufficient privileges." If I do it from the command line using sudo nmcli, I connect fine. I installed the gnome nm-applet and can connect using it *only* if I run it as "sudo nm-applet" but not if I run it with user privileges.

Similarly, Apper no longer works, stating that I do not have sufficient authorization to install software, though sudo apt-get works fine. When I open a new Konsole, I get the following repeated multiple times: "complete: usage: complete [-abcdefgjksuv] [-pr] [-DE] [-o option] [-A action] [-G globpat] [-W wordlist] [-F function] [-C command] [-X filterpat] [-P prefix] [-S suffix] [name ...]" though the prompt eventually comes up fine.

This happened once before, and I threw up my hands and re-installed from scratch -- and it went away for awhile.

Any pointers?

Level 5
Level 5
Posts: 779
Joined: Wed Jul 11, 2012 4:10 pm

Re: irritating loss of permissions

Postby trapperjohn » Fri Jun 28, 2013 9:46 am

Is it possible that your user was set to a "standard" user rather than an "administrative" user at some point? A standard user is not, by default, a sudoer.

Return to “Other topics”