[How to] change numlock default behaviour to 'on' at logon

Archived topics about LMDE 1
Forum rules
Bisto
Level 1
Level 1
Posts: 24
Joined: Tue Mar 26, 2013 7:41 am

[How to] change numlock default behaviour to 'on' at logon

Postby Bisto » Sat May 11, 2013 9:22 am

Hi all,
I believe this has been covered before, but I thought I would do a quick one to help others do what I finally got around to bothering with today.

In order to set your install so that your numlock defaults to on, in LMDE with Cinnamon (and quite a few other distros) you will have to install a command (numlockx)
Do this:

Code: Select all

sudo apt-get install numlockx

next you will want to set this to autorun on boot - to do this, open your menu, and type 'start' then select 'Startup Applications'
-Click on 'Add'
-in the box next to 'command' paste in the following:

Code: Select all

/usr/bin/numlockx on

-fill in the rest of the boxes with whatever you want, here's my example:
Image
-Press 'save' then close the main window.

You're all done :)
Last edited by Bisto on Sat May 11, 2013 10:04 am, edited 1 time in total.

User avatar
killer de bug
Level 13
Level 13
Posts: 4677
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: [How to] change numlock default behaviour to 'on' at boo

Postby killer de bug » Sat May 11, 2013 9:45 am

Does this method enable numlock during login or after, when the desktop is loaded ?
I prefer this version, that way I can type my password with numbers, without any problem during the login in MDM.

After installing numlockx :

sudo gedit /etc/mdm/Init/Default


At the top of the file, just under the comments, add :

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi
Image
If it ain't broke, fix it until it is.

Bisto
Level 1
Level 1
Posts: 24
Joined: Tue Mar 26, 2013 7:41 am

Re: [How to] change numlock default behaviour to 'on' at boo

Postby Bisto » Sat May 11, 2013 10:03 am

I believe that my way would set the numlock during logon, as opposed to boot. I will change the title accordingly - nice one :)

stilloving
Level 1
Level 1
Posts: 5
Joined: Sat Jun 29, 2013 7:52 am

Re: [How to] change numlock default behaviour to 'on' at log

Postby stilloving » Sat Jun 29, 2013 8:09 am

This method enable numlock during login and after login, so you have the numlock always ON in your LINUX MINT and LMDE

1) FIRST, install numlockx : sudo apt-get install numlockx

2) SECOND, go to menu and type startup application and opent it.

3) Click on +add

4) On "Name" put NUMLOCK ON

5) On "Command" put /usr/bin/numlockx on

6) Click on "+add" and "close" .


7) Go to /etc/mdm/Init/ and edit Default

8) Add before exit 0 these lines:

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


Just restart your computer and next time you turn on it you have Numlock On always.


Stilloving from Argentina, Buenos Aires

User avatar
killer de bug
Level 13
Level 13
Posts: 4677
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: [How to] change numlock default behaviour to 'on' at log

Postby killer de bug » Tue Jul 02, 2013 4:12 pm

Thank you for repeating exactly what was written earlier. Very Very useful... :roll:
Image
If it ain't broke, fix it until it is.

User avatar
DrHu
Level 17
Level 17
Posts: 7560
Joined: Wed Jun 17, 2009 8:20 pm

Re: [How to] change numlock default behaviour to 'on' at log

Postby DrHu » Tue Jul 02, 2013 4:30 pm

I set my number lock in the BIOS and the Linux OS didn't change that
--OK, maybe its my version ? (lmde 13..)

vksteff
Level 1
Level 1
Posts: 6
Joined: Fri Aug 02, 2013 11:53 am

Re: [How to] change numlock default behaviour to 'on' at log

Postby vksteff » Wed Aug 07, 2013 5:20 am

stilloving

Ater i reboot the numlock was off,

have you an ide what its wrong?

User avatar
killer de bug
Level 13
Level 13
Posts: 4677
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: [How to] change numlock default behaviour to 'on' at log

Postby killer de bug » Wed Aug 07, 2013 5:59 am

Follow my first post in this topic. Don't create a start up application please.

edit : are you using mdm ? or gdm or... ?
Image
If it ain't broke, fix it until it is.

vksteff
Level 1
Level 1
Posts: 6
Joined: Fri Aug 02, 2013 11:53 am

Re: [How to] change numlock default behaviour to 'on' at log

Postby vksteff » Wed Aug 07, 2013 6:09 am

killer de bug

Im new....

Then i save it and reboot its gone, like i dont write it.

i have use sudo for edit..

nswearin
Level 1
Level 1
Posts: 2
Joined: Sat Oct 04, 2014 1:39 am

Re: [How to] change numlock default behaviour to 'on' at log

Postby nswearin » Sat Oct 04, 2014 2:18 am

One using LinuxMint 17, cinnamon not sure of other specifics, can simply search software manager for numlockx, install it and then check the "enable numlock" box in Login window preferences

step 1: menu > administration > software manager > (enter password for admin user) > then search and install numlockx
step 2: menu > administration > login window > (enter password for admin user) > options > check the "enable numlock" box

to me that was easiest method :D (yes typing my password twice was annoying but hey it worked :) )

johnniedoo
Level 1
Level 1
Posts: 48
Joined: Sun Jun 15, 2014 4:33 pm
Location: USA, NYC,NOLA,CT

Re: [How to] change numlock default behaviour to 'on' at log

Postby johnniedoo » Mon Oct 06, 2014 1:00 pm

I am a very new Linux(mint17-mate mostly) and in MATE
I do the above terminal numlockx install, then i go to the 'Appearance"
app and under 'options' the number lock enable is no longer dim
i just check to enable number lock or uncheck to disable.
But, it took me a while to figure out why the numlock check box was dimmed out
no numlockx applet comes up with the bin command , but the numlock check box is live


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest