cs46xx and coaxial

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Wed Jul 10, 2013 9:21 am

cs46xx and coaxial

Post by zagor.fp » Tue Jul 16, 2013 12:22 pm

Dear all,

my pc has an old Ubuntu Lucid 10.04 64bit installed but I've recently decided to change to something newer.
Unfortunately all distros I've tried have the same audio issue.
Besides the onboard audio, I have a quite old Hercules Game Theater XP, very nice and working fine on Lucid and before or on other distro, including the first mint editions up to mint10.
Unfortunately it seems the new distros do not ship with the CS46xx firmware.
The best result achieved so far was on a Mint Debian 2013 (LMDE): after following the debian guide http://wiki.debian.org/snd-cs46xx I have sound but not completely: the small desk speakers connected directly to the GameTheater box work, but the coaxial output does not.
I use a coaxial cable out from the sound card to a DAC converter eventually reaching the stereo amplifier.
My guess is that the coaxial output does not work with this firmware.
alsamixer shows all available volume sliders high and unmuted.
Google and the forums seem not to help.

Kernel is 3.2.0-4-amd64 and the audio part is:

Code: Select all

$ inxi -Axc 0
Audio:     Card-1 Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] BusID: 05:04.0
           Card-2 NVIDIA CK804 AC'97 Audio Controller driver snd_intel8x0 at ports dc00 e000 BusID: 00:04.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Any suggestions?


Level 1
Level 1
Posts: 2
Joined: Wed Jul 10, 2013 9:21 am

[SOLVED] cs46xx and coaxial

Post by zagor.fp » Thu Aug 08, 2013 1:06 pm

Ok, done.
On LinuxMint LMDE freshly installed I had to follow the debian wiki, but the sliders for the digital output were not present in alsamixer.
Reading a lot a posts, I've got the hint that maybe the kernel was not compiled with the proper parameters, therefore I tried to go back from the 3.2.0-4-amd64 std Mint LMDE kernel, to an old 2.6 as my old Ubuntu.
Not easy.
I've found instead a pre-compiled [url=http://extonlinux.wordpress.com/2013/05/06/install-the-latest-kernel-3-9-for-ubuntudebian-64bit-systems/]3.9 kernel done in "the ubuntu way" by mr Exton[/url].
Installed, rebooted and the digital is there!
1. install alsamixer (gnome-alsmixer for a nice and complete GUI)
2. enable the IEC958 sliders in alsamixer
3. go in the system sound preferences and select the "digital duplex output"

It might be an issue with 3.2.0 kernel or maybe a Mint LMDE issue, but the 3.9.0 kernel works!

So, my most humble yet highly grateful thanks to mr. Exton!!!

Post Reply

Return to “Sound, Multimedia, & Codecs”