(How to) open Libreoffice documents over a network

Archived topics about LMDE 1
Forum rules
Level 4
Level 4
Posts: 265
Joined: Thu Apr 19, 2012 9:59 am

(How to) open Libreoffice documents over a network

Postby dclement » Tue Sep 03, 2013 12:00 pm


This week I struggled a bit to open a document on my network (a NAS device) with Libreoffice. This doesn't work OOTB (you get a "file corrupt" error and your file never opens).

I found pieces of solution in various places, and none on this forum. So I thought it could be useful to describe how I solved that issue:

1) Install the gvfs-fuse package;

2) Add the user to the fuse group;

3) Logout and login again (I suppose it would be enough to restart the fuse daemon?);

4) Modify the user's rights for ~/.gvfs to rw/rw/r.

That's it. A few comments:

* Why isn't step 1 done by default? (gvfs-fuse could be installed as a samba dependency)?
* Without 2) and 3) you can't do 4) even as root. Same question.
* Sadly this workaround seems broken in Libreoffice 4.1 (mine is 4.0.3), but I was able to test it under XFCE and Mate as well.

HTH, Daniel

Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: (How to) open Libreoffice documents over a network

Postby cwsnyder » Sat Sep 07, 2013 9:17 am

That sounds more like an error with your NAS device rather than with LibreOffice, networking, or documents. gvfs as I have seen it used was more for connecting iOS or Android devices with MTP (Media Transfer Protocol) connections over USB.

I think you will have to provide much more information about your NAS device before anyone could help you. Since you call it an NAS device, is it connected wireless or over wired Ethernet? If it is connected over USB, then technically it is not an NAS device. Is it designed to connect via SAMBA share, NFS, or other protocol? Did you try any of the specific gvfs settings/programs for the specific type of share (reference man gvfs)?
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

Level 4
Level 4
Posts: 265
Joined: Thu Apr 19, 2012 9:59 am

Re: (How to) open Libreoffice documents over a network

Postby dclement » Sat Sep 07, 2013 10:53 am


I was not asking help here, it's solved for me! I was just trying to help others who might have faced the same issue.

My NAS are very basic Synology, I have 3 of them, 2 ethernet and one wifi, all 3 exhibit the same behavior. They use Samba.

It's definitely a Libreoffice issue. No other app (gedit, gimp, firefox, ...) has any trouble opening or saving a file over the network.

It's so widely known it's been called a Libreoffice MAB (Most Annoying Bug)!

Now, I can just tell is seems related in some way to a strange (abnormal) behavior of the .gvfs folder in a default LMDE install:
* Take a default install (I tried XFCE and Mate);
* Mount any Samba share (e.g., browsing your network in Thunar or Caja);
* Take a look at your ~/.gvfs: it's empty. It shouldn't.

Libreoffice is the only app I know of which is disturbed by that.

If you go through steps 1) to 4) from my 1st post, your Samba shares neatly appear in the .gvfs folder. You can open and save with Lobreoffice again.

Now, I'm not explaining anything, I just wanted to sum up pieces of solution which I found scattered on various sites.

Best regards, Daniel

Return to “Archive”