paquete roto libc6

Spanish Forum

Moderators: hatteras, jcsenar

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

paquete roto libc6

Postby baenaremoto » Sat Nov 09, 2013 9:58 am

En synaptic me da paquete roto: libc6 versión actual 2.15 Oubuntu20.1 nueva versión 2.15 Oubuntu20.2.

Tengo Linux Mint 14 (nadia) Cinnamon32 bit.

Creo que la versión de libc6 que tengo no corresponde con la version de LM14, al parecer instalé manualmente la versión vieja sobre la nueva y ahora me da mensaje de paquete roto. No se arregla desde synaptic

Si pongo en terminal: sudo aptitude reinstall libc6
obtengo:
A copy of the C library was found in an unexpected directory:
'/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: error al procesar /var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb (--unpack):
el subproceso script pre-installation nuevo devolvió el código de salida de error 1
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
/var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:

¿Cómo solucionarlo? Gracias por vuestra ayuda

User avatar
hectorsales
Level 4
Level 4
Posts: 293
Joined: Sun Jul 07, 2013 3:25 am

Re: paquete roto libc6

Postby hectorsales » Sat Nov 09, 2013 11:21 am

Prueba los siguientes comandos:

Code: Select all

sudo apt-get install libc6



Code: Select all

sudo dpkg --configure -a


(Para reconfigurar los repositorios para solucionar paquetes rotos).

Code: Select all

sudo apt-get -f install


(Resuelve problemas con dependencias).

A ver si funciona uno u otro.

Un Saludo. :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Sat Nov 09, 2013 1:58 pm

Mantenemos el error.

Gracias por el aporte.

User avatar
hectorsales
Level 4
Level 4
Posts: 293
Joined: Sun Jul 07, 2013 3:25 am

Re: paquete roto libc6

Postby hectorsales » Sat Nov 09, 2013 5:49 pm

Prueba a borrar el paquete .deb que da el error:

Code: Select all

sudo rm /var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb


Saludos.
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Sat Nov 09, 2013 7:16 pm

Hector seguimos igual.

Agradezco tu ayuda, haber si logramos encontrar una solución.

si tecleo en la terminal: sudo apt-get -f install

da la siguiente salida:
Preparando para reemplazar libc6:i386 2.15-0ubuntu20.1 (usando .../libc6_2.15-0ubuntu20.2_i386.deb) ...

A copy of the C library was found in an unexpected directory:
'/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: error al procesar /var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb (--unpack):
el subproceso script pre-installation nuevo devolvió el código de salida de error 1
Se encontraron errores al procesar:
/var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

User avatar
hectorsales
Level 4
Level 4
Posts: 293
Joined: Sun Jul 07, 2013 3:25 am

Re: paquete roto libc6

Postby hectorsales » Sun Nov 10, 2013 5:09 am

Hola vamos a intentarlo con esto:

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb


Después vuelve a ejecutar:

Code: Select all

sudo apt-get -f install


A ver si funciona.. :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Sun Nov 10, 2013 2:35 pm

Seguimos igual

Preparando para reemplazar libc6:i386 2.15-0ubuntu20.1 (usando .../libc6_2.15-0ubuntu20.2_i386.deb) ...

A copy of the C library was found in an unexpected directory:
'/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: error al procesar /var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb (--unpack):
el subproceso script pre-installation nuevo devolvió el código de salida de error 1
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
/var/cache/apt/archives/libc6_2.15-0ubuntu20.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Gracias por el intento..... seguimos probando soluciones.

nestoriano
Level 4
Level 4
Posts: 332
Joined: Thu Nov 08, 2012 7:15 pm

Re: paquete roto libc6

Postby nestoriano » Tue Nov 12, 2013 6:18 pm

Prueba con Synaptic que hay una opcion para "forzar version".
Me ha salvado en varias ocaciones cuando algun paquete "nuevo" me ha dado problemas y no podia instalar el paquete original.

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Sun Nov 17, 2013 7:51 am

Sigue sin funcionar. Sinaptic no arregla el paquete roto.

User avatar
hatteras
Level 8
Level 8
Posts: 2361
Joined: Fri Sep 24, 2010 6:43 pm

Re: paquete roto libc6

Postby hatteras » Wed Nov 20, 2013 7:04 am

A copy of the C library was found in an unexpected directory:
'/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

Una copia de la librería esta en un directorio inesperado
'/lib/i386-linux-gnu/libc-2.15.so'
no es seguro actualizar la librería en esa situación
borre la copia de la librería o sáquela de
'/lib/i386-linux-gnu' e intente de nuevo ( instalar el paquete roto libc6 )

Pues, eso, que borres el archivo que esta en el directorio /lib/i386-linux-gnu/libc-2.15.so
e intentes de nuevo actualizar el paquete roto libc6
Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

http://hatteras-blog.blogspot.com.es/

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Wed Nov 20, 2013 3:29 pm

Borré el fichero.

Ahora no me funciona nada...
Que hago.... Por favor ayuda.

andres338
Level 1
Level 1
Posts: 1
Joined: Thu Nov 21, 2013 7:49 am

Re: paquete roto libc6

Postby andres338 » Thu Nov 21, 2013 8:10 am

A mi me pasa lo mismo en LM 13, borre la librería libc6 para poder actualizarla y no funciono más nada. Lo que hice fue bajar nuevamente el instalador de LM 13 desde otra máquina y luego lo grabé en un DVD y en mi equipo inicie con el DVD el S.O . y copie el archivo libc6 en el lugar donde estaba. Y luego arrancó el sistema. Pero sigo con el error de actualización del mismo paquete y no lo puedo solucionar.
Saludos.

User avatar
hectorsales
Level 4
Level 4
Posts: 293
Joined: Sun Jul 07, 2013 3:25 am

Re: paquete roto libc6

Postby hectorsales » Sat Nov 23, 2013 4:00 am

Hola, el paquete que os da el error al haber actualizado, se ha actualizado a través del gestor de actualizaciones o a través de algún paquete que habéis instalado...o realmente ¿Cómo lo habéis hecho?

Saludos.. :wink:
Linux Mint 17.1 LTS Rebecca Cinnamon x86_64

User avatar
hatteras
Level 8
Level 8
Posts: 2361
Joined: Fri Sep 24, 2010 6:43 pm

Re: paquete roto libc6

Postby hatteras » Sat Nov 23, 2013 7:09 am

Hay varias formas de controlar los paquetes que se instalan y desinstalan

Paquetes instalados/desinstalados con Synaptic ( o con apt-get ): En el directorio /root/.synaptic/log/ se crean archivos con el formato fecha.numero.log ( es decir, por ejemplo /root/.synaptic/log/2009-06-24.195504.log ) con información sobre los paquetes instalados y/o desinstalados con synaptic en dicha fecha

Paquetes instalados/desinstalados con Aptitude: Al ejecutar aptitude para instalar y/o desinstalar paquetes, se crea un archivo de registro de dichos programas en /var/log/aptitude ( o aptitude.gz).

Para obtener una lista de los paquetes instalados que tenemos en nuestro pc: procederemos ejecutar lo siguiente en una Terminal:
$ dpkg --get-selections | grep -v deinstall > ubuntu-files
Esto nos genera en /usuario/home un archivo llamado ubuntu-files, el cual contiene la lista que deseamos.

http://hatteras-blog.blogspot.com.es/20 ... ue-se.html
Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

http://hatteras-blog.blogspot.com.es/

baenaremoto
Level 1
Level 1
Posts: 7
Joined: Sat Nov 09, 2013 9:48 am

Re: paquete roto libc6

Postby baenaremoto » Sun Nov 24, 2013 4:13 am

Arreglado, reintalando sistema y salvando antes la configuración.

Gracias a todos por vuestros comentarios.

SOLUCIONADO


Return to “Español (Spanish)”

Who is online

Users browsing this forum: No registered users and 2 guests