Linux Mint 15 KDE and time synchronization

Forum rules
Before you post please read how to get help
tannhaus
Level 1
Level 1
Posts: 7
Joined: Sun Jun 23, 2013 9:26 pm

Linux Mint 15 KDE and time synchronization

Post by tannhaus »

If you click on adjust date and time and select to get date and time via NTP, it will not connect. I uninstalled ntpdate and installed ntp. Still no luck. I am in central time zone so even if I have the correct time set up, KDE adds 6 hours to the time thinking it's UTC when it can't connect.

Once checked and it can't connect, it no longer shows a checkmark under get the date and time via ntp but it still continues to try to do so. Every 10 minutes or so, it messes up the time I set manually by adding 6 hours.

This is really a dealbreaker for me if the system can't even keep the correct time. Ill have to stick with opensuse that doesn't have problems like this.

phill1978
Level 3
Level 3
Posts: 176
Joined: Fri Apr 22, 2011 5:19 am

Re: Linux Mint 15 KDE and time synchronization

Post by phill1978 »

does opensuse use KDE? because i have opensuse on gnome 3 on a partition and gnome 3 isnt very nice at all, hate the lack of minimize buttons for a start.

i also had a UTC issue and tempromental network issue in KDE 15.

I would log it as a bug if i were you, i wont as ive logged too many recently and i usually get a snotty reply from someone telling me i haven't supplied enough information

tannhaus
Level 1
Level 1
Posts: 7
Joined: Sun Jun 23, 2013 9:26 pm

Re: Linux Mint 15 KDE and time synchronization

Post by tannhaus »

I tried to and it looks like a couple hundred people have done so for years. It's still not fixed.

OpenSUSE has KDE as the default. It's extremely polished and works perfectly. I wanted to try Mint because it's so popular.

xox101
Level 2
Level 2
Posts: 93
Joined: Sat Jan 29, 2011 7:34 pm

Re: Linux Mint 15 KDE and time synchronization

Post by xox101 »

Same clock problem here and what's worse when the clock goes wrong in Mint KDE it messes up the clock in the bios which in turn makes the clock wrong in my Windows 8 partition. It is small stupid problems like this that keep me going back to Windows.

tannhaus
Level 1
Level 1
Posts: 7
Joined: Sun Jun 23, 2013 9:26 pm

Re: Linux Mint 15 KDE and time synchronization

Post by tannhaus »

OpenSUSE doesn't have that problem at all. I don't understand why Linux Mint does. If they did something to fix it for SUSE, then fix it for Mint.

cordycep
Level 1
Level 1
Posts: 1
Joined: Fri Jun 28, 2013 1:17 am

Re: Linux Mint 15 KDE and time synchronization

Post by cordycep »

Same here, though I didn't have this problem with Mint 14 KDE. No matter what I tried, it would always reset the date to UTC time (four hours ahead for me). Disabling ntpd did nothing. When I would reboot the computer, as soon as I connected to the Internet the clock would mess up again. Finally I was able to fix it by logging in as root and changing the clock settings, editing some NTP info in a file, and then changing the BIOS back to the right time.

One very strange thing I noticed was, after changing to the correct time (when I wasn't logged in as root), the computer would instantly start to lag a little. Everything would have about a second of delay. This would continue until after a reboot and after the clock would reset to UTC time, so there's definitely some problem here.

One thing I noticed is, when you aren't in as root, the "set date and time automatically" option isn't checked in the clocks settings. However when you are logged in as root, it is checked.

User avatar
anandrkris
Level 5
Level 5
Posts: 944
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Linux Mint 15 KDE and time synchronization

Post by anandrkris »

Code: Select all

sudo dpkg-reconfigure tzdata
Typing this in terminal has solved the issue in past. Hope this helps.
More http://forums.linuxmint.com/viewtopic.php?f=56&t=128331&hilit=clock
Cheers,
If there is a drive, there will be a path

tannhaus
Level 1
Level 1
Posts: 7
Joined: Sun Jun 23, 2013 9:26 pm

Re: Linux Mint 15 KDE and time synchronization

Post by tannhaus »

It solves the problem for about 10 minutes. Then, the system does the same thing again and you have to run it several times the second time to get it to take. KDE still can't connect to set the time via ntp either. It will not connect.

I'm getting the feeling that KDE Mint is the wicked stepchild.

UPDATE: It appears to hold the time as long as I do not try to get the time via ntp or do anything with it.

eyemeansit
Level 1
Level 1
Posts: 7
Joined: Mon Mar 16, 2009 5:20 am

Re: Linux Mint 15 KDE and time synchronization

Post by eyemeansit »

Same problem here

tannhaus
Level 1
Level 1
Posts: 7
Joined: Sun Jun 23, 2013 9:26 pm

Re: Linux Mint 15 KDE and time synchronization

Post by tannhaus »

Well, I hate to say it, but I wiped mint and installed kubuntu. It appears to have a bit more polish than mint.

negora
Level 1
Level 1
Posts: 10
Joined: Tue Dec 06, 2011 1:43 pm

Re: Linux Mint 15 KDE and time synchronization

Post by negora »

I also suffered from the same problem after installing this version. There was an offset of 2 hours backwards when the clock was updated via NTP. I suspected that it had something to do with the time zone, even though it had been properly set using the KDE system settings.

So I decided to read a little about the matter. I wanted to configure the time zone via the command line to find out if it was a problem of KDE or not. I read that, to do so, you must create a soft link called /etc/localtime that points to one of the existing time zone files of the system, which are located at /usr/share/zoneinfo/ .

For example, for Europe/Madrid, I did this:

Code: Select all

ln -sf /usr/share/zoneinfo/Europe/Madrid /etc/localtime
This solved the issue.

The soft link that existed before pointed to an non existing file. In my case the wrong path was ../posix/Europe/Madrid . Obviosuly, this file doesn't exist, and I believe that's the cause.

Do we need to open a bug report?

pvonbert
Level 1
Level 1
Posts: 1
Joined: Mon May 09, 2011 1:18 pm

Re: Linux Mint 15 KDE and time synchronization

Post by pvonbert »

the code yoiu suggest works,

Code: Select all

ln -sf /usr/share/zoneinfo/Europe/Madrid /etc/localtime
but still does not address the problem that NTP is not working. If you try to use the 'Date & Time - KDE Control Module' and click on 'Set date and time automatically' it does not read /etc/ntp.conf file with the correct time servers but the (probably internal) default pool.ntp.org and gives the error message that it cannot connect.

negora
Level 1
Level 1
Posts: 10
Joined: Tue Dec 06, 2011 1:43 pm

Re: Linux Mint 15 KDE and time synchronization

Post by negora »

KDE uses the file /etc/kde4/kcmclockrc . If you check it, you will see that the NTP servers listed in it correspond to those that are shown in the Date & Time module of the System Settings.

User avatar
jgagnon
Level 1
Level 1
Posts: 11
Joined: Thu Jun 06, 2013 1:16 pm

Re: Linux Mint 15 KDE and time synchronization

Post by jgagnon »

I realize this is an old thread but I also had this issue and tried every fix here without success.

What I did to actually fix it on my LM 15 KDE install was right-click on the time in the system tray and select Digital Clock Settings. In the dialog that came up I then selected Time Zone on the left and picked my correct time zone and unchecked UTC. Sanity returned to my system.

Setting the time zone from the console did not do the trick but setting it this way did. No clue why but hopefully this will help someone else.

Cerule

Re: Linux Mint 15 KDE and time synchronization

Post by Cerule »

For me the earlier mentioned "sudo dpkg-reconfigure tzdata" seems to do the trick.

Dracos
Level 1
Level 1
Posts: 9
Joined: Mon Aug 23, 2010 3:49 pm

Re: Linux Mint 15 KDE and time synchronization

Post by Dracos »

I've been having time issues also. After coming to this thread, I decided to check what /etc/localtime was symlinked to. Turns out it was dead:

Code: Select all

$ ll /etc/localtime
lrwxrwxrwx   2 root   root      18 Sep  9 12:47 localtime -> ../SystemV/MST7MDT
I symlinked it to /usr/share/zoneinfo/America/Denver and witin seconds KDE updated to show the correct times. FWIW, I had also made this change in /etc/default/rcS (but hadn't rebooted):

Code: Select all

UTC=no
I didn't reboot the entire time (14 months, I think) I ran Lisa, so we'll see how long this lasts.

Ian Clarke
Level 2
Level 2
Posts: 81
Joined: Wed Nov 03, 2010 5:29 am

Re: Linux Mint 15 KDE and time synchronization

Post by Ian Clarke »

Thanks for this solution, it was driving me nuts !
It's obviously a minor oversight but a small thing like the clock displaying the wrong time can lead to all sorts of problems, especially if you rely on it. Mine was only 1 hour fast butI had no way of knowing it had altered and 1 hour is fairly easy to overlook untill it is too late. It seemed to keep the correct time for a few hours but would change without me noticing.

I agree with others, this very minor issue could be a deal breaker for some new users who might think that if Linux can't tell the correct time then it's useless. I have been a Linux user for a good few years so I relised that there was a solution which would be a simple fix but I spent over 1 week trying to sort it out myself, it didn't matter which timezone I selected in Digital Clock Settings, it always reverted, the Bios Time was also affected and changing that made no difference. UTC could not connect and the only way I could get a reliable time displayed on screen was to use a separate browser window with a clock on it and that was saying that my clock was 1 hour fast !
Really confusing ! :roll:

phill1978
Level 3
Level 3
Posts: 176
Joined: Fri Apr 22, 2011 5:19 am

Re: Linux Mint 15 KDE and time synchronization

Post by phill1978 »

I hope they fix this for Mint 16 !

i used the fix it seems to work for the moment but you shouldnt have this issue.

i had to install a firefox clock addon !! :roll:

MishaSherpa

Re: Linux Mint 15 KDE and time synchronization

Post by MishaSherpa »

same problem. Went back to LM14KDE

User avatar
obreel
Level 1
Level 1
Posts: 9
Joined: Fri Nov 01, 2013 8:57 am

Re: Linux Mint 15 KDE and time synchronization

Post by obreel »

Greetings,

I had the same problem open a terminal as root then enter:

Code: Select all

sudo dpkg-reconfigure tzdata


Then adjust to your local time zone instead of UTC. :wink:
B Reale

Remember, you are unique...just like everyone else!

Post Reply

Return to “KDE”