No thumbnails at all in Nemo 2.08

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
solar1951
Level 4
Level 4
Posts: 275
Joined: Wed Oct 03, 2007 4:14 am
Location: France

No thumbnails at all in Nemo 2.08

Post by solar1951 »

Mint 13 LTS plus Nemo 2.08 from backports.
This is becoming important now as I have a large number of photos and without the thumbnails it is getting frustrating to use Nemo.
I have obviously set thumbnails to be displayed in preferences and increased the file size to max - 4 Gb but no thumbnails are displayed.
Not pdf files, jpeg files, png files, avi files, mpeg files etc etc
It was OK with nautilus as the file manager but Nemo refuses to co-operate.
So what to do next apart from dumping Mint after many years ?
This is a plea for assistance.
Thanks
User avatar
karlchen
Level 21
Level 21
Posts: 13809
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: No thumbnails at all in Nemo 2.08

Post by karlchen »

Hello, solar1951.

Might be the solution/workaround has been posted in the blog comments about "Petra backports available in Linux Mint 13" => here (post #100) <=

Cheers,
Karl
Last edited by karlchen on Sat Jan 18, 2014 5:52 pm, edited 1 time in total.
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Seaside Rendezvous
solar1951
Level 4
Level 4
Posts: 275
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Re: No thumbnails at all in Nemo 2.08

Post by solar1951 »

Hi Karl,
Well I tried that with symlinks etc and can now get thumbnails BUT I for all the photos I have I need to view them in the default viewer before the thumbs are created. This will take ages. Is there no way to run a batch job to thumbnail all items in a folder and subfolders ?

This is plain madness !
User avatar
karlchen
Level 21
Level 21
Posts: 13809
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: No thumbnails at all in Nemo 2.08

Post by karlchen »

Hello, solar1951.

I do not quite understand the problem which you have with the process of creating thumbnails:
I followed the given piece of advice and created the ~/.thumbnails symlink pointing to ~/.cache/thumbnails.
I deliberately removed all existing thumbnails from ~/.cache/thumbnails.
Then I visited ~/Pictures with Nemo, view mode "icons".
During the first visit the thumbnails in ~/.cache/thumbnails were recreated. This was to be expected. So the first visit of Nemo in a folder holding images will take some time to create thumbnails.
Then I closed Nemo and opened it again and navigated to ~/Pictures. This time Nemo was pretty quick to display the cached thumbnails for all image files in the folder.
So where is the problem?
Creating thumbnails for a dozen files was fast. Creating thumbnails for a few hundred image files will be considerably slower and take more time. Yet, I do not see any way around it. And I do not quite see why you should have to view all image files in an external image viewer first. I did not do so.
You may have to check the Nemo settings under Preferences => Preview. Perhaps you have switched of creating thumbnails completely or restricted the filesize to rigidly?

Kind regards,
Karl
Last edited by karlchen on Sat Jan 18, 2014 10:36 am, edited 1 time in total.
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Seaside Rendezvous
solar1951
Level 4
Level 4
Posts: 275
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Re: No thumbnails at all in Nemo 2.08

Post by solar1951 »

karl,
I have found the error I made. I followed the post later in the link you gave (post 153) which in fact reversed the symlink properties.
Having made the symlink as explained in your post above it now seems to work OK.

Many thanks for your patience.

Bill
User avatar
karlchen
Level 21
Level 21
Posts: 13809
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: No thumbnails at all in Nemo 2.08

Post by karlchen »

Hi, Bill.

Glad to earn that the piece of advice which I pointed you to worked in the end. :-)
In order not to confuse any future readers the post number #100 has been added to that link.

Cheers,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Seaside Rendezvous
libregeek
Level 1
Level 1
Posts: 3
Joined: Mon Jun 04, 2012 3:20 am

Re: No thumbnails at all in Nemo 2.08

Post by libregeek »

The second answer in the following link worked for me in Cinnamon-2.4.6 and Nemo-2.4.4:

http://askubuntu.com/questions/395911/w ... thumbnails
Post Reply

Return to “Cinnamon”