Single external hard drive is mounting TWICE [solved]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
aneurysm1985
Level 2
Level 2
Posts: 93
Joined: Sun Sep 13, 2009 6:28 am
Location: Australia

Single external hard drive is mounting TWICE [solved]

Post by aneurysm1985 » Tue Feb 18, 2014 6:31 pm

Hopefully this is a simple question for someone here.

I have used gparted to label a partition of a 1TB external hard drive "Stu_external_1TB".

The problem is that the hard drive seems to be mounting in two locations via Linux Mint. It is appearing here:

/media/stuart/Stu_external_1TB (when I double-click this icon in nautilus I get the error message The folder contents could not be displayed. You do not have the permissions necessary to view the contents of "Stu_external_1TB".)
/media/stuart/Stu_external_1TB1 (the folders and files all seem perfectly viewable within this mount point.)

My question is: how can I force the hard drive only to mount in one location, ideally at "Stu_external_1TB". Thanks in advance.

edit: PS my system is Linux Mint 16 64-bit Cinnamon. Let me know any other information you'd like me to share.

edit2: Fixed a typo in my original message. See Flemur's post (below) to see that I originally mis-typed "Stu_external_TB" instead of "Stu_external_1TB".
Last edited by aneurysm1985 on Mon Mar 03, 2014 7:28 am, edited 1 time in total.

User avatar
Flemur
Level 17
Level 17
Posts: 7307
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Single external hard drive is mounting TWICE

Post by Flemur » Tue Feb 18, 2014 8:50 pm

I have used gparted to label a partition of a 1TB external hard drive "Stu_external_TB".

/media/stuart/Stu_external_1TB
/media/stuart/Stu_external_1TB1


Neither name matches the label. ?

My question is: how can I force the hard drive only to mount in one location, ideally at "Stu_external_1TB".


That's not a mount point - did you mean "/Stu_external_1TB" ?


$ sudo mkdir /Stu_external_1TB
$ sudo chown yourusername /Stu_external_1TB
$ chmod a+w /Stu_external_1TB


Then add a line to /etc/fstab:
LABEL=Stu_external_TB /Stu_external_1TB ext4 defaults 0 0
(assuming it's ext4) Note that the label is different than the mount point, as you specified: Stu_external_TB and Stu_external_1TB.

It'll mount at boot. If you want to mount it by hand, change 'defaults' to 'noauto'.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

aneurysm1985
Level 2
Level 2
Posts: 93
Joined: Sun Sep 13, 2009 6:28 am
Location: Australia

Re: Single external hard drive is mounting TWICE

Post by aneurysm1985 » Tue Feb 18, 2014 11:14 pm

Thanks for the reply.

Note I made a typo in my original post. I want both the label and the mount point to be "Stu_external_1TB".

I edited fstab via the Terminal command sudo gedit /etc/fstab. Here is the current file:

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=8953aefa-b8a4-414c-8de1-cc63d6342c72 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=d69b8c62-c0dc-465b-889f-ee028cfe6205 none            swap    sw              0       0
# LABEL=Stu_external_1TB /Stu_external_1TB ntfs defaults 0 0
Does this look as it should?

After editing that file I rebooted the computer, however upon reboot, the situation looks the same as before. i.e. in my "/media/stuart/" directory I am seeing two hard drives listed: "Stu_external_1TB" and "Stu_external_1TB1". See screenshot #1

When I double-click "Stu_external_1TB" from within nautilus, I get the "The folder contents could not be displayed." error I mentioned before.

However, I have noticed that if I try to browse that drive via another application (Crashplan), I get a single directory ("backup") listed. However, the contents of that directory is different to what is shown on the 'other' drive. See screenshot #2.

As you can see, in the top drive, there is a directory called '54966xxxxxxx'. That directory is not listed in the bottom drive. Instead, directories called 'Crashplan', 'Kitty', 'Stuart-HDD' and 'Stuart-server' are listed.

Any idea why it would be separating out like this? Out of interest, the '54966xxxxxxxx' directory was created by the Crashplan software in the past, though currently the software shouldn't be accessing it.

As you can see, I am not able to view that '54966xxxxxxxx' directory through nautilus. See screenshot #1 again.

Any ideas what is happening?

aneurysm1985
Level 2
Level 2
Posts: 93
Joined: Sun Sep 13, 2009 6:28 am
Location: Australia

Re: Single external hard drive is mounting TWICE

Post by aneurysm1985 » Sun Feb 23, 2014 5:28 am

Just bumping this message. Hope someone can provide a solution for me.

User avatar
jahid
Level 6
Level 6
Posts: 1219
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Single external hard drive is mounting TWICE

Post by jahid » Sun Feb 23, 2014 5:53 am

if you are following Flemur's method then the fstab file should look like this:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=8953aefa-b8a4-414c-8de1-cc63d6342c72 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=d69b8c62-c0dc-465b-889f-ee028cfe6205 none swap sw 0 0
LABEL=Stu_external_1TB /Stu_external_1TB ntfs defaults 0 0
(removing # from the last line....)

in this method it will mount at /Stu_external_1TB not in /media/stuart/Stu_external_1TB

i would have done it in a different approach:
sudo fdisk -l
then find your device id for the partition. it seems like /dev/sdax, x is a number.
then add this line in the end of the fstab file (without any preceding #):
/dev/sdax /media/stuart/Stu_external_1TB ntfs defaults 0 0
jahid@HP ProBook 440 G1 Laptop

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Single external hard drive is mounting TWICE

Post by austin.texas » Sun Feb 23, 2014 8:35 am

# LABEL=Stu_external_1TB /Stu_external_1TB ntfs defaults 0 0
To begin with, any line that begins with # will not be executed - that is a Comment, not a Command.
in my "/media/stuart/" directory I am seeing two hard drives listed:
You are seeing two folders or mount points listed. You only have one hard drive. You do have more than one partition.
I have used gparted to label a partition of a 1TB external hard drive "Stu_external_TB".
Excellent - that works fine. Now you want to create a mount point where you can mount that partition, and you want that mount point (and the partition it points to) to be owned by you.
Right now, looking at your screenshots, there is a mount point with the name you want that is not being used, and a mount point with the name that you don't want, that is being used.
So you need to create the correct command in fstab to mount the partition on the right mount point - not on the one you don't like.
Flemur gave you good instructions on how to do that. I don't know how the # got there, but that stops the command from executing.
jahid_0903014 gave you good instructions as well
Then reboot for the new mount point to be used, and delete the mount point that you don't want to use - Stu_external_1TB1
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

altair4
Level 19
Level 19
Posts: 9738
Joined: Tue Feb 03, 2009 10:27 am

Re: Single external hard drive is mounting TWICE

Post by altair4 » Sun Feb 23, 2014 10:07 am

I have used gparted to label a partition of a 1TB external hard drive "Stu_external_TB".
"A partition" meaning one of many or is this the only partition on the device? If you post the output of the following command it might make things clearer:

Code: Select all

sudo blkid -c /dev/null
The problem is that the hard drive seems to be mounting in two locations via Linux Mint. It is appearing here:

/media/stuart/Stu_external_1TB (when I double-click this icon in nautilus I get the error message The folder contents could not be displayed. You do not have the permissions necessary to view the contents of "Stu_external_1TB".)
/media/stuart/Stu_external_1TB1 (the folders and files all seem perfectly viewable within this mount point.)
There may be multiple things going on here but a partition that is not specified in fstab will mount to /media/stuart/LABEL if a Label exists for that partition. If for some reason you created a folder under /media/stuart and named it the same name as the label of the partition ( as in /media/stuart/Stu_external_1TB ) then when the external partition is connected it cannot auto mount where it wants to mount so it mounts to /media/stuart/LABEL1 ( or in this case /media/stuart/Stu_external_1TB1 ) .

So did you create the /media/stuart/Stu_external_1TB folder yourself? If you did:

*** Unmount the external drive.
*** The /media/stuart/Stu_external_1TB1 folder should disappear.
*** Make absolutely sure that the external drive is disconnected.
*** Then delete the /media/stuart/Stu_external_1TB folder.
*** Then insert or connect the external drive again and it should show up under /media/stuart/Stu_external_1TB all by itself.

Note: Having an entry in fstab for an external "drive" wouldn't by my choice of how to do this unless you are having some strange issue with the device itself.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

aneurysm1985
Level 2
Level 2
Posts: 93
Joined: Sun Sep 13, 2009 6:28 am
Location: Australia

Re: Single external hard drive is mounting TWICE

Post by aneurysm1985 » Mon Mar 03, 2014 7:26 am

Thanks everyone, I fixed the problem. Mostly using jahid_0903014's procedure, but it was good to see everyone's suggestions.

Now it is is only mounting to a single point in my Nautilus view.

Marking the thread as [solved]

Post Reply

Return to “Hardware Support”