Bluetooth audio not working

Archived topics about LMDE 1
Forum rules
dimi
Level 1
Level 1
Posts: 12
Joined: Sun Apr 15, 2012 4:43 am

Bluetooth audio not working

Postby dimi » Fri Jan 04, 2013 7:44 am

I have trouble connecting my LMDE laptop to my car stereo via bluetooth.

The car stereo shows up in my Bluetooth devices, but I cannot connect. And when I try to connect from my car stereo, my laptop shows up but it cannot connect either.

I can't remember how, but before on my laptop it did say it was connected to the car stereo, I must have been able to pair them before, but even then I wasn't able to play audio via the car stereo and on the stereo it said no bluetooth audio device was connected. My car stereo is a JVC KD-X50BT.

Code: Select all

$ lsusb | grep Bluetooth
Bus 001 Device 005: ID 0489:e00f Foxconn / Hon Hai Foxconn T77H114 BCM2070 [Single-Chip Bluetooth 2.1 + EDR Adapter]


Code: Select all

$ /etc/init.d/bluetooth status
[ ok ] bluetooth is running.

dimi
Level 1
Level 1
Posts: 12
Joined: Sun Apr 15, 2012 4:43 am

Re: Bluetooth audio not working

Postby dimi » Thu Feb 07, 2013 2:51 pm

I'm connected to my Car Radio, it shows up in my Bluetooth menu:
Bluetooth Settings.png
Bluetooth menu, showing car radio is connected
Bluetooth Settings.png (23.24 KiB) Viewed 16348 times


But in my Volume Management I cannot see any Bluetooth option, where should I be able to choose audio should be sent to the Bluetooth device?

Volume Control.png
Mint Voolume Control
Volume Control.png (44.04 KiB) Viewed 16348 times

hunternet93
Level 1
Level 1
Posts: 3
Joined: Wed Oct 17, 2012 9:25 pm

Re: Bluetooth audio not working

Postby hunternet93 » Sun Feb 17, 2013 7:39 pm

I found the solution! Sorry to dig up an old post, but I had a hard time finding any info on this so I though I'd post here for others. The solution is actually simple: Just install Pulseaudio and Pulseaudio's Bluetooth module with the command:

Code: Select all

sudo apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol

Edit the file /etc/bluetooth.d/audio.conf with your favorite editor and add the line "Enable=Socket" under the "[General]" heading.
Then, restart pulseaudio with the command:

Code: Select all

pulseaudio -k; pulseaudio --start

Connect your headset with the bluetooth applet, then click the applet, select your headset, and click the "Open sound preferences" item. Your headset should show up as disabled in the devices menu, select "High Fidelity Playback" from the Profile menu to enable it. Then under Output select it as the default output. For some reason the "Test speakers" button didn't make any sound for me, but audio worked from everything else. Now I can wander about my room and still get sound from my computer! Hope this helps someone else. I used this post to figure this out: http://www.funzt.info/?p=783

EDIT: Missed a step. It's there now.

User avatar
krige
Level 1
Level 1
Posts: 19
Joined: Wed Sep 18, 2013 8:36 am

Re: Bluetooth audio not working

Postby krige » Fri Feb 21, 2014 7:06 am

I had a similar problem with my Sennheiser MM 450-X bluetooth headset, they were correctly paired with my computer but no audio was coming out from them; they did not appear in the "Play sound through" list of the Sound Settings panel. I managed to have them appear in the list by following hunternet93 solution and running:

Code: Select all

sudo apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol
pulseaudio -k; pulseaudio --start


I did not need to edit the /etc/bluetooth.d/audio.conf file (the file doesn't actually exist).

The audio comes very badly from the headphones though, and it is probably due to the fact that it's currently working in "Telephony Duplex (HSP/HFP)" mode. The other mode, "High Fidelity Playback (A2DP)", appears in the list, I can select it but it doesn't seem to be "activated": if I close the Sound Settings panel and open it again, the "Telephony Duplex (HSP/HFP)" mode appears selected again.

ergoman
Level 1
Level 1
Posts: 5
Joined: Wed Jan 01, 2014 4:57 pm

Re: Bluetooth audio not working

Postby ergoman » Thu Apr 17, 2014 10:55 pm

https://bugs.launchpad.net/ubuntu/+sour ... omments/15

^^ This solution worked for me to get A2DP working


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 4 guests