XD memory card - not mounting

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
BigNewPrinz
Level 1
Level 1
Posts: 2
Joined: Sun Jun 22, 2014 6:50 am

XD memory card - not mounting

Postby BigNewPrinz » Sun Jun 22, 2014 7:06 am

I wonder if someone could help me out (because, basically, I'm a clueless numpty).

I'm trying to read from an XD card using an old USB2.0 reader, the same as described here...http://forums.linuxmint.com/viewtopic.php?f=49&t=142768

I've followed the instructions in the fourth post here...https://bugs.launchpad.net/ubuntu/+sour ... bug/354832

...and have come to the point where

Code: Select all

lsusb

gives

Bus 001 Device 007: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 001 Device 006: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB

(The second line didn't appear until I unbound it from the ehci_hcd (which now seems to be ehci-pci)

Code: Select all

fdisk -l

now gives...
Disk /dev/sde: 262 MB, 262144000 bytes
9 heads, 56 sectors/track, 1015 cylinders, total 512000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xffffffff

Disk /dev/sde doesn't contain a valid partition table


which is my XD card (256 MB) - this disappears when I physically take it out.

When I try to mount, I get...

mount: wrong fs type, bad option, bad superblock on /dev/sde,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


trying dmesg |tail gives
[ 894.920953] usb 1-5: USB disconnect, device number 5
[ 929.765070] sde: detected capacity change from 262144000 to 0
[ 943.110950] sd 5:0:0:2: [sde] 512000 512-byte logical blocks: (262 MB/250 MiB)
[ 943.113319] sd 5:0:0:2: [sde] No Caching mode page found
[ 943.113326] sd 5:0:0:2: [sde] Assuming drive cache: write through
[ 943.116158] sd 5:0:0:2: [sde] No Caching mode page found
[ 943.116163] sd 5:0:0:2: [sde] Assuming drive cache: write through
[ 943.298829] sde: unknown partition table
[ 1704.288583] FAT-fs (sde): bogus logical sector size 65535
[ 1704.288592] FAT-fs (sde): Can't find a valid FAT filesystem


Can someone point me as to to my next steps, plz, to actually read the thing...
Thanks in advance
Last edited by karlchen on Sun Jun 22, 2014 12:14 pm, edited 1 time in total.
Reason: Split off from dead thread http://forums.linuxmint.com/viewtopic.php?p=650583#p650583 and converted into a new thread

User avatar
seeley
Level 7
Level 7
Posts: 1886
Joined: Sun Mar 07, 2010 7:20 am

Re: XD memory card - not mounting

Postby seeley » Mon Jun 23, 2014 5:16 am

Hi!
Your DE is?
Maybe a Partition Manager gives you a clue,
KDE: KDE Partition Manager 1.03,
others: GParted - if not installed it's easy to install e.g. via Terminal
(typing

Code: Select all

gparted

you'll get a command how to install).
seeley @ Linux multiboot

BigNewPrinz
Level 1
Level 1
Posts: 2
Joined: Sun Jun 22, 2014 6:50 am

Re: XD memory card - not mounting

Postby BigNewPrinz » Tue Jun 24, 2014 4:28 pm

Hi,

Thanks for the response.

I've now worked out that the problem seems to have been with the XD card which seems to have been corrupted - which is unusal, never had that before.

The reader works for SD cards...daren't try another XD card in case it was my system that corrupted the last one.

User avatar
seeley
Level 7
Level 7
Posts: 1886
Joined: Sun Mar 07, 2010 7:20 am

Re: XD memory card - not mounting

Postby seeley » Wed Jun 25, 2014 7:30 am

Hi!
You have another question concerning that problem?
Or do you think your problem is solved; if "yes", please edit your first post and add to the subject line [Solved].
seeley @ Linux multiboot


Return to “Newbie Questions”

Who is online

Users browsing this forum: Boca, JoeFootball, Laurent85 and 21 guests