Cinnamon fails to load session after upgrade to 2.0.14+lmde

Archived topics about LMDE 1 and LMDE 2
Locked
Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

Cinnamon fails to load session after upgrade to 2.0.14+lmde

Post by Emerson Prado »

Hi all,
I had Cinnamon 1.6.7+lmde, and decided to upgrade to be able to install the weather applet, and I can't log into Cinnamon no more. Gnome Classic and Mate are OK.
When I try to log in, I get a small dialog about the error and, after hitting OK, another dialog saying session lasted less than 10 seconds and pointing to a error log - ~/.xsession-errors. I pasted the whole file below, because the forum doesn't accept this kind of file (I renamed it twice, but no luck). This log shows some interesting stuff:

Code: Select all

openConnection: connect: Arquivo ou diretório não encontrado (Portuguese for "file or directory not found")
cannot connect to brltty at :0
(gnome-panel:3889): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed
(gnome-panel:3889): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed
(process:4043): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Plus several warnings. I tried purging and reinstalling Cinnamon, upgrading libraries (gdk, gtk and glib), something called nemo and the applications shown in previous logs (firefox and gnome-panel), in this order:

Code: Select all

grep Commandline /var/log/apt/history.log | sed 's/Commandline: //'
apt-get install gnome-settings-daemon
apt-get install cinnamon
apt-get remove debian-system-adjustments
apt-get install cinnamon
apt-get install mate-desktop
apt-get purge cinnamon*
apt-get install cinnamon-desktop-data cinnamon-session cinnamon-session-common
apt-get install mate-session-manager mate-panel mate-panel-common
apt-get install mate-applets mate-applets-common mate-calc mate-common mate-keyring mate-media mate-media-common mate-power-manager mate-power-manager-common mate-screensaver mate-screensaver-common mate-utils mate-utils-common
apt-get install --only-upgrade glib*
apt-get install cinnamon-common cinnamon-screensaver
apt-get purge mate*
apt-get install namebench
apt-get autoremove
apt-get install gtk-doc-tools ndisgtk
apt-get install gnome-panel firefox
apt-get install firefox-l10n-pt-br
apt-get install --only-upgrade xserver-xorg*
Yes, I did apt-get update prior to all that.
When I STFW, many people said such errors were gone in Cinnamon 2.0.6.something, but i'm quite beyond that. I also tried to compile directly from source, but the installer complains about lack of a macro:

Code: Select all

Cinnamon-2.2.13 $ sudo ./autogen.sh
...
Running aclocal...
configure.ac:151: warning: macro 'AM_PATH_GLIB_2_0' not found in library
Running autoconf...
configure.ac:151: error: possibly undefined macro: AM_PATH_GLIB_2_0
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
I couldn't find .deb packages either. I wanted to roll back to the previous version to see if it gets OK again, even without the weather applet (working without it is better than not working at all). To my ultimate desperation, it's not in /var/cache/apt/archives/ either.

More stuff:

Code: Select all

> uname -a
Linux duvidagnocchi 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux
> inxi
CPU[-Dual core Intel Core i5-3337U (-HT-MCP-) clocked at Min:1314.000Mhz Max:2502.000Mhz-] Kernel[-3.11-2-amd64 x86_64-] Up[-49 min-] Mem[-453.5/5851.5MB-] HDD[-1000.2GB(36.5% used)-] Procs[-158-] Client[-Shell-] inxi[-1.4.23-]
cat /proc/version
Linux version 3.11-2-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.1 (Debian 4.8.1-10) ) #1 SMP Debian 3.11.8-1 (2013-11-13)
> cat /etc/debian_version 
wheezy/sid
I'm trying also this old .deb package: http://sourceforge.net/projects/cinnamondebian/files/ . When trying to solve dependencies with apt-get -f install, apt decided to upgrade lots of stuff. Let's see.

I'm out of ideas. Could someone help me fix this?
Many thanks,
Emerson

================ .xsession-errors ================

Code: Select all

/etc/mdm/Xsession: Beginning session setup...
localuser:grilo being added to access control list
openConnection: connect: Arquivo ou diretório não encontrado
cannot connect to brltty at :0
gnome-session-flashback (3.8.0): attempting to launch gnome-session at 2014-06-25T22:43:22-0300
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-UEygJK
SSH_AUTH_SOCK=/run/user/1000/keyring-UEygJK/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-UEygJK
SSH_AUTH_SOCK=/run/user/1000/keyring-UEygJK/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-UEygJK
SSH_AUTH_SOCK=/run/user/1000/keyring-UEygJK/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-UEygJK/gpg:0:1
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.

(gnome-panel:3889): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed

** (gnome-panel:3889): WARNING **: Unable to parse mouse modifier '(null)'

Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected
glibtop: Non-standard uts for running kernel:
release 3.11-2-amd64=3.11.0 gives version code 199424

access control disabled, clients can connect from any host
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
system-config-printer-applet: failed to start NewPrinterNotification service
system-config-printer-applet: failed to start PrinterDriversInstaller service: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.40" is not allowed to own the service "com.redhat.PrinterDriversInstaller" due to security policies in the configuration file
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected

(gnome-panel:3889): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed

** (gnome-panel:3889): WARNING **: Unable to parse mouse modifier '(null)'


(gnome-panel:3889): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.4/./gobject/gsignal.c:2475: signal `size_request' is invalid for instance `0x2c1cbc0' of type `GtkLabel'

(gnome-settings-daemon:3660): updates-plugin-WARNING **: Failed to get symlink: Erro ao obter informação para o arquivo "/run/udev/firmware-missing/intel-ucode/06-3a-09": Arquivo ou diretório não encontrado
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected
Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected

(process:4043): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected
No permission to use the keyboard API for https://googleads.g.doubleclick.net
No permission to use the keyboard API for https://googleads.g.doubleclick.net
No permission to use the keyboard API for http://googleads.g.doubleclick.net
No permission to use the keyboard API for http://googleads.g.doubleclick.net
No permission to use the keyboard API for http://googleads.g.doubleclick.net
No permission to use the keyboard API for http://www.linuxforums.org
No permission to use the keyboard API for http://googleads.g.doubleclick.net
No permission to use the keyboard API for http://googleads.g.doubleclick.net
No permission to use the keyboard API for http://googleads.g.doubleclick.net
Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

Re: Cinnamon fails to load session after upgrade to 2.0.14+l

Post by Emerson Prado »

Emerson Prado wrote:I'm trying also this old .deb package: http://sourceforge.net/projects/cinnamondebian/files/ . When trying to solve dependencies with apt-get -f install, apt decided to upgrade lots of stuff. Let's see.
Update: it didn't work.
Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

Re: Cinnamon fails to load session after upgrade to 2.0.14+l

Post by Emerson Prado »

I tried more stuff, but no success at all. My last steps:

I purged Cinnamon and reinstalled everything:

Code: Select all

apt-get purge cinnamon*
apt-get purge mint-artwork-cinnamon
apt-get install cinnamon cinnamon-common cinnamon-control-center cinnamon-control-center-data cinnamon-dbg cinnamon-desktop-data cinnamon-screensaver cinnamon-session cinnamon-session-common cinnamon-settings-daemon cinnamon-settings-daemon-dev cinnamon-translations
Following instructions in this comment in bug 982051 in Launchpad, I reset all settings using gsettings:

Code: Select all

gsettings reset-recursively org.cinnamon
I also tried disabling lots of stuff in cinnamon settings typing cinnamon-settings, following this comment in RedHat's Bugzilla.

Unfortunately, the errors are there and Cinnamon session isn't.

I also read in This comment in bug 728947 in Debian bug tracker that the error "openConnection: connect: No such file or directory - cannot connect to brltty at :0" is nothing to worry about (just not finding a Braile display).

Plus, /var/log/Xorg.0.log shows no error messages, just some warnings, and none that seemed to prevent Cinnamon to start:

Code: Select all

[   571.602] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   571.602] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   571.602] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   571.602] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   571.602] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   571.613] (WW) Falling back to old probe method for vesa
[   571.613] (WW) Falling back to old probe method for modesetting
[   571.613] (WW) Falling back to old probe method for fbdev
[   571.704] (WW) evdev: USB USB Keykoard: ignoring absolute axes.
The only interesting stuff I found was in dmesg, which shows bad things about nouveau (NVidia's drivers, if I'm correct):

Code: Select all

dmesg | grep nouveau
[    4.355650] nouveau 0000:02:00.0: enabling device (0006 -> 0007)
[    4.356097] nouveau  [  DEVICE][0000:02:00.0] BOOT0  : 0x0d7000a2
[    4.356153] nouveau  [  DEVICE][0000:02:00.0] Chipset: GF117 (NVD7)
[    4.356208] nouveau  [  DEVICE][0000:02:00.0] Family : NVD0
[    4.361948] nouveau  [   VBIOS][0000:02:00.0] checking PRAMIN for image...
[    4.410131] nouveau  [   VBIOS][0000:02:00.0] ... signature not found
[    4.410186] nouveau  [   VBIOS][0000:02:00.0] checking PROM for image...
[    4.410301] nouveau  [   VBIOS][0000:02:00.0] ... signature not found
[    4.410357] nouveau  [   VBIOS][0000:02:00.0] checking ACPI for image...
[    4.410413] nouveau  [   VBIOS][0000:02:00.0] ... signature not found
[    4.410469] nouveau  [   VBIOS][0000:02:00.0] checking PCIROM for image...
[    4.416751] nouveau 0000:02:00.0: Invalid ROM contents
[    4.416816] nouveau  [   VBIOS][0000:02:00.0] ... signature not found
[    4.416870] nouveau  [   VBIOS][0000:02:00.0] checking PLATFORM for image...
[    4.416925] nouveau  [   VBIOS][0000:02:00.0] ... signature not found
[    4.416981] nouveau E[   VBIOS][0000:02:00.0] unable to locate usable image
[    4.417037] nouveau E[  DEVICE][0000:02:00.0] failed to create 0x10000001, -22
[    4.417103] nouveau E[     DRM] failed to create 0x80000080, -22
[    4.417377] nouveau: probe of 0000:02:00.0 failed with error -22
Should there be a problem with the video driver, or firmware, or else...?
Best regards,
Emerson
Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

Re: Cinnamon fails to load session after upgrade to 2.0.14+l

Post by Emerson Prado »

I installed Mate and it's running flawlessly for over a month now. So I guess nothing is broken outside Cinnamon. But purging Cinnamon, reset all its settings in GSettings and reinstalling again from scratch makes no difference. So I just defaulted to Mate and gave up on Cinnamon.
Locked

Return to “LMDE Archive”