Reducing mouse sensitivity

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Nick Payne
Level 3
Level 3
Posts: 101
Joined: Sun Feb 21, 2010 8:49 pm

Reducing mouse sensitivity

Post by Nick Payne »

I'm using a Logitech optical mouse with LM17 amd64. My problem is that I already have pointer acceleration and sensitivity set to the minimum in the Control Center mouse settings, but the pointer still moves uncomfortably fast, particularly when I'm doing something fiddly such as drawing a mask around an object in a graphics program. Is there anything I can do to lower the pointer speed beyond what the GUI in Control Center allows? I found a couple of web pages that talked about modifying settings in xorg.conf, but on LM17 with the nVidia driver /etc/X11/xorg.conf doesn't exist at all...

JeremyB
Level 20
Level 20
Posts: 11657
Joined: Fri Feb 21, 2014 8:17 am

Re: Reducing mouse sensitivity

Post by JeremyB »

Nick Payne wrote:I'm using a Logitech optical mouse with LM17 amd64. My problem is that I already have pointer acceleration and sensitivity set to the minimum in the Control Center mouse settings, but the pointer still moves uncomfortably fast, particularly when I'm doing something fiddly such as drawing a mask around an object in a graphics program. Is there anything I can do to lower the pointer speed beyond what the GUI in Control Center allows? I found a couple of web pages that talked about modifying settings in xorg.conf, but on LM17 with the nVidia driver /etc/X11/xorg.conf doesn't exist at all...
I can't help much other than to say that you might want to look in /usr/share/X11 but it doesn't hurt anything to create the xorg.conf in /etc/X11/

Nick Payne
Level 3
Level 3
Posts: 101
Joined: Sun Feb 21, 2010 8:49 pm

Re: Reducing mouse sensitivity

Post by Nick Payne »

I wound up creating a script that runs xinput at login to reduce the mouse sensitivity:

Code: Select all

#!/bin/bash
DEVID=`xinput list | grep "Logitech USB Receiver" | sed -e "s/^.*id=\([0-9]\+\).*/\1/"`
if [ "$DEVID" != "" ]; then
   xinput --set-prop $DEVID "Device Accel Constant Deceleration" 2.5
fi

440roadrunner
Level 1
Level 1
Posts: 14
Joined: Sat Nov 22, 2008 2:42 pm

Re: Reducing mouse sensitivity

Post by 440roadrunner »

Can someone please explain what I do with this? Thanks.

Running Mint 17 64 B on asus U56E laptop. Just bought a Logitech m525. Settings are on slowest, still way way too fast

User avatar
jimallyn
Level 18
Level 18
Posts: 8955
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Reducing mouse sensitivity

Post by jimallyn »

440roadrunner, it's usually better to start a new thread than to tag onto a months old thread started by someone else.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

440roadrunner
Level 1
Level 1
Posts: 14
Joined: Sat Nov 22, 2008 2:42 pm

Re: Reducing mouse sensitivity

Post by 440roadrunner »

jimallyn wrote:440roadrunner, it's usually better to start a new thread than to tag onto a months old thread started by someone else.
My question IS ABOUT this thread, what am I supposed to do start a new one and quote this one? I don't know how to do that. I'm asking what to do with the above information. I do not understand it.

Maybe you misunderstood? "what to do with this" meant I don't know what to do with the information posted

440roadrunner
Level 1
Level 1
Posts: 14
Joined: Sat Nov 22, 2008 2:42 pm

Re: Reducing mouse sensitivity

Post by 440roadrunner »

Can anybody provide an answer, AKA "bump?"

440roadrunner
Level 1
Level 1
Posts: 14
Joined: Sat Nov 22, 2008 2:42 pm

Re: Reducing mouse sensitivity

Post by 440roadrunner »

Hello? Hello? Anybody?

JeremyB
Level 20
Level 20
Posts: 11657
Joined: Fri Feb 21, 2014 8:17 am

Re: Reducing mouse sensitivity

Post by JeremyB »

440roadrunner wrote:Hello? Hello? Anybody?
It might be done with

Code: Select all

gedit mouse.sh
paste the following in

Code: Select all

#!/bin/bash
DEVID=`xinput list | grep "Logitech USB Receiver" | sed -e "s/^.*id=\([0-9]\+\).*/\1/"`
if [ "$DEVID" != "" ]; then
   xinput --set-prop $DEVID "Device Accel Constant Deceleration" 2.5
fi
make it executable

Code: Select all

chmod +x ./mouse.sh
Then find how to add to your Startup Applications for whatever desktop environment you have

In Cinnamon, I have to use the Menu in the taskbar, choose Preferences, then click on Startup Applications and it gives me a new window where I can choose 'Add'
Name: Enter whatever you want
Command: Use browse to find your /home folder and select mouse.sh
Comment: again, enter whatever you want
Click Add and reboot to see if it does what you want

440roadrunner
Level 1
Level 1
Posts: 14
Joined: Sat Nov 22, 2008 2:42 pm

Re: Reducing mouse sensitivity

Post by 440roadrunner »

Thank you for responding. Might take me a couple of days to digest this

I've run various Linux for several years now, but you would not call me a software expert, LOL.

Laugh2
Level 4
Level 4
Posts: 201
Joined: Fri Aug 16, 2013 4:01 am

Re: Reducing mouse sensitivity

Post by Laugh2 »

I'm having the same problem with Mint 17.1 RC Rebecca. In "Control Centre/Mouse" I've adjusted both Acceleration and Sensitivity to their minimum values, but the mouse is still too fast for comfort.

There also appears still to be some acceleration even now, which I don't use. (For many years and in a previous life on Windows I always disabled mouse acceleration altogether, as I personally find it unhelpful.)

Equipment
Logitech M310t wireless mouse
Dell Latititude D630 laptop
Mint 17.1 RC Rebecca

Ph0z3
Level 3
Level 3
Posts: 149
Joined: Thu Nov 20, 2014 6:21 pm
Location: Kansas City, MO

Re: Reducing mouse sensitivity

Post by Ph0z3 »

I also run a Logitech mouse...

use "lomoco" from the SPM.

edit the options via CLI

awesome software.
-- If your thread is solved, please add [SOLVED] in caps at the beginning of the post, so others & admins know there is a solution!

Example: [SOLVED] Your_Thread_Name_Here

Laugh2
Level 4
Level 4
Posts: 201
Joined: Fri Aug 16, 2013 4:01 am

Re: Reducing mouse sensitivity

Post by Laugh2 »

Hi thanks for quick reply - brilliant. :D

I installed Lomoco from the Synaptics Package Manager and all went well. :D After opening a terminal and executing "man lomoco" then reading the blurb I used "lomoco -s" to see if my Logiotech mouse is supported. (My mouse is a Logitech M310t.)

Lomoco said it found two Logitech products on my computer (correct: a Logitech microphone and the mouse) but that they were not supported. :( So it's back to square one. Thanks anyway, this hint may well help the next reader.

Ph0z3
Level 3
Level 3
Posts: 149
Joined: Thu Nov 20, 2014 6:21 pm
Location: Kansas City, MO

Re: Reducing mouse sensitivity

Post by Ph0z3 »

my g5 mouse is "not supported" but commands work anyways.... try a few and see what happens.
-- If your thread is solved, please add [SOLVED] in caps at the beginning of the post, so others & admins know there is a solution!

Example: [SOLVED] Your_Thread_Name_Here

Laugh2
Level 4
Level 4
Posts: 201
Joined: Fri Aug 16, 2013 4:01 am

Re: Reducing mouse sensitivity

Post by Laugh2 »

Thanks. I just reinstalled Lomoco and tried the commands "Lomoco --400" and "Lomoco --2000". Unfortunately they made no difference. :( Thanks for the suggestions.

Ph0z3
Level 3
Level 3
Posts: 149
Joined: Thu Nov 20, 2014 6:21 pm
Location: Kansas City, MO

Re: Reducing mouse sensitivity

Post by Ph0z3 »

bummer... well, i hope you find something... unfortunately logitech is kind of "here and there" with linux.
-- If your thread is solved, please add [SOLVED] in caps at the beginning of the post, so others & admins know there is a solution!

Example: [SOLVED] Your_Thread_Name_Here

TropiKo
Level 1
Level 1
Posts: 4
Joined: Wed Nov 26, 2014 10:07 pm

Re: Reducing mouse sensitivity

Post by TropiKo »

I've had the same sensitivity and acceleration issue with my Diamondback mouse which I fixed using : http://patrickmylund.com/blog/lowering- ... untu-9-10/

hal-device returns nothing so it shouldn't be the case in mint no?

It works fine BUT when I insert another USB device the xinput config sort of reverts, or if I reinsert the mouse. Any way to make it stay the same always?

sadhu
Level 5
Level 5
Posts: 643
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: Reducing mouse sensitivity

Post by sadhu »

I have the same problem, and I don't have a Logitech mouse. It's not a mouse issue, it's a Linux Mint issue.

System settings > Mouse and Touchpad --> is set to zero, but the mouse is uncomfortably fast. I've connect a cheap optical mouse to my laptop. Touchpads just don't do it for me. Got an external keyboard, too.

First I issed

Code: Select all

xinput --list --short
and got the name of the mouse. Then I created a little script:

Code: Select all

xinput --set-prop "SIGMACHIP Usb Mouse" "Device Accel Constant Deceleration" 2
xinput --set-prop "SIGMACHIP Usb Mouse" "Device Accel Velocity Scaling" 1
Which works fine --- for a while. Then the mouse speeds up again. I've not been able to nail down the circumstances when the mouse speeds up again. The last time it happened was a moment ago after I installed an app via apt-get. And it just speeded up again when I adjusted Panel Settings. It's something in the mint implementation of xwindows.

-sadhu
sabbe sattā bhavantu sukhitattā. LN 19.3-64 Cinn 4.4.8, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:ASUS, Core i3, 4G RAM Intel Gfx

dumble
Level 1
Level 1
Posts: 37
Joined: Thu Nov 07, 2013 8:22 am

Re: Reducing mouse sensitivity

Post by dumble »

I have the same problem with linux mint 17.1 x64 and logitech mx1000 mouse. I have not found a good solution. What commands should I run with lomoco?

When I run lomoco-i I get this:

Code: Select all

lomoco -i
001.004: 046d:c318 Unsupported Logitech device: Unknown
001.003: 046d:c50e Receiver for MX1000 Laser (C-BN34) Caps: CSR SMS 
lomoco.c:95
Writing to USB device: CSR: Operation not permitted
I also have a logitech keyboard..

sadhu
Level 5
Level 5
Posts: 643
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: Reducing mouse sensitivity

Post by sadhu »

dumble wrote:I have the same problem with linux mint 17.1 x64 and logitech mx1000 mouse. I have not found a good solution. What commands should I run with lomoco?
In a terminal window, issue the command

Code: Select all

xinput --list
and note the output line that refers to the logitech mouse. For example, on my machine with a cheap generic mouse, I get

Code: Select all

n$ xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SIGMACHIP USB Keyboard                  	id=9	[slave  pointer  (2)]
⎜   ↳ PixArt USB Optical Mouse                	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ SIGMACHIP USB Keyboard                  	id=8	[slave  keyboard (3)]
Them create a text file and paste this text

Code: Select all

xinput --set-prop "SIGMACHIP Usb Mouse" "Device Accel Constant Deceleration" 2
xinput --set-prop "SIGMACHIP Usb Mouse" "Device Accel Velocity Scaling" 1
substituting the logitech output on your system for "SIGMACHIP...". After saving the file, issue the command chmod +x <your text file name>. In the command window enter ./<your text file name> to execute the little script.

You may have to play around with the values. Constant Deceleration of 1 is very slow, 9 is very fast. I'm not sure about what the Velcity Scaling does.
sabbe sattā bhavantu sukhitattā. LN 19.3-64 Cinn 4.4.8, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:ASUS, Core i3, 4G RAM Intel Gfx

Post Reply

Return to “Hardware Support”