How to automount ntfs drives in Linux Mint 17 KDE?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
colyn
Level 6
Level 6
Posts: 1230
Joined: Sat Aug 14, 2010 1:37 pm
Location: ¿ǝɯ ǝǝs ɐʎ ʇ,uɐƆ ˙ǝɹǝɥ ʇɥƃᴉɹ ɯ,I
Contact:

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by colyn »

altair4 wrote:
Besides ntfs-config just makes a mess of things.
How so??

I've used it for several years now without a single glitch..
Linil
Level 1
Level 1
Posts: 12
Joined: Tue Jul 23, 2013 11:56 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by Linil »

head /etc/fstab|hexdump -C

Code: Select all

00000000  ef bb bf 23 20 2f 65 74  63 2f 66 73 74 61 62 3a  |...# /etc/fstab:|
00000010  20 73 74 61 74 69 63 20  66 69 6c 65 20 73 79 73  | static file sys|
00000020  74 65 6d 20 69 6e 66 6f  72 6d 61 74 69 6f 6e 2e  |tem information.|
00000030  0a 23 0a 23 20 55 73 65  20 27 62 6c 6b 69 64 27  |.#.# Use 'blkid'|
00000040  20 74 6f 20 70 72 69 6e  74 20 74 68 65 20 75 6e  | to print the un|
00000050  69 76 65 72 73 61 6c 6c  79 20 75 6e 69 71 75 65  |iversally unique|
00000060  20 69 64 65 6e 74 69 66  69 65 72 20 66 6f 72 20  | identifier for |
00000070  61 0a 23 20 64 65 76 69  63 65 3b 20 74 68 69 73  |a.# device; this|
00000080  20 6d 61 79 20 62 65 20  75 73 65 64 20 77 69 74  | may be used wit|
00000090  68 20 55 55 49 44 3d 20  61 73 20 61 20 6d 6f 72  |h UUID= as a mor|
000000a0  65 20 72 6f 62 75 73 74  20 77 61 79 20 74 6f 20  |e robust way to |
000000b0  6e 61 6d 65 20 64 65 76  69 63 65 73 0a 23 20 74  |name devices.# t|
000000c0  68 61 74 20 77 6f 72 6b  73 20 65 76 65 6e 20 69  |hat works even i|
000000d0  66 20 64 69 73 6b 73 20  61 72 65 20 61 64 64 65  |f disks are adde|
000000e0  64 20 61 6e 64 20 72 65  6d 6f 76 65 64 2e 20 53  |d and removed. S|
000000f0  65 65 20 66 73 74 61 62  28 35 29 2e 0a 23 0a 23  |ee fstab(5)..#.#|
00000100  20 3c 66 69 6c 65 20 73  79 73 74 65 6d 3e 20 3c  | <file system> <|
00000110  6d 6f 75 6e 74 20 70 6f  69 6e 74 3e 20 20 20 3c  |mount point>   <|
00000120  74 79 70 65 3e 20 20 3c  6f 70 74 69 6f 6e 73 3e  |type>  <options>|
00000130  20 20 20 20 20 20 20 3c  64 75 6d 70 3e 20 20 3c  |       <dump>  <|
00000140  70 61 73 73 3e 0a 23 20  2f 20 77 61 73 20 6f 6e  |pass>.# / was on|
00000150  20 2f 64 65 76 2f 73 64  61 36 20 64 75 72 69 6e  | /dev/sda6 durin|
00000160  67 20 69 6e 73 74 61 6c  6c 61 74 69 6f 6e 0a 55  |g installation.U|
00000170  55 49 44 3d 30 65 62 62  30 32 38 61 2d 61 33 64  |UID=0ebb028a-a3d|
00000180  33 2d 34 61 35 61 2d 61  39 66 33 2d 31 65 61 64  |3-4a5a-a9f3-1ead|
00000190  38 32 33 65 65 35 37 62  20 2f 20 20 20 20 20 20  |823ee57b /      |
000001a0  20 20 20 20 20 20 20 20  20 65 78 74 34 20 20 20  |         ext4   |
000001b0  20 65 72 72 6f 72 73 3d  72 65 6d 6f 75 6e 74 2d  | errors=remount-|
000001c0  72 6f 20 30 20 20 20 20  20 20 20 31 0a 23 20 73  |ro 0       1.# s|
000001d0  77 61 70 20 77 61 73 20  6f 6e 20 2f 64 65 76 2f  |wap was on /dev/|
000001e0  73 64 61 35 20 64 75 72  69 6e 67 20 69 6e 73 74  |sda5 during inst|
000001f0  61 6c 6c 61 74 69 6f 6e  0a                       |allation.|
Linil
Level 1
Level 1
Posts: 12
Joined: Tue Jul 23, 2013 11:56 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by Linil »

Even If I remove the last three lines from fstab it still gives the same error.
I Know Nothing
Level 1
Level 1
Posts: 41
Joined: Sun Oct 06, 2013 8:44 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by I Know Nothing »

The best foolproof way I found to automount a partition on boot up with no errors was to set it's mount point up during the installation procedure. No amount of post installation manual fstab editing or setting it up using the disks utility from the menu or other downloaded apps seemed to make it do what I wanted despite me being able to make other partitions do what I told them just fine with similar methods.
Linil
Level 1
Level 1
Posts: 12
Joined: Tue Jul 23, 2013 11:56 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by Linil »

I've already installed all the required apps and drivers.. and more over I did not have the drive connected during installation..
I used Cinnamon desktop before this and it had no auto mounting problems I switched to KDE just recently and the experience is quite dissappointing..
altair4
Level 20
Level 20
Posts: 10278
Joined: Tue Feb 03, 2009 10:27 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by altair4 »

Run this command again:

Code: Select all

kdesudo kate /etc/fstab
Then select the Tools button and deselect "Add Byte Order Mark (BOM)"

Then save the file and run this command again to see if you still get the error:

Code: Select all

sudo mount -a
Those three dots appear to be a byte order mark which kate will add automatically if told to do so and that appears to be what's causing the problem:
00000000 ef bb bf 23 20 2f 65 74 63 2f 66 73 74 61 62 3a |...# /etc/fstab:|
If that doesn't fix it we'll have to wait for WharfRat's recommendation on how to fix this.

@WharfRat, your diagnostic skills are second to none in my book.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
Linil
Level 1
Level 1
Posts: 12
Joined: Tue Jul 23, 2013 11:56 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by Linil »

It worked... :)
Thank you...
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by Spearmint2 »

All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by WharfRat »

altair4 wrote:Run this command again:
kdesudo kate /etc/fstab
Then select the Tools button and deselect "Add Byte Order Mark (BOM)"
If that doesn't fix it we'll have to wait for WharfRat's recommendation on how to fix this.
I wouldn't have known about that byte order thingy. I don't see anything like that in pluma so I would have just sent the fstab file back with

Code: Select all

cat > /etc/fstab << "EOF"
...
...
EOF
and have Linil run it to fix it. However it would croak again if Linil ever decided to make another change with kate :?
ImageImage
altair4
Level 20
Level 20
Posts: 10278
Joined: Tue Feb 03, 2009 10:27 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by altair4 »

I have Mint KDE in a VBox VM so I can answer samba questions mostly but this question seemed so simple I figured even I could answer it. Yikes!

Started playing around with different options in kate and found this thing about BOM and edited fstab with it - immediately got the "line 1 in /etc/fstab is bad" error. Ran your command found the three dots and figured I just remove the option from kate and see what happens.

Don't know exactly what it is or why anyone would want it but it's not enabled by default on my system.

KDE gives me the willies :)
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by WharfRat »

altair4 wrote:KDE gives me the willies :)
At the very least we all know now that the mount error referred to the actual first line in/etc/fstab and not the first uncommented line :D
ImageImage
nmumbach
Level 1
Level 1
Posts: 8
Joined: Sat Jul 12, 2014 11:49 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by nmumbach »

I found out, by trial and error, that I can automount partitions (NTFS, USB connected, whatever) in Linux Mint 17.1 with xfce desktop (other versions of Linux, Linux Mint with a different desktop, or maybe even the same distro in earlier or later versions may be different) by opening the menu, highlighting Settings, choosing Disks (Disk Management), then select (highlight) the drive, click on the little intermeshed gears icon under the Volumes window, choose Edit Mount Options, and set Automatic Mount Options to OFF! Yes that's right, Automatic Mount "OFF". In what universe does this make sense? Then you can choose Mount at startup, and other things I haven't gotten into. Hope this helps SOMEONE. It took me days to figure this out, even though I was a computer professional for for 30+ years. Sometimes Window$ doesn't look so bad, after all. :evil:
peter_62au
Level 1
Level 1
Posts: 16
Joined: Wed Apr 29, 2015 4:43 am

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by peter_62au »

Excellent, something else for my useful commands/information file. Worked a treat. The only thing is I had a link on the desktop to a spreadsheet on the drive I wanted to mount on startup. I had to delete this link and create it again, I assume because the mount point had changed. No big deal though.
gonewild
Level 1
Level 1
Posts: 3
Joined: Sun May 31, 2015 3:53 pm

Re: How to automount ntfs drives in Linux Mint 17 KDE?

Post by gonewild »

I followed a similar guide to automount my ntfs partition (http://forums.linuxmint.com/viewtopic.p ... 5#p1025385). It works fine for a while, then suddenly I got this message:Unable to create io-slave:klauncher said: Error Loading 'kio_file.'
Could it be related?
thanks
Post Reply

Return to “Newbie Questions”