Upgraded to 17.1 from 14, wifi now slow and intermittent

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
dig59017
Level 1
Level 1
Posts: 14
Joined: Tue Jan 06, 2015 7:44 pm

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by dig59017 »

Sorry for being silent for so long. Had work/life interruptions and then it took me a while to figure out that I needed to install the -extra package to get the drivers I needed. I finally have a functional 3.13.0-24 kernel installation and so far so good. If this works then I'll see if I can get -43 to work and see if it works better than the -37 kernel that I had. It seems pretty obvious that there is a significant improvement but I'll run with it the rest of the day today and see what crops up.
craig100
Level 2
Level 2
Posts: 91
Joined: Mon Nov 07, 2011 1:37 pm
Location: Slough, UK

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by craig100 »

I upgraded my Linux Mint 17.1 Cinnamon x64 to Kernel 3.13.0-37 a few months ago. I don't use the WiFi that often but the last two weeks I've a contracting job in some new offices and I can't connect to their WiFi for longer than a few seconds. That is, it connects, but I have no connection to the internet. Any web page request just shows "Resolving Host" in Chrome's Status Bar. At home or anywhere else it's fine. Everyone else (running MACs) in the office are fine. It's just my laptop (Toshiba Portege R830 138) that has issues. Also the Mobile Network (sim card) keeps dropping after a few minutes.

The Network Card is an Intel Centrino Advanced-N 6230 (Rainbow Peak) with driver: iwlwifi
The Linux-firmware version is 1.127.10

I don't know what to do to fault find this so if anyone could help I'd be grateful.

Craig
JeremyB
Level 20
Level 20
Posts: 11659
Joined: Fri Feb 21, 2014 8:17 am

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by JeremyB »

Chili555 might have found a solution http://ubuntuforums.org/showthread.php? ... st13211316
Start at "please download this to desktop"
moien57
Level 1
Level 1
Posts: 1
Joined: Tue Jan 20, 2015 7:53 am

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by moien57 »

Hi ....

i had the same problem with my Acer Aspire TimelineU . After days of searching and testing i simply removed the Device MAC Address in the connection manager and it works....
craig100
Level 2
Level 2
Posts: 91
Joined: Mon Nov 07, 2011 1:37 pm
Location: Slough, UK

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by craig100 »

moien57 wrote:Hi ....

i had the same problem with my Acer Aspire TimelineU . After days of searching and testing i simply removed the Device MAC Address in the connection manager and it works....
Fantastic. I did the same and it worked. Doesn't reconnect after a suspend, but does after a full re-boot.

Thanks,

Craig
craig100
Level 2
Level 2
Posts: 91
Joined: Mon Nov 07, 2011 1:37 pm
Location: Slough, UK

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by craig100 »

Spoke too soon. The day I did it, it was great. Now it doesn't matter whether I have a MAC address or not, it connects but doesn't resolve. That's for WiFi. For Mobile it connects and works for 5 mins, then has to be totally rebooted for another 5 mins of use. This is totally unacceptable performance. As there's quite a few of these wifi issues reported I hope someone's looking into it as a matter of urgency. It's cripplingly embarrassing to turn up at a client's and not be able to work as a web developer when you can't connect to the web!
JeremyB
Level 20
Level 20
Posts: 11659
Joined: Fri Feb 21, 2014 8:17 am

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by JeremyB »

I heard that adding the BSSID for the access point may help because it prevents the wifi card from looking for other access points
JeremyB
Level 20
Level 20
Posts: 11659
Joined: Fri Feb 21, 2014 8:17 am

Re: Upgraded to 17.1 from 14, wifi now slow and intermittent

Post by JeremyB »

Any one who has this issue should be filing a bug report https://bugs.launchpad.net/linuxmint/+filebug or even install ubuntu and file bug reports on them, start here https://help.ubuntu.com/community/ReportingBugs
Or go to the existing bug report and click affects me but don't add comments on somebody elses bug report
Post Reply

Return to “Wireless”