Cannot upgrade due to problems?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
kcredden
Level 1
Level 1
Posts: 4
Joined: Sat Jan 18, 2014 1:55 pm

Cannot upgrade due to problems?

Post by kcredden »

Guys: I'm having some serious problems. I cannot upgrade at all.

Here is the lastest copy/paste from a terminal:

Code: Select all

zeus KC Redden # apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  console-setup gstreamer0.10-plugins-ugly hunspell-en-us initramfs-tools
  initscripts keyboard-configuration kpartx libalgorithm-diff-xs-perl
  libgnomevfs2-0 libgnomevfs2-common libio-pty-perl liblist-moreutils-perl
  liblocale-gettext-perl libnetpbm10 libnih-dbus1 libnih-dbus1:i386 libnih1
  libnih1:i386 libsub-name-perl libtext-charwidth-perl netpbm
  python-cupshelpers system-config-printer-gnome ttf-punjabi-fonts xorg
  xserver-xorg-video-all
The following packages will be upgraded:
  bind9-host binutils bluetooth bluez-alsa bluez-alsa:i386 bluez-cups
  bluez-gstreamer ca-certificates chromium-browser chromium-browser-l10n
  chromium-codecs-ffmpeg-extra cinnamon-translations clamav clamav-base
  clamav-freshclam dnsutils ecryptfs-utils firefox firefox-locale-en
  gir1.2-gnomebluetooth-1.0 gir1.2-gudev-1.0 gnome-bluetooth gnome-keyring
  gparted icedtea-7-jre-jamvm krb5-locales language-pack-en
  language-pack-en-base language-pack-gnome-en language-pack-gnome-en-base
  libavc1394-0 libavc1394-0:i386 libbind9-90 libbluetooth3 libclamav6
  libdbus-glib-1-2 libdbus-glib-1-2:i386 libdns100 libdrm-intel1
  libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdv4 libdv4:i386 libecryptfs0 libgnome-bluetooth11                       
  libgudev-1.0-0 libgudev-1.0-0:i386 libice6 libice6:i386 libicu52 libisc95                      
  libisccc90 libisccfg90 libjasper1 libjasper1:i386 libjpeg-progs libjpeg8                       
  libjpeg8:i386 liblightdm-gobject-1-0 liblightdm-qt-3-0 liblwres90                              
  libnautilus-extension1a libnss3 libnss3:i386 libnss3-1d libnss3-nssdb                          
  libpam-gnome-keyring libpam-systemd libpoppler-qt4-4 libpulsedsp:i386                          
  libpulsedsp libsm6 libsm6:i386 libsmbclient libsystemd-daemon0                                 
  libsystemd-journal0 libsystemd-login0 libvisual-0.4-0 libvisual-0.4-0:i386                     
  libwbclient0 libxdmcp6 libxdmcp6:i386 libxmu6 libxmu6:i386 libxpm4 libxss1                     
  libxss1:i386 lightdm mint-flashplugin-steam mint-translations mintsystem                       
  multiarch-support nautilus-data ntpdate openjdk-7-jre openjdk-7-jre-headless
  openjdk-7-jre-lib pulseaudio-module-bluetooth pulseaudio-module-x11
  pulseaudio-utils python-samba rsyslog sa-compile samba samba-common
  samba-common-bin samba-dsdb-modules samba-libs smbclient spamassassin spamc
  system-config-printer-common system-config-printer-udev systemd-services
  thunderbird thunderbird-locale-en tzdata tzdata-java unattended-upgrades
  unzip xserver-common xserver-xephyr xserver-xorg-core
  xserver-xorg-video-intel
127 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
Need to get 0 B/209 MB of archives.
After this operation, 9,866 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  libjpeg8 libjpeg8:i386 libxdmcp6 libxdmcp6:i386 libxss1 libxss1:i386
  libdbus-glib-1-2 libdbus-glib-1-2:i386 libdv4 libdv4:i386 libice6
  libice6:i386 libsm6 libsm6:i386 libvisual-0.4-0 libvisual-0.4-0:i386 libxmu6
  libxmu6:i386 libxpm4 libavc1394-0 libavc1394-0:i386 libjpeg-progs
Install these packages without verification? [y/N] y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 249212 files and directories currently installed.)
Preparing to unpack .../libjpeg8_8d-1+deb7u1_i386.deb ...
De-configuring libjpeg8:amd64 (8c-2ubuntu8) ...
Unpacking libjpeg8:i386 (8d-1+deb7u1) over (8c-2ubuntu8) ...
dpkg: error processing archive /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:i386 1.3.0-0ubuntu2
Preparing to unpack .../libjpeg8_8d-1+deb7u1_amd64.deb ...
De-configuring libjpeg8:i386 (8c-2ubuntu8) ...
Unpacking libjpeg8:amd64 (8d-1+deb7u1) over (8c-2ubuntu8) ...
dpkg: error processing archive /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:amd64 1.3.0-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb
 /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
This has been going on, for months. If I do try to force the upgrades, it destorys my system, and I have to restore from an image.

Is there something missing? Or something I need to fix deeper than this? This has to be fixed, so asking for help.
User avatar
Fornhamfred
Level 6
Level 6
Posts: 1243
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Cannot upgrade due to problems?

Post by Fornhamfred »

I am unable to suggest a resolution at the moment but it would be useful for you to give us more information.

1. What are you upgrading from and to.

2. Full details of your system.

3. How you have mint installed i.e do you have a separate root and home partition
User avatar
karlchen
Level 21
Level 21
Posts: 13074
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Cannot upgrade due to problems?

Post by karlchen »

Hello, ckredden.

One, the main source of trouble will be this:

Code: Select all

    Unpacking libjpeg8:i386 (8d-1+deb7u1) over (8c-2ubuntu8) ...
    dpkg: error processing archive /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb (--unpack):
     trying to overwrite '/usr/lib/i386-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:i386 1.3.0-0ubuntu2
    Preparing to unpack .../libjpeg8_8d-1+deb7u1_amd64.deb ...
    De-configuring libjpeg8:i386 (8c-2ubuntu8) ...
    Unpacking libjpeg8:amd64 (8d-1+deb7u1) over (8c-2ubuntu8) ...
    dpkg: error processing archive /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_amd64.deb (--unpack):
     trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:amd64 1.3.0-0ubuntu2
    Errors were encountered while processing:
     /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb
     /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
The shared library libjpeg.so.8 is brought along in two conflicting software packages: libjpeg-turbo8 and libjpeg8_8d-1+deb7u1.

Please, run the commandline

Code: Select all

sudo apt-cache policy libjpeg8
and post the screen output here.
Also, please, post the output of

Code: Select all

inxi -Sr
here.
I strongly suspect you have added a PPA to your source list files which causes the conflict.

Further:
The list of software packages which are on status "hold" seems long to me. Such "held" packages can cause conflicts, too.

Cheers,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
kcredden
Level 1
Level 1
Posts: 4
Joined: Sat Jan 18, 2014 1:55 pm

Re: Cannot upgrade due to problems?

Post by kcredden »

Thanks for the help, folks: I'm sorry for the delay, collage is running me ragged at times.

Here is the first command I was asked to run:

Code: Select all

zeus kcredden # sudo apt-cache policy libjpeg8
libjpeg8:
  Installed: 8c-2ubuntu8
  Candidate: 8d-1+deb7u1
  Version table:
     8d-1+deb7u1 0
        500 http://ftp.debian.org/debian/ wheezy/main amd64 Packages
 *** 8c-2ubuntu8 0
        500 http://mirrors.liquidweb.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
zeus kcredden #
and the second

Code: Select all

zeus kcredden # inxi -Sr
System:    Host: zeus Kernel: 3.13.0-37-generic x86_64 (64 bit) Desktop: KDE 4.14.2 Distro: Linux Mint 17.1 Rebecca
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp.debian.org/debian/ wheezy main contrib non-free
           deb http://ftp.debian.org/debian/ wheezy main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/removed.list
           deb http://archive.removed/ubuntu trusty-removed apps
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com rebecca main upstream import
           deb http://extra.linuxmint.com rebecca main
           deb http://mirrors.liquidweb.com/ubuntu trusty main restricted universe multiverse
           deb http://mirrors.liquidweb.com/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner
           Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
           deb-src http://packages.linuxmint.com rebecca main upstream import
           deb-src http://extra.linuxmint.com rebecca main
           deb-src http://mirrors.liquidweb.com/ubuntu trusty main restricted universe multiverse
           deb-src http://mirrors.liquidweb.com/ubuntu trusty-updates main restricted universe multiverse
           deb-src http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb-src http://archive.canonical.com/ubuntu/ trusty partner
zeus kcredden #
Let me also add to this, that I'm using this exact same DVD on my laptop, an Lenovo X201, but I haven't had the same problem with upgrading it. If you need info off it, just ask.
User avatar
karlchen
Level 21
Level 21
Posts: 13074
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Cannot upgrade due to problems?

Post by karlchen »

Hello, kcredden.

This output

Code: Select all

    zeus kcredden # sudo apt-cache policy libjpeg8
    libjpeg8:
      Installed: 8c-2ubuntu8
      Candidate: 8d-1+deb7u1
      Version table:
         8d-1+deb7u1 0
            500 http://ftp.debian.org/debian/ wheezy/main amd64 Packages
     *** 8c-2ubuntu8 0
            500 http://mirrors.liquidweb.com/ubuntu/ trusty/main amd64 Packages
            100 /var/lib/dpkg/status
    zeus kcredden #
shows that the package libjpeg8 has got two incompatible sources on your system: Debian Wheezy and Ubuntu.
The inxi report reveals you are using the correct Mint repositories on your Mint 17.1, but also Debian Wheezy repositories, which you should not do.

Remove the Debian Wheezy repositories from the sources list files. Refresh the software list. (sudo apt-get update). Try to run the actual updating process (sudo apt-get upgrade).

HTH,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
kcredden
Level 1
Level 1
Posts: 4
Joined: Sat Jan 18, 2014 1:55 pm

Re: Cannot upgrade due to problems?

Post by kcredden »

Karl:

Thanks for the help. I've been though four upgrade cycles, and everyone worked like a charm. Not a single problem with any. I think I finally found the linux to get me away from Debian finally. Now just need to address a few more problems and I can sit back and relax.

Kc
Post Reply

Return to “Other topics”