KDE in Mint 12

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
varrtto
Level 1
Level 1
Posts: 3
Joined: Sun May 06, 2012 2:56 pm

KDE in Mint 12

Post by varrtto »

Hi! I just installed KDE in Linux Mint 12 (not KDE version) and I just dont know how to install Icon tasks. When using some PPA ive find, it tells my it depends on some kubuntu ppa that im not using, and when try to compile it from source i get:
$ sudo cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The CXX compiler identification is GNU
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/varrtto/.kde/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:22 (find_package)


-- Configuring incomplete, errors occurred!
But i would really like to install it from PPA. Any ideas?
User avatar
Danko8321
Level 4
Level 4
Posts: 206
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: KDE in Mint 12

Post by Danko8321 »

Sorry, what?

Why are you installing KDE like that? KDE is already in the Mint repositories (V 4.74) and ready to install as a simple apt-get. You don't need a PPA for KDE, just run:

Code: Select all

sudo apt-get install kde-full
to install all KDE (With Kate, KOffice, Konsole, etc.)

Also, I believe the Kubuntu-Desktop metapackage is available in the Mint repos. Try:

Code: Select all

sudo apt-get install kubuntu-desktop
and see where that gets you as well.

You don't really have to compile KDE, just relax and apt-get it, this ain't Gentoo.

Cheers. Danko.
Cheer up! Things are getting worse at a slower rate.
varrtto
Level 1
Level 1
Posts: 3
Joined: Sun May 06, 2012 2:56 pm

Re: KDE in Mint 12

Post by varrtto »

NOT trying to compile KDE, I've allready installed it. I want to install "Icon tasks", a plasmoid.

cheers.
User avatar
Danko8321
Level 4
Level 4
Posts: 206
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: KDE in Mint 12

Post by Danko8321 »

varrtto wrote:NOT trying to compile KDE, I've allready installed it. I want to install "Icon tasks", a plasmoid.

cheers.
Sorry, the compiling part activated my "nag newbie" mode. I truly apologize for not reading thoroughly. Now, is this what you are looking for? And, if so, have you tried the method that it explains?
Cheer up! Things are getting worse at a slower rate.
varrtto
Level 1
Level 1
Posts: 3
Joined: Sun May 06, 2012 2:56 pm

Re: KDE in Mint 12

Post by varrtto »

Yes, but when I try to add de PPA I get:
$ sudo add-apt-repository ppa:gnumdk/ppa
You are about to add the following PPA to your system:
PPA for Bellegarde Cedric
Warning: This PPA depends on ppa:kubuntu-ppa/backports
More info: https://launchpad.net/~gnumdk/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it
Even if I allow to add it, update and then install it:
sudo apt-get install plasma-widget-icon-tasks
It tells me there's no package with that name. I dont want to add Kubuntu backports PPA, not sure if something is gonna get rainbows up.

Any clues?
User avatar
Danko8321
Level 4
Level 4
Posts: 206
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: KDE in Mint 12

Post by Danko8321 »

varrtto wrote:Yes, but when I try to add de PPA I get:
$ sudo add-apt-repository ppa:gnumdk/ppa
You are about to add the following PPA to your system:
PPA for Bellegarde Cedric
Warning: This PPA depends on ppa:kubuntu-ppa/backports
More info: https://launchpad.net/~gnumdk/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it
Even if I allow to add it, update and then install it:
sudo apt-get install plasma-widget-icon-tasks
It tells me there's no package with that name. I dont want to add Kubuntu backports PPA, not sure if something is gonna get rainbows up.

Any clues?
Hmmm... Well, the Kubuntu Backports PPA is not precisely hell, but I wouldn't recommend that if you are Running the Main edition (have heard of people on KDE Mint using it though). So, big no no to the Kubuntu Backports.

However, I see in their launchpad page they only have to packages, one called "kde-workspace" and another one called "kde-appmenu". Launchpad is most likely rebuilding packages or the maintainers are uploading new versions (or both) so you will have to wait and see if the problem goes away and try another day (this usually gets resolved in less than two days, so it's no big deal). No more to do (unless, of course, they haven't rebuilt the packages and gone back online in three days; that would be a worry).

EDIT: well you just look at that...
PPA for Bellegarde Cedric wrote:Warning: This PPA depends on ppa:kubuntu-ppa/backports
:lol: it seems you'll have to add the Kubuntu Backports PPA if you want that plasmoid
Cheer up! Things are getting worse at a slower rate.
Post Reply

Return to “Newbie Questions”