Bluetooth does not work [solved]

Forum rules
Before you post please read how to get help
User avatar
seeley
Level 7
Level 7
Posts: 1867
Joined: Sun Mar 07, 2010 7:20 am

Bluetooth does not work [solved]

Post by seeley »

Hi!
http://community.linuxmint.com/iso/view/125
MATE amd64: ...#106... Bluetooth success
http://community.linuxmint.com/iso/view/124
MATE i386: Bluetooth failure.
I installed LM 13 MATE 64 bit, but BT does not work
(after having started it nothing happened).
BTW: No problem with Cinnamon.
seeley
Last edited by seeley on Mon May 28, 2012 9:46 am, edited 1 time in total.
seeley @ Linux multiboot
remoulder
Level 17
Level 17
Posts: 7624
Joined: Fri May 09, 2008 1:14 pm

Re: Bluetooth does not work

Post by remoulder »

Bug reports need to be posted on the blog page
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
seeley
Level 7
Level 7
Posts: 1867
Joined: Sun Mar 07, 2010 7:20 am

Re: Bluetooth does not work

Post by seeley »

DID IT BEFORE, BUT MY POSTING WAS DELETED.
seeley @ Linux multiboot
water spirit
Level 2
Level 2
Posts: 84
Joined: Sun Aug 01, 2010 12:32 am
Location: Queensland

Re: Bluetooth does not work

Post by water spirit »

seeley wrote:Hi!
http://community.linuxmint.com/iso/view/125
MATE amd64: ...#106... Bluetooth success
http://community.linuxmint.com/iso/view/124
MATE i386: Bluetooth failure.
I installed LM 13 MATE 64 bit, but BT does not work
(after having started it nothing happened).
BTW: No problem with Cinnamon.
seeley
I have the same situation with Bluetooth and LM 13 MATE 64 bit on one Laptop but no problem with Cinnamon on another Laptop.
User avatar
seeley
Level 7
Level 7
Posts: 1867
Joined: Sun Mar 07, 2010 7:20 am

Re: Bluetooth does not work

Post by seeley »

Hi!
After having downloaded and installed the final release Maya MATE 64 bit: same problem - no BT. Why? LMDE 2012 MATE BT works.
Even CentoS and Snowlinux MATE RC do not have a BT problem.
seeley
seeley @ Linux multiboot
User avatar
seeley
Level 7
Level 7
Posts: 1867
Joined: Sun Mar 07, 2010 7:20 am

Re: Bluetooth does not work

Post by seeley »

Hi!
Now BT works. Steps:
1. Remove MATE BT
2. Install Blueman and other packages; summary:
FOTObluez.png
3. Start BT Manager from the Menu -> new BT applet
4. search and connect.
seeley
seeley @ Linux multiboot
rea987
Level 1
Level 1
Posts: 8
Joined: Wed Jun 06, 2012 6:51 pm

Re: Bluetooth does not work

Post by rea987 »

seeley wrote:Hi!
Now BT works. Steps:
1. Remove MATE BT
2. Install Blueman and other packages; summary:
FOTObluez.png
3. Start BT Manager from the Menu -> new BT applet
4. search and connect.
seeley
That is great! I successfully added my bluetooth mouse after installing mentioned packages. Thank you!
User avatar
daveinuk
Level 7
Level 7
Posts: 1555
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.
Contact:

Re: Bluetooth does not work [solved]

Post by daveinuk »

I've been having trouble with BT services not being 'found' even though they're there but on Mint 12, . . . . I will have a search through the software center tonight and see if this fixes it, never thought to look for alternative BT services thanks !
User avatar
LatinPoet
Level 1
Level 1
Posts: 2
Joined: Sun Jun 17, 2012 2:15 pm
Location: California, United States

Re: Bluetooth does not work [solved]

Post by LatinPoet »

I can confirm that bluetooth does work on LM 13 Mate 64-bit. I uninstalled Mate-BT, and installed all the bluez packages with Synaptic, but bluetooth would still not work. So I rebooted the computer, started Blueman Bluetooth Manager, hit search, and what do you know? My IOGEAR GBU421 USB bluetooth adapter found my Motorola MOTOROKR S305 wireless headphones! I get a great signal every time I use the headphones, and bluetooth starts automatically every time I boot my computer. The only minor issue is that the indicator light on the IOGEAR adapter does not turn on, but I don't find it to be a problem as the Blueman applet on the taskbar shows me that bluetooth indeed is turned on. Enjoy!
Libertas, semper libertas!
flashfr33z
Level 1
Level 1
Posts: 8
Joined: Sun Jul 22, 2012 1:32 am

Re: Bluetooth does not work [solved]

Post by flashfr33z »

What if, when you launch Blueman, It doesn't allow you to search for a device, because when I launch it, the Sreen (of the application) if transparent grey, I can see all the options, but not select them -_-
User avatar
seeley
Level 7
Level 7
Posts: 1867
Joined: Sun Mar 07, 2010 7:20 am

Re: Bluetooth does not work [solved]

Post by seeley »

Hi!
Some times it is necessary to switch off (hardware) BT and again ON or disable (software) and ENABLE again BT.
seeley @ Linux multiboot
koshari
Level 1
Level 1
Posts: 3
Joined: Tue May 22, 2012 2:10 am

Re: Bluetooth does not work

Post by koshari »

why is this thread labeled solved when the bug still exists? and adding another bluetooth package is only a workaround,
barrad0s
Level 1
Level 1
Posts: 2
Joined: Wed Oct 10, 2012 5:39 pm

Re: Bluetooth does not work [solved]

Post by barrad0s »

Hello guys, linux newbie here. I have the same problem, with the bluetooth not working. Now, i have found blueman, and know how to install that, but i'm not sure how to uninstall mate bt. I went to Synaptic Package Manager and searched for mate bt, but too many things show and i just don't want to uninstall the wrong thing, so i'm just asking here for help before. How/where do i uninstall mate bt from?

Thanks, appreciate the help.
fullmoonguru
Level 2
Level 2
Posts: 98
Joined: Sat Mar 12, 2011 11:14 am

Re: Bluetooth does not work [solved]

Post by fullmoonguru »

Blueman didn't work reliably for me in Mate. I don't remember seeing teh post above that has the image of all the specific dependancies so maybe I missed something. Anyway, here is what works for me. In the terminal:

Code: Select all

sudo -s
apt-get update
apt-get install gnome-bluetooth
bluetooth-wizard (this will start the wizard)
Setup your device & it should work.
fullmoonguru
Level 2
Level 2
Posts: 98
Joined: Sat Mar 12, 2011 11:14 am

Re: Bluetooth does not work [solved]

Post by fullmoonguru »

Well that works with a fesh install, but I just updated & it killed my bluetooth. Now I can't get it back. This is really frustrating.
barrad0s
Level 1
Level 1
Posts: 2
Joined: Wed Oct 10, 2012 5:39 pm

Re: Bluetooth does not work [solved]

Post by barrad0s »

fullmoonguru wrote:Blueman didn't work reliably for me in Mate. I don't remember seeing teh post above that has the image of all the specific dependancies so maybe I missed something. Anyway, here is what works for me. In the terminal:

Code: Select all

sudo -s
apt-get update
apt-get install gnome-bluetooth
bluetooth-wizard (this will start the wizard)
Setup your device & it should work.

This is what i get from that:

gnome-bluetooth is already the newest version.
bluetooh-wizard
No command 'bluetooh-wizard' found, did you mean:
Command 'bluetooth-wizard' from package 'gnome-bluetooth' (main)
bluetooh-wizard: command not found

But i do have two icons for bluetooth on my desktop now, when trying to connect through both, neither works.
fullmoonguru
Level 2
Level 2
Posts: 98
Joined: Sat Mar 12, 2011 11:14 am

Re: Bluetooth does not work [solved]

Post by fullmoonguru »

You're missing the "t" in bluetooth.

Try:

bluetooth-wizard
c_malc
Level 1
Level 1
Posts: 8
Joined: Fri Jan 13, 2012 9:17 am

Re: Bluetooth does not work [solved]

Post by c_malc »

Bluetooth wouldn't detect anything for me, but after doing:
ctrl-alt-t sudo service bluetooth restart
it started working correctly
yohann
Level 1
Level 1
Posts: 3
Joined: Fri Oct 19, 2012 12:44 pm

Re: Bluetooth does not work [solved]

Post by yohann »

I removed the package "mate-bluetooth" and install the "blueman" package from synaptic. That's all, and it works. I have not remove/add any others package.
caractacus
Level 1
Level 1
Posts: 8
Joined: Tue Apr 12, 2011 11:18 am

Re: Bluetooth does not work [solved]

Post by caractacus »

Is Mate-Bluetooth broken? I was having the same problem.
Locked

Return to “MATE”