Chrome and Flash issues [solved]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
zer0ed
Level 1
Level 1
Posts: 8
Joined: Fri Jan 27, 2012 6:12 pm

Chrome and Flash issues [solved]

Post by zer0ed »

I have something that is completely beyond me, I can't figure out what is going on.
I'm currently running Mint 14 and latest version of Chrome stable but none of my flash plugin stuff is working as it should. Anything using flash (youtube, etc) shows a "couldn't load plugin" error. It was working fine earlier today and I've changed nothing.

Figuring something must have gone funny with a config, I deleted ~/.config/google-chrome and ~/.cache/google-chrome directories and then reloaded chrome.
I did not setup my google account so it wouldn't sync anything and everything worked... for about 3 minutes then the plugin errors started again.

I repeated the above, checked about:plugins url in chrome and it lists 10 plugins. I loaded youtube, it works fine.
A few minutes goes by (where I let the chrome sit idle) and flash problems again and youtube doesn't work. I check about:plugins again and the data has changed.. only 3 plugins are listed.

What is changing this plugins list? I have disabled sync and deleted user data files a few times and it still happens.
I've even created a new user account, logged in cinnamon as that user, loaded chrome and watched it happen all again.

I checked my apt logs to see if I've updated chrome, and yesterday I did so I rolled back to the older chrome version located in /var/cache/apt/archives.
It does it with older chrome versions also so I'm unsure what is going on.

I've even removed all flash plugin packages to see if there was some incompatibly issues with chrome's built in flash.. still problems!!

Anybody have any ideas, I'm all ears!
Last edited by zer0ed on Sat Feb 02, 2013 10:25 pm, edited 1 time in total.
BAlGaInTl
Level 1
Level 1
Posts: 3
Joined: Fri Feb 01, 2013 11:01 pm

Re: Chrome and Flash issues - worked fine earlier

Post by BAlGaInTl »

I'm having this same issue.

Just installed 64-bit Mint.

Installed the 64-bit chrome and immediately noticed the issue.

The default Firefox install is working fine.
zer0ed
Level 1
Level 1
Posts: 8
Joined: Fri Jan 27, 2012 6:12 pm

Re: Chrome and Flash issues - worked fine earlier

Post by zer0ed »

Interesting, it was working earlier today. can you check your about:plugins and see how many are listed..

I'm wondering if something in the plugin list is "pushed" from the google end of things. Maybe it's something that they changed upstream today.
I just noticed it stopped working in the afternoon here (eastern standard time).

Very curious.

Edit: I'm also using 64 bit Mint and Chrome
BAlGaInTl
Level 1
Level 1
Posts: 3
Joined: Fri Feb 01, 2013 11:01 pm

Re: Chrome and Flash issues - worked fine earlier

Post by BAlGaInTl »

Three are listed:

libpepflashplayer
Chrome PDF Viewer
Adobe Flash Player
User avatar
tdockery97
Level 14
Level 14
Posts: 5059
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: Chrome and Flash issues - worked fine earlier

Post by tdockery97 »

Disable libpepflashplayer and everything will work fine.
Mint Cinnamon 20
BAlGaInTl
Level 1
Level 1
Posts: 3
Joined: Fri Feb 01, 2013 11:01 pm

Re: Chrome and Flash issues - worked fine earlier

Post by BAlGaInTl »

tdockery97 wrote:Disable libpepflashplayer and everything will work fine.
That worked like a charm.

Care to elaborate why that works?
User avatar
tdockery97
Level 14
Level 14
Posts: 5059
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: Chrome and Flash issues - worked fine earlier

Post by tdockery97 »

Not sure. There must be a conflict with both shockwave flash and Chrome's pepper flash trying to run at the same time. Anyway, I can't take credit for the solution...I found it on the web.
Mint Cinnamon 20
zer0ed
Level 1
Level 1
Posts: 8
Joined: Fri Jan 27, 2012 6:12 pm

Re: Chrome and Flash issues - worked fine earlier

Post by zer0ed »

It does seem to work, thanks for the workaround!

Youtube warns at the top of the site where a video banner is supposed to go "You need to upgrade your Adobe Flash Player to watch this video" but it seems to work elsewhere fine for now.

Curious as to how my plugin list is being changed.. I'm going to disconnect from the net and see if chrome is getting something pushed to it via internet.. which I assume.
zer0ed
Level 1
Level 1
Posts: 8
Joined: Fri Jan 27, 2012 6:12 pm

Re: Chrome and Flash issues - worked fine earlier

Post by zer0ed »

Apparently it's a problem for many users of different distros. I've just checked the official Chrome forum and there is a few posts all recent today.

One solution is to delete the pepperflash directory in ~/.config/google-chrome
User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: Chrome and Flash issues - worked fine earlier

Post by mockturtl »

zer0ed wrote:I'm wondering if something in the plugin list is "pushed" from the google end of things. Maybe it's something that they changed upstream today.
I just noticed it stopped working in the afternoon here (eastern standard time).
It shouldn't re-enable itself. That's a regression. (#150596)

Code: Select all

$ ls -alh .config/google-chrome/PepperFlash/
... Feb 1 20:41 11.5.31.138/
$ grep chrome /var/log/dpkg.log.1
2013-01-30 22:31:39 status installed google-chrome-unstable:amd64 26.0.1397.2-r179372
Image
User avatar
caf4926
Level 7
Level 7
Posts: 1883
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Chrome and Flash issues - worked fine earlier

Post by caf4926 »

zer0ed wrote:Apparently it's a problem for many users of different distros. I've just checked the official Chrome forum and there is a few posts all recent today.

One solution is to delete the pepperflash directory in ~/.config/google-chrome
Yes, I did see this
Guess a fix will get thru eventually

In the mean time, Chromium is fine
Linux Mint 19.3 Cinnamon
av8r0023
Level 1
Level 1
Posts: 21
Joined: Tue Feb 23, 2010 4:24 pm
Location: San Antonio, TX

Re: Chrome and Flash issues - worked fine earlier

Post by av8r0023 »

I'm also having this problem. I disabled the libpepflashplayer and everything seems to be working again, but... Now it's running an older version of flash, 11.2.202.243. The only reason I switched to Chrome over Firefox is flash updates. So confused? Guess I'll have to take up my beef with Google.
User avatar
caf4926
Level 7
Level 7
Posts: 1883
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Chrome and Flash issues - worked fine earlier

Post by caf4926 »

av8r0023 wrote:I'm also having this problem. I disabled the libpepflashplayer and everything seems to be working again, but... Now it's running an older version of flash, 11.2.202.243. The only reason I switched to Chrome over Firefox is flash updates. So confused? Guess I'll have to take up my beef with Google.
You'll all want to re-enable pepper flash
I just renamed .config/google-chrome/PepperFlash

Now I seem to have

Code: Select all

Adobe Flash Player (2 files) - Version: 11.5.31.137
Shockwave Flash 11.5 r31
Name:	Shockwa
Linux Mint 19.3 Cinnamon
braankoo
Level 1
Level 1
Posts: 2
Joined: Fri Feb 01, 2013 8:37 pm
Location: Belgrade

Re: Chrome and Flash issues - worked fine earlier

Post by braankoo »

same problem here.
everything worked fine until today :/

just disable libpepflashplayer and its working fine
zer0ed
Level 1
Level 1
Posts: 8
Joined: Fri Jan 27, 2012 6:12 pm

Re: Chrome and Flash issues - worked fine earlier

Post by zer0ed »

Solution from a Google Dev which I've been using since yesterday

"Hey folks,

Thanks for your reports. If you are seeing this issue on a Linux machine, please follow the steps below. If you are on a non-Linux machine, please start a different discussion thread.

Linux users, please try deleting the following file, and let us know if it helps:
~/.config/google-chrome/PepperFlash

We are investigating this specific Linux issue on our public issue tracker, and will continue to post updates there (and also here). "

Sources:
http://productforums.google.com/forum/# ... 5-false%5D
https://code.google.com/p/chromium/issu ... 173790#c31
mjones41
Level 1
Level 1
Posts: 9
Joined: Sat Jun 16, 2012 9:28 am

Re: Chrome and Flash issues [solved]

Post by mjones41 »

I renamed the folder;

~/.config/google-chrome/PepperFlash
to
~/.config/google-chrome/old PepperFlash

and it now works. It seemed safer than deleting. Hopefully a real fix coming soon.
av8r0023
Level 1
Level 1
Posts: 21
Joined: Tue Feb 23, 2010 4:24 pm
Location: San Antonio, TX

Re: Chrome and Flash issues [solved]

Post by av8r0023 »

I am now able to play flash videos with the libpepflashplayer with the latest update of Google Chrome.

1. update to the newest version of Chrome (24.0.1312.69 and above)
2. go to chrome://plugins/
3. click on "+Details" in the top right-hand corner.
4. scroll to Adobe Flash Player and enable the latest vesion (11.5.31.139 and above) and disable the 11.2 version. only one version can run at a time.
5. restart Chrome
6. test it out by playing a flash video, right click the video and see which version number pops up

Hope this helps.
rmh291
Level 1
Level 1
Posts: 1
Joined: Sun Feb 17, 2013 6:29 pm

Re: Chrome and Flash issues [solved]

Post by rmh291 »

I just installed Mint lisa 32 bit yesterday and Adobe flash plug in wouldn't work in Firefox or Chrome. I tried various things all day today and finally hit pay dirt with - see below- both Chrome & Firefox works now: (I chose Y at the end and it installed)

sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
gecko-mediaplayer unshield gstreamer0.10-plugins-bad-multiverse
gnome-mplayer libmjpegtools-1.9 libquicktime2 mint-flashplugin-11
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libnspr4 libnspr4-0d
Suggested packages:
msttcorefonts ttf-xfree86-nonfree xfs
The following packages will be REMOVED:
mint-flashplugin mint-meta-codecs
The following NEW packages will be installed:
flashplugin-installer libnspr4-0d
The following packages will be upgraded:
libnspr4
1 upgraded, 2 newly installed, 2 to remove and 403 not upgraded.
Need to get 157 kB of archives.
After this operation, 106 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Post Reply

Return to “Software & Applications”