Airplane mode won't turn off [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Aoi v1
Level 1
Level 1
Posts: 8
Joined: Sun Mar 17, 2013 12:03 pm

Airplane mode won't turn off [SOLVED]

Post by Aoi v1 »

Hello everyone, I'll try to explain my problem as brief and clear as possible:

I dual boot LM and Win7. When in LM, I wanted to click on network preferences, but accidentally clicked over wireless and turned it off. My laptop (Vaio VPCCA-17FL) has a physical button for turning wifi off, and an LED indicator. The led turned off, wifi went off and airplane mode turned on. Now it's stucked :/ I thought "ah, whatever, click wireless on again..." well, it seems airplane mode doesn't want to turn off! I click it but nothing happens, same as with clickin over wireless (it does nothing), even if I turn the physical switch off and on again. Even worst, when I boot Win7, there is no wifi! The physical switch doesn't work and I can't find something similar to "airplane mode" in there to fix it... what can I do? Is there anything I can type in terminal to check it or enable it?
Last edited by Aoi v1 on Mon Jul 01, 2013 10:11 am, edited 1 time in total.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Airplane mode won't turn off

Post by AlbertP »

Could you open Terminal from the menu, run this command and post the output:

Code: Select all

rfkill list
Maybe on Windows there is some VAIO tool to manage wireless, which can turn it on again - there is HP Wireless Assistant for example on HP laptops.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Aoi v1
Level 1
Level 1
Posts: 8
Joined: Sun Mar 17, 2013 12:03 pm

Re: Airplane mode won't turn off

Post by Aoi v1 »

Thanks a lot Albert, I'll try checking the VAIO software (it would be the first time it could come in handy). This is the output:

Code: Select all

0: sony-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: sony-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Airplane mode won't turn off

Post by AlbertP »

Please run this in terminal:

Code: Select all

sudo rfkill unblock all
Then please run rfkill list again to see if anything has changed.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Aoi v1
Level 1
Level 1
Posts: 8
Joined: Sun Mar 17, 2013 12:03 pm

Re: Airplane mode won't turn off

Post by Aoi v1 »

Ah, worked charms. Thanks a lot Albert! It immediately enabled wifi, this is the output now:

Code: Select all

0: sony-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: sony-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
Thanks! I think this is a solved thread now... shall I rename it/close it?

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Airplane mode won't turn off

Post by AlbertP »

Yes, please edit the first post to add [solved] to the title.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

julianbran
Level 1
Level 1
Posts: 1
Joined: Thu Oct 09, 2014 8:32 pm

Re: Airplane mode won't turn off [SOLVED]

Post by julianbran »

I tried the sudo command, it asked me for my password, but when I tried to type it, it wouldn't let me.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Airplane mode won't turn off [SOLVED]

Post by AlbertP »

You don't see anything when you type your password, but you can just type it and press Enter.

This was just a short question, so I didn't mind replying in a "solved" topic.
In future it's better not to post here because solved topics get overlooked. If you have any further questions please open a new topic (you may post a link to this topic there to make clear what you're trying to do).
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Newbie Questions”