desktop effects "could not be enabled"

Forum rules
Before you post please read how to get help
Post Reply
divindavid

desktop effects "could not be enabled"

Post by divindavid » Sun Jul 20, 2008 11:09 am

hello, i am new to linux mint but not new to linux so this has been a lot of fun so far. for the past 4 days i have been trying to find a distro to work well with my new IBM T41. i tried fedora 8 and 9 ubuntu 8.04 open susa (i think thats what it is) and then i made my faw to linux mint and i love it on my old computer i ran ubuntu 7.10 but then the inverter blew. ok back to what i need help with.
in Fedora and ubuntu desktop effects worked right out of the box with no problem. but with this it does not happen it goes "desktop effects could not be enabled" on me. i never had to install drivers for my video card. i think i have a radon 7500???? i think but i will have to double check. if you have any ancewers or sugestions for me please help because that would be a great help. oh.... and my specs are
IBM T41
512mb of ram
40gig HDD
32mb of video ram
1.6GHz pentium M processor

David D

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: desktop effects "could not be enabled"

Post by Husse » Sun Jul 20, 2008 2:25 pm

this could be a driver issue
I suppose you installed Elyssa (always include at least the version of Mint you use) so launch EnvyNG and let it so its job
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
67GTA
Level 6
Level 6
Posts: 1300
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: desktop effects "could not be enabled"

Post by 67GTA » Sun Jul 20, 2008 2:29 pm

I don't use compiz, but I remember there was a small utility you could run in a terminal to give you a diagnostic look. I think it is

Code: Select all

compiz-check
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: desktop effects "could not be enabled"

Post by Husse » Sun Jul 20, 2008 4:22 pm

Correct ( compiz-check)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

divindavid
Level 1
Level 1
Posts: 4
Joined: Sun Jul 20, 2008 11:13 am

Re: desktop effects "could not be enabled"

Post by divindavid » Mon Jul 21, 2008 1:47 pm

cool i did that. here is the out come

Code: Select all

david@david-laptop ~ $     compiz-check

Gathering information about your system...

 Distribution:          Linux Mint 
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
 Driver in use:         radeon
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [ OK ]
and so it seems that everything is good when i try to enable desktop effects it says that they could not be enabled. any ideas????????

David

User avatar
67GTA
Level 6
Level 6
Posts: 1300
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: desktop effects "could not be enabled"

Post by 67GTA » Mon Jul 21, 2008 2:16 pm

You might try starting it in a terminal to try and catch an error

Code: Select all

compiz
It will automatically try to start emerald also. If it fails, you will lose your window decorations. Just run

Code: Select all

metacity --replace
in a terminal to revert back to the default metacity window manager.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

divindavid
Level 1
Level 1
Posts: 4
Joined: Sun Jul 20, 2008 11:13 am

Re: desktop effects "could not be enabled"

Post by divindavid » Mon Jul 21, 2008 6:14 pm

67GTA wrote:You might try starting it in a terminal to try and catch an error

Code: Select all

compiz
It will automatically try to start emerald also. If it fails, you will lose your window decorations. Just run

Code: Select all

metacity --replace
in a terminal to revert back to the default metacity window manager.
jigga what....... i get an error on the first one.,

divindavid
Level 1
Level 1
Posts: 4
Joined: Sun Jul 20, 2008 11:13 am

Re: desktop effects "could not be enabled"

Post by divindavid » Mon Jul 21, 2008 6:43 pm

67GTA wrote:You might try starting it in a terminal to try and catch an error

Code: Select all

compiz
It will automatically try to start emerald also. If it fails, you will lose your window decorations. Just run

Code: Select all

metacity --replace
in a terminal to revert back to the default metacity window manager.
for the first code i get

Code: Select all

david@david-laptop ~ $     compiz
Checking for Xgl: not present. 
Found laptop using ati driver. 
aborting and using fallback: /usr/bin/metacity 
then it just hangs there
then i run the second code and it shows the code and when i press enter nothing happens

Post Reply

Return to “MATE”