./configure complains of freetype2 >=9.3.0

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

./configure complains of freetype2 >=9.3.0

Post by palo » Thu Dec 26, 2013 2:57 am

A simple noob at this but I have been trying to configure a package for install. Several errors I eliminated but hit a brick wall with this one...

Code: Select all

checking whether imported symbols can be declared weak... yes
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking for pthread_kill in -lpthread... yes
checking for pthread_rwlock_t... yes
checking for multithread API to use... posix
checking which threads API is used... POSIX
checking whether to build POSIX threads spinlock code... yes
checking whether to enable chained pool built... yes
checking whether to enable pass through built... yes
checking whether to enable one big built... yes
configure: Finished Eina checks
configure: Start Eet checks
checking for libjpeg... yes
checking for zlib... yes
checking for EET... yes
configure: Finished Eet checks
configure: Start Eo checks
configure: Finished Eo checks
configure: Start Evas checks
checking for dlsym... yes
configure: error: pkg-config missing freetype2 >= 9.3.0
As far as I can tell Freetype2 does not version that high (2.5.2 atm) but I may be not understanding what it is saying. My Google-Fu has not helped. Can anyone give any guidance on this. Please...

Pat

Monsta
Level 10
Level 10
Posts: 3000
Joined: Fri Aug 19, 2011 3:46 am

Re: ./configure complains of freetype2 >=9.3.0

Post by Monsta » Thu Dec 26, 2013 3:09 am

Very interesting. If you install libfreetype6-dev and look at the version provided in the .pc file (that's what pkg-config looks at), it will be different from the package version!

Code: Select all

$ pkg-config --modversion freetype2
16.1.10
In case you'll want to look at the file yourself, it's /usr/lib/x86_64-linux-gnu/pkgconfig/freetype2.pc (that's for amd64 arch).

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: ./configure complains of freetype2 >=9.3.0

Post by palo » Thu Dec 26, 2013 8:52 am

Monsta> Thanks so much for the help - you were right on: installing libfreetype6-dev satisfied the dependency for freetype2. After that I was able to figure out some other needed dependencies. It just seems that the whole process is a kind of guessing game and not straight forward - looking through synaptic at names and descriptions and then trial and error installs. There must be a better way to find these missing packages. For the latest one I have tried libxcb-render0-dev libx11-dev libx11-xcb-dev libxcb-keysyms1-dev. Would there be any logical clues in the output to lead me to finding what package to install????

Code: Select all

<snip>
checking for dlsym... yes
checking whether to enable OpenGL Cocoa rendering backend... no
checking whether OpenGL Cocoa rendering backend will be built... no
checking whether to enable OpenGL SDL rendering backend... no
checking whether OpenGL SDL rendering backend will be built... no
checking whether to enable Software GDI rendering backend... no
checking whether Software GDI rendering backend will be built... no
checking whether to enable Software DirectDraw rendering backend... no
checking whether Software DirectDraw rendering backend will be built... no
checking whether to enable Wayland Egl rendering backend... no
checking whether Wayland Egl rendering backend will be built... no
checking whether to enable Wayland Shm rendering backend... no
checking whether Wayland Shm rendering backend will be built... no
checking whether to enable Drm rendering backend... no
checking whether Drm rendering backend will be built... no
checking whether to build Software XCB Engine... no
checking whether to enable Software Xlib rendering backend... yes
checking how to find X... use pkg-config
checking for EFL_X11... yes
checking X11/X.h usability... yes
checking X11/X.h presence... yes
checking for X11/X.h... yes
configure: error: Software Xlib dependencies not found
Again any help is appreciated.

Pat

Monsta
Level 10
Level 10
Posts: 3000
Joined: Fri Aug 19, 2011 3:46 am

Re: ./configure complains of freetype2 >=9.3.0

Post by Monsta » Thu Dec 26, 2013 9:01 am

I think it's better to ask the authors of that software, or try to find some info on their websites/forums/mailing lists.

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: ./configure complains of freetype2 >=9.3.0

Post by palo » Thu Dec 26, 2013 11:49 am

Monsta wrote:I think it's better to ask the authors of that software, or try to find some info on their websites/forums/mailing lists.
Yes the website does have a long list of required packages. For example, it lists freetype2 but doesn't say expect to find it in a package called libfreetype6-dev. I guess doing anything in Linux requires one be a master of the universe. Unfortunately there is no forum and I won't join the mailing list because it will expose my e-mail address and I'm not about to make another addy for that. It's just a bit frustrating trying to learn this stuff.

Thanks
Pat

Post Reply

Return to “Other topics”