[Solved] Synaptics TouchPad Driver / Toshiba Satellite

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

[Solved] Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

From a previous thread of mine:

White Phoenix
Everything is working except the touch pad now is completely disabled. I had to get out my mouse and plug that in, like I had thought of doing before the laptop decided to go on strike.

Basically, for some reason the syndaemon disappeared. I still have the command in the start up list, but it no longer shows up in the list of processes. I checked and it is still missing.

Oh yeah. Somehow I had received instructions to get the syndaemon installed in the first place. Maybe this forum or the Linux Forums. Come to think of it that was only to get syndaemon to behave and load at startup. Now it seems to be missing.

Any thoughts? You’ve been doing great so far.

PatH57
In the meantime I will check what synaptic package you need for the Satellite L655

White Phoeinix
Thanks for checking on the Synaptics driver. If you find one post on a different thread. A lot of people are looking for a good one. Apparently at the moment Mint does not carry any that are really any good. Even the fix for the syndaemon that I tried turned out to be only temporary since somehow the file disappeared.

----

So, I’m starting this thread here.
Last edited by White Phoenix on Sun Aug 24, 2014 7:38 am, edited 3 times in total.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

ok,

let's see if it is detected

Code: Select all

xinput list
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

Code: Select all

Virtual core printer id=2 [master pointer] (3)]
    Virtual core XTEST pointer id=4 [slave pointer (2)]
    Logitech USB Optical Mouse id=9 [slave pointer (2)]
    SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)]
Virtual core keyboard id=3 [master keyboard (2)]
    Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    Power Button id=6 [slave keyboard (3)] * all the rest are slave keyboard (3)
    Video Bus id=7
    Power Button id=8
    CNF9055 id=10
    AT Translated Set 2 keyboard id=11
    Toshiba input device id=13
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

do you have the Fn-f5 combination to enable disable the touchpad?
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

Oh, is that what that symbol means? Yes, I have that. Just a sec. Pressing Fn-F5 with or without the mouse plugged in does nothing.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

well we had to try it first (normally enables disables touchpad)

check /etc/X11/xorg.conf.d/50-synaptics.conf

copy it back here.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

There is no xorg.conf.d folder. Is that a problem? 8-)

I must also warn you my keyboard has been giving me grief since the Xserver problem was fixed. But that is on another thread.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

usr/share/X11/xorg.conf.d/50-synaptics.conf 8)
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

The file is not there. I did a search of my entire system. I do not have the file unless it is in one of the driver archives for the Synaptics Touchpad, but those are for Windows except the one I downloaded and haven’t checked out yet which is for Linux, but there are no guarantees it will work.

I just checked. It does not have the file either.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

let's try to force it

Code: Select all

sudo rmmod usbhid && sudo modprobe -v usbhid quirks="0x0930:0x0807:0x0040"
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

Buttons are now responding, but the touch pad itself still does nothing. Buttons work even with mouse plugged in.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

I upgraded to Mint 17 and everything is working again including the touchpad.

Setting it to turn off the touchpad while typing is not good enough. The touchpad is just in a bad position. It should have been put in front of the numeric key pad, but then people who use that a lot would still have problems.

How do you disable the touchpad? Which brings up the point that it isn’t just a driver problem. The Synaptics touchpad has a settings interface that allows much more control over the touchpad. Including turning off the touchpad when the mouse is plugged in.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

first open package manager and search for toshiba.
you should have:
-toshset
-acpi-support
-acpitool
enabled.
Then

Code: Select all

xinput list
and look for the id
check these suggestions on how to disable yours using the id you found.
http://askubuntu.com/questions/65951/ho ... e-touchpad
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by JeremyB »

Disabling the touchpad can be as simple as

Code: Select all

synclient TouchpadOff=1
and you can use

Code: Select all

synclient TouchpadOff=0
to enable it
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

I tried the easiest way first and it worked. 8-) Thanks guys.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: [Solved] Synaptics TouchPad Driver / Toshiba Satellite

Post by PatH57 »

how do they say "as long as it works...." :mrgreen:
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
White Phoenix
Level 4
Level 4
Posts: 268
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: [Solved] Synaptics TouchPad Driver / Toshiba Satellite

Post by White Phoenix »

PatH57 wrote:how do they say "as long as it works...." :mrgreen:
It wasn’t permanent. So now we will try your method.

Found all three. acpitool not enabled. It has something to do with the battery, which I do not have right now. (Mental note: Need to replace that.)

Reading thread. Someone else also suggested disabling using the Touchpad switch. Switch key to toggle the touchpad on/off? Er, that was mentioned in another thread. Mine may not work now that I’m using Linux, like the Fn + PrtSc keys . . . which now work in Mint 17. (Mental note: Change signature to reflect upgraded OS.) No, Fn + F9 doesn’t do anything. Some Fn keys work, some don’t. Too bad.

Peng Wu has a terrible habit of typing the command line code into the sentence making it difficult to read what the command is:
Peng Wu Oct 17 '11 at 10:40 wrote:turn off touch pad synclient TouchpadOff=1 turn it back on synclient TouchpadOff=0 This way even better.

Code: Select all

synclient TouchpadOff=1
to turn off

Code: Select all

synclient TouchpadOff=0
to turn on
But we already know this only works until the next reboot.
Peng Wu Nov 10 '11 at 23:47 wrote:sudo apt-get install touchpad-indicator the good new is that touchpad-indicator is worked again in 11.10.

Code: Select all

sudo apt-get install touchpad-indicator
Using this returns the message:
E: Unable to locate package touchpad-indicator
which is probably what is needed to get the Fn+F9 keys to work.

The next suggestion also depends on the touchpad-indicator to be in the repository to install. Something for the developers to work on.

Defining the keyboard shortcut is the best solution. It would be better if the Fn key could be used to toggle the touchpad like the key combo is supposed to. Instead I used Win+F9 and Ctrl+Win+F9. Using Ctrl is okay since I won’t be needing to turn it back on often. To cover myself, I will add the command to disable the touchpad in the startup also.

The command is:

Code: Select all

xinput set-prop <id> "Device Enabled" #
where <id> is the id number of the touchpad you find when running the “xinput list” command and # is 0 to disable and 1 to enable.

If you want the default condition to be “off” like I do, put the disable command in the startup list via Command Center. You don’t need to do anything if you want the touchpad off by default.

Use Keyboard Shortcuts to set two key combos. You can select whichever combo suits you by pressing the keys after selecting the new custom command. For titles I simply used “Disable touchpad” and “Enable touchpad”.

Now to see if it all works.

Fixed! Mission complete.
Linux Mint 18.3 / Cinnamon
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)
Post Reply

Return to “Hardware Support”