Installation crash, Live over PXE

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Lebowski
Level 1
Level 1
Posts: 6
Joined: Thu Aug 21, 2014 10:27 am

Installation crash, Live over PXE

Post by Lebowski »

Hi,

i setup booting the live-CD over PXE as described here: http://forums.linuxmint.com/viewtopic.php?f=197&t=96322 This works fine.

Once the livesystem is running i want to install linux mint and chose the Install-Icon on the desktop. The installation started as expected, but after downloading the packages the installer crashed. Below you find the /var/log/installer/debug and the last lines /var/log/syslog.

Can someone help me?

Thank you


/var/log/installer/debug
Ubiquity 2.18.8-1linuxmint4
Gtk-Message: Failed to load module "overlay-scrollbar"

(ubiquity:2678): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed

(ubiquity:2678): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed
No such schema 'org.gnome.nautilus.desktop'
update_release_notes_label()
update_release_notes_label()
update_release_notes_label()
locale.setlocale failed: unsupported locale setting (LANG=de_DE.UTF-8)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE.UTF-8",
LC_ALL = (unset),
LANG = "de_DE.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
No such schema 'com.canonical.indicator.session'
No such schema 'com.canonical.indicator.session'
No such schema 'com.canonical.indicator.session'
No such schema 'com.canonical.indicator.session'
device node not found
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE.UTF-8",
LC_ALL = (unset),
LANG = "de_DE.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE.UTF-8",
LC_ALL = (unset),
LANG = "de_DE.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/lib/ubiquity/plugins/ubi-console-setup.py:72: Warning: Source ID 630 was not found when attempting to remove it
GLib.source_remove(self.keyboard_layout_timeout_id)
/usr/lib/ubiquity/plugins/ubi-console-setup.py:74: Warning: Source ID 633 was not found when attempting to remove it
GLib.source_remove(self.keyboard_variant_timeout_id)
java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.6) (7u51-2.4.6-1ubuntu4)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
/var/log/syslog
...
Aug 21 13:14:13 mint in-target: OK http://archive.ubuntu.com trusty-updates/restricted Translation-en
Aug 21 13:14:13 mint in-target: OK http://archive.ubuntu.com trusty-updates/universe Translation-en
Aug 21 13:14:17 mint in-target: Ign http://archive.ubuntu.com trusty/main Translation-de_DE
Aug 21 13:14:17 mint in-target: Ign http://archive.ubuntu.com trusty/main Translation-de_DE.UTF-8
Aug 21 13:14:17 mint in-target: Ign http://archive.ubuntu.com trusty/multiverse Translation-de_DE
Aug 21 13:14:17 mint in-target: Ign http://archive.ubuntu.com trusty/multiverse Translation-de_DE.UTF-8
Aug 21 13:14:17 mint in-target: Ign http://archive.ubuntu.com trusty/restricted Translation-de_DE
Aug 21 13:14:18 mint in-target: Ign http://archive.ubuntu.com trusty/restricted Translation-de_DE.UTF-8
Aug 21 13:14:18 mint in-target: Ign http://archive.ubuntu.com trusty/universe Translation-de_DE
Aug 21 13:14:18 mint in-target: Ign http://archive.ubuntu.com trusty/universe Translation-de_DE.UTF-8
Aug 21 13:14:20 mint in-target: Ign http://packages.linuxmint.com qiana/import Translation-de_DE
Aug 21 13:14:20 mint in-target: Ign http://packages.linuxmint.com qiana/import Translation-de
Aug 21 13:14:21 mint in-target: Ign http://packages.linuxmint.com qiana/import Translation-de_DE.UTF-8
Aug 21 13:14:21 mint in-target: Ign http://packages.linuxmint.com qiana/import Translation-en
Aug 21 13:14:21 mint in-target: Ign http://packages.linuxmint.com qiana/main Translation-de_DE
Aug 21 13:14:21 mint in-target: Ign http://packages.linuxmint.com qiana/main Translation-de
Aug 21 13:14:21 mint in-target: Ign http://packages.linuxmint.com qiana/main Translation-de_DE.UTF-8
Aug 21 13:14:22 mint in-target: Ign http://packages.linuxmint.com qiana/main Translation-en
Aug 21 13:14:22 mint in-target: Ign http://packages.linuxmint.com qiana/upstream Translation-de_DE
Aug 21 13:14:22 mint in-target: Ign http://packages.linuxmint.com qiana/upstream Translation-de
Aug 21 13:14:22 mint in-target: Ign http://packages.linuxmint.com qiana/upstream Translation-de_DE.UTF-8
Aug 21 13:14:22 mint in-target: Ign http://packages.linuxmint.com qiana/upstream Translation-en
Aug 21 13:14:22 mint in-target: Es wurden 208 kB in 15 s geholt (13,7 kB/s).
Aug 21 13:14:22 mint in-target: Paketlisten werden gelesen...
Aug 21 13:14:29 mint in-target:
Aug 21 13:14:30 mint ubiquity: mv:
Aug 21 13:14:30 mint ubiquity: cannot stat ‘/target/etc/apt/sources.list.new’
Aug 21 13:14:30 mint ubiquity: : No such file or directory
Aug 21 13:14:30 mint ubiquity:
Aug 21 13:14:30 mint /plugininstall.py: log-output -t ubiquity umount /target/cdrom
Aug 21 13:14:30 mint finish-install: Disabling CD in sources.list
Aug 21 13:14:30 mint ubiquity: sed: can't read /target/etc/apt/sources.list: No such file or directory
Aug 21 13:14:30 mint /plugininstall.py: Exception during installation:
Aug 21 13:14:30 mint /plugininstall.py: Traceback (most recent call last):
Aug 21 13:14:30 mint /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1772, in <module>
Aug 21 13:14:30 mint /plugininstall.py: install.run()
Aug 21 13:14:30 mint /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Aug 21 13:14:30 mint /plugininstall.py: func(self)
Aug 21 13:14:30 mint /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 241, in run
Aug 21 13:14:30 mint /plugininstall.py: self.configure_apt()
Aug 21 13:14:30 mint /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 656, in configure_apt
Aug 21 13:14:30 mint /plugininstall.py: "AptSetup failed with code %d" % ret)
Aug 21 13:14:30 mint /plugininstall.py: ubiquity.install_misc.InstallStepError: AptSetup failed with code 1
Aug 21 13:14:30 mint /plugininstall.py:
Aug 21 13:17:01 mint CRON[18453]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

Lebowski
Level 1
Level 1
Posts: 6
Joined: Thu Aug 21, 2014 10:27 am

Re: Installation crash, Live over PXE

Post by Lebowski »

Ok,

this seems to be an nfs Problem, because of an older nfs-Server. After using 14.04 server for nfs everything works fine.

HeadlessChild
Level 1
Level 1
Posts: 2
Joined: Thu Aug 28, 2014 8:58 am

Re: Installation crash, Live over PXE

Post by HeadlessChild »

Lebowski wrote:Ok,

this seems to be an nfs Problem, because of an older nfs-Server. After using 14.04 server for nfs everything works fine.
Care to explain more thorough? I have the exact same problem as you have/had but my nfs server is the lastest version (nfs-kernel-server 1:1.2.6-4) and it still doesn't work.

ThePeePs
Level 1
Level 1
Posts: 3
Joined: Sun Oct 05, 2014 2:57 pm

Re: Installation crash, Live over PXE

Post by ThePeePs »

HeadlessChild wrote:
Lebowski wrote:Ok,

this seems to be an nfs Problem, because of an older nfs-Server. After using 14.04 server for nfs everything works fine.
Care to explain more thorough? I have the exact same problem as you have/had but my nfs server is the lastest version (nfs-kernel-server 1:1.2.6-4) and it still doesn't work.
Same here, Debian 7 (wheezy) has the same version of nfs-kernel-server (1:1.2.6-4), and I am getting the same error messages when trying to install mint via PXE.

There has to be another work around besides using Ubuntu 14.04....

I currently have my exports file configured with this, and it has been working fine for any and all other linux PXE boot/installs

Code: Select all

/srv/install  192.168.2.0/24(ro,sync,no_wdelay,insecure_locks,no_root_squash,no_subtree_check,insecure,fsid=0)
Any suggestions would be greatly appreciated.

looselyrigorous
Level 1
Level 1
Posts: 1
Joined: Tue Oct 07, 2014 1:06 pm

Re: Installation crash, Live over PXE

Post by looselyrigorous »

Okay guys, I had the same problem and I came up with a patch about it. After patching the file that causes this, the installation finishes normally and after the reboot there are no problems whatsoever.

As you can see from the output, there is an error with a file called plugininstall.py. So I boot normally (tested with PXE) and before I opened the installer I ran a:
locate plugininstall.py
It returned two files, of which the correct one is the:
/usr/share/ubiquity/plugininstall.py

I opened it in vim (I had to get this from apt-get but nano works as well) and checked the last error Python had, in line 656. As you can see, there is an if that checks the output of a previous command and throws an exception if something goes wrong (Lines 654-656).
It turns out if you comment out these three lines, (just enter a # in front) everything works!

TL;DR
apt-get install vim
vim /usr/share/ubiquity/plugininstall.py
[ go to line 654 by typing ":654" ]
[ press i ]
[ press # ]
[ press arrow-down ]
[ press # ]
[ press arrow-down ]
[ press # ]
[ press esc ]
[ type ":wq" ]

Proceed normally with install :-)

ThePeePs
Level 1
Level 1
Posts: 3
Joined: Sun Oct 05, 2014 2:57 pm

Re: Installation crash, Live over PXE

Post by ThePeePs »

That did the trick thanks.

I unpacked the filesystem.squashfs edited the file, and repacked it. Now I don't have to edit every time I need to install Mint 17.

To do this. you will need to install squash-tools

Code: Select all

sudo apt-get install squash-tools
Then unpack (unsquash the live filesystem in liveCDRoot/casper)

Code: Select all

 sudo unsquashfs filesystem.squashfs
This will create a directory called squashfs-root.

Edit the file, and save (comment out lines 654-656).

Finally repack(squash) the filesystem

Code: Select all

sudo mksquashfs squashfs-root filesystem.squshfs-new
Copy the new squashfs file to your PXE server and your good to go.
Last edited by ThePeePs on Fri Dec 12, 2014 3:09 pm, edited 1 time in total.

ThePeePs
Level 1
Level 1
Posts: 3
Joined: Sun Oct 05, 2014 2:57 pm

Re: Installation crash, Live over PXE

Post by ThePeePs »

Just an FYI, this also needs to be done for Rebecca (17.1)

HeadlessChild
Level 1
Level 1
Posts: 2
Joined: Thu Aug 28, 2014 8:58 am

Re: Installation crash, Live over PXE

Post by HeadlessChild »

ThePeePs wrote:Just an FYI, this also needs to be done for Rebecca (17.1)
This is why I love the Linux community!
Thank you so much for the find and detailed fix.

Lebowski
Level 1
Level 1
Posts: 6
Joined: Thu Aug 21, 2014 10:27 am

Re: Installation crash, Live over PXE

Post by Lebowski »

Hi,

can someone tell me, if this is fixed in Rebecca (17.1) or Rafaela (17.2)?


best regards

richud
Level 1
Level 1
Posts: 1
Joined: Thu Feb 11, 2016 9:34 am

Re: Installation crash, Live over PXE

Post by richud »

still same problem in 17.3 (incidentally its ok in ubuntu)

I came across the problem as I was using the same seed file from my auto ubuntu installs with mint.
If it helps anyone you can do this to get around it without needing to repack squashfs.

Put this somewhere in your seed file....

Code: Select all

d-i partman/early_command string \
	sed -i "653s#ret = .*#ret = 0#" /usr/share/ubiquity/plugininstall.py

nisu
Level 1
Level 1
Posts: 1
Joined: Mon Mar 21, 2016 3:02 am

Re: Installation crash, Live over PXE

Post by nisu »

I too had the same problem when I had the installation files copied to hd. I accidentally found out that the installation went without a hitch if I just mounted the iso and installed from there.

valentin
Level 1
Level 1
Posts: 10
Joined: Sat May 13, 2017 5:29 am

Re: Installation crash, Live over PXE

Post by valentin »

I am installing Linux Mint 18.1 and after i apply this solution, the situation persists.
Maybe other lines needs to be modified.
Can you be more specific, in order to find myself the lines?

Thank you

Post Reply

Return to “Installation & Boot”