[Solved] Get back nemo as default file manager

Quick to answer questions about finding your way around Linux Mint as a new user.
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
erebus_oneiros
Level 1
Level 1
Posts: 30
Joined: Wed Oct 08, 2014 8:57 am

[Solved] Get back nemo as default file manager

Post by erebus_oneiros »

Hi,

I shifted from win7 to linux mint qiana a month back. I was trying out different looks and apps on the pc when i installed dolphin and set it <although not completely succesfully> as the default file manager following instructions on http://askubuntu.com/questions/84929/ho ... le-manager answer by Hristo. But later i found nemo to be faster so i uninstalled dolphin, and then:
1. ran exo-preferred-applications
2. changed the default file manager to "nemo.desktop"

Problem:
When i click on computer or files the file browser opens without any problem, but when i try to open the file manager via any app like "dropbox > open dropbox folder" or via banshee song_name>right-click "open containing folder", i get the following error:
Failed to execute default file manager
Failed to execute child process "/usr/share/applications/nemo.desktop" (Permission Denied).
Is there any way to revert back the changes and bring nemo back ?
Last edited by erebus_oneiros on Mon Oct 13, 2014 12:00 pm, edited 1 time in total.
User avatar
karlchen
Level 21
Level 21
Posts: 14227
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Get back nemo as default file manager

Post by karlchen »

Hello, erebus_oneiros.

The default file-manager is nemo, executable filename /usr/bin/nemo. The file /usr/share/applications/nemo.desktop is not an executable file, but a launcher file. In the average Windows user terms: this is the icon in the Mint menu which you click upon in order to launch nemo.
You must have given the path to the nemo.desktop file in some place where actually you should have simply said "nemo" (without the double quotes).

I suggest to check /correct if necessary the following locations:
  • In the startup applications GUI, disable your old filemanager Dolphin and enable Nemo as you default flemanager, like has been done with Nautilus and Nemo in the screenshot below:
    Image
    (Disabled Nautilus, enabled Nemo - click image to enlarge, press <alt><cursor_left> to return here)
  • Click on Nemo, then on the Edit button, in order to check and if necessary to correct the nemo startup properties.
    Image
    (Nemo startup properties- click image to enlarge, press <alt><cursor_left> to return here)
  • Right-click on the tiny files icon near the menu button. Check the nemo properties.
    Image
    (Nemo launcher near [Menu] button - click image to enlarge, press <alt><cursor_left> to return here)
  • Make sure that in the folder /usr/share/applications the system wide settings in file mimeinfo.cache point to nemo:

    Code: Select all

    /usr/share/applications$ grep nemo mimeinfo.cache 
    application/x-gnome-saved-search=nemo.desktop;
    inode/directory=nemo.desktop;
    x-content/unix-software=nemo-autorun-software.desktop;
  • As the personal settings can override the systemwide settings, also check the file mimeinfo.cache in the folder ~/.local/share/applications

    Code: Select all

    ~/.local/share/applications$ grep nemo mimeinfo.cache 
    application/x-gnome-saved-search=nemo-folder-handler.desktop;
    inode/directory=nemo-folder-handler.desktop;
Hopefully I have not missed yet another location where the default filemanager can be redefined.

Cheers,
Karl
Last edited by karlchen on Wed Oct 08, 2014 4:25 pm, edited 1 time in total.
Reason: corrected: it is <alt><cursor_left> to go back to the previous page in Firefox
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
The Prophet's Song
erebus_oneiros
Level 1
Level 1
Posts: 30
Joined: Wed Oct 08, 2014 8:57 am

Re: Get back nemo as default file manager

Post by erebus_oneiros »

Hi KarlChen,

Many thanks for the quick reply !! :D :)

1. In the startup program I didn't have any entry for nemo, so i created one. (but even without it i could use nemo without any error from general files folder and computer from the pane or the menu).

2. All the other settings mentioned by you are exactly as mentioned, but in the file mimeinfo.cache in the folder ~/.local/share/applications
i couldn't find any of the two statements which you mentioned in your reply. Should I add them?
User avatar
karlchen
Level 21
Level 21
Posts: 14227
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Get back nemo as default file manager

Post by karlchen »

Hello, erebus_oneiros.

I do not think that it will be necessary to create the entries in ~/.local/share/applications/mimeinfo.cache manually. Usually if the systemwide entries and the personal entries differ, the personal entries will win. Else no user would be able to change his settings.
Yet you might try and find out whether it makes any difference.

Kind regards,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
The Prophet's Song
erebus_oneiros
Level 1
Level 1
Posts: 30
Joined: Wed Oct 08, 2014 8:57 am

Re: Get back nemo as default file manager

Post by erebus_oneiros »

No it didn't resolve it. The error persists, even for trying to open files via the menu or downloaded files via chrome or firefox.
User avatar
karlchen
Level 21
Level 21
Posts: 14227
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Get back nemo as default file manager

Post by karlchen »

Hello, erebus_oneiros.

Hm. Maybe reinstalling nemo and forcing dpkg to reconfigure it will help.
Please, open a terminal window, execute the following commands in the given order and one at a time.
  • Refresh local software list.

    Code: Select all

    sudo apt-get update
  • Re-install nemo.

    Code: Select all

    sudo apt-get install --re-install nemo
  • Reconfigure it explicitly.

    Code: Select all

    sudo dpkg-reconfigure nemo
It might be helpful to log out and log back in.

HTH,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
The Prophet's Song
erebus_oneiros
Level 1
Level 1
Posts: 30
Joined: Wed Oct 08, 2014 8:57 am

Re: Get back nemo as default file manager

Post by erebus_oneiros »

Hi Karl,

I did reinstall and reconfigure nemo using the *commands that you suggested but still the error persists. So it seems that I am stuck !! :( :(

On another note, as I had made the changes using exo-preferred-applications by running the following code:

Code: Select all

exo-preferred-applications
and made changes in the "Preferred applications window that opened, so should I make any changes in that ? As of now I have included its screenshots:
Screenshot of preferred app
Screenshot of preferred app
Screenshot of preferred app2
Screenshot of preferred app2
p.s. *in the reinstall command it should be "sudo apt-get install --reinstall nemo" without the dash in "re-install" as i was getting a command line error cause of it.
User avatar
karlchen
Level 21
Level 21
Posts: 14227
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Get back nemo as default file manager

Post by karlchen »

Hello, erebus_oneiros.

Have a look at the 2 screenshots which you posted displaying the configured default programmes:
The entries read e.g. Chromium, Debian X Terminal Emulator. Note that there is no extension .desktop suffixed.
But then have a look at the entry for the default file-manager: nemo.desktop.
The first 2 entries give the (display) names of 2 applications.
The third entry gives the name of a launcher file. I still suspect this to be the problem.

Moreover the exo-commands are part of the xfce desktop. I am not sure that they can be used successfully on Cinnamon as well.

Kind regards,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
The Prophet's Song
erebus_oneiros
Level 1
Level 1
Posts: 30
Joined: Wed Oct 08, 2014 8:57 am

Re: Get back nemo as default file manager

Post by erebus_oneiros »

Hi Karl,

many thanks, its sorted out. :) I am posting the solution as it might help someone else too !!

After thinking for sometime what you had said i did the following which sorted it:

1. Execute:

Code: Select all

exo-preferred-applications
2. In the Preferred applications window that opened,
- click on the dropdown menu > other
- go to /usr/bin/ and look for nemo (the file size would be in MBs) and select it
- now the window should look like this:
Screenshot of Preferred Application window
Screenshot of Preferred Application window
Post Reply