Cinnamon: Alt+Click moving windows

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Locked
gonzo28

Cinnamon: Alt+Click moving windows

Post by gonzo28 »

Hello,

how is it possible to deactivate this feature? I need the alt+click action in a program but it doesn't work because the wm catches it.
(the program is eve online in wine, while moving probes with alt+ left mouse).

I have mint 17.
Last edited by LockBot on Wed Dec 28, 2022 7:16 am, edited 1 time in total.
Reason: Topic automatically closed 6 months after creation. New replies are no longer allowed.
User avatar
xenopeek
Level 25
Level 25
Posts: 29846
Joined: Wed Jul 06, 2011 3:58 am

Re: Cinnamon: Alt+Click moving windows

Post by xenopeek »

Install dconf-tools and then open the dconf editor from your menu. Go to org > cinnamon > desktop > wm > preferences. Change the mouse-button-modifier. Don't set it to empty! (that will make all clicks move a window) For example set the value of the setting to <Ctrl> or <Super>. After changing it will be in effect immediately (the edit field needs to lose focus to be seen as having changed it). Test it. If it's still Alt+mouse to move a window, you made a typo or used an unsupported key.
Image
gonzo28

Re: Cinnamon: Alt+Click moving windows

Post by gonzo28 »

Perfect! Thanks!
JosephM
Level 6
Level 6
Posts: 1487
Joined: Sun May 26, 2013 6:25 pm

Re: Cinnamon: Alt+Click moving windows

Post by JosephM »

Xenopeek's solution obviously works but there is no need for dconf to do this in Cinnamon. Go to System Settings->Windows and there is a setting called "Special key to move and resize windows". That's the setting you're looking for and it's possible to disable it completely from there.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.
Locked

Return to “Cinnamon”