No desktop icons/terminal is blank(transparent) after reboot

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
bengalitiger89
Level 1
Level 1
Posts: 3
Joined: Wed Jan 08, 2014 8:19 pm

No desktop icons/terminal is blank(transparent) after reboot

Postby bengalitiger89 » Sat Mar 14, 2015 2:09 pm

Running Linux Mint 17.1 Rebecca

I have no idea what happened, yesterday I was trying to fix issues with PPA errors and I installed Y PPA manager last night and it solved the problem. And the last thing I did was look at TLP before turning in for the night.

Today I turned on my system and there were no icons and my conky widgets were not there, save for one. Opening conky manager and unselecting and reselecting them does not bring them back. Adding desklets though, does work, but I can't get my old icons or conky widgets to show. I would think nothing is wrong and re-add icons, except I can not and the most troubling thing is:

Opening System monitor or terminal (or many other programs related to the system) shows a transparent window with shadows but no GUI itself, even in terminal. Typing exit (blindly) into terminal closes the window and clicking on where the x button should be does close the window. i attached a photo to show what the "terminal" looks like.

I uninstalled Y PPA manager and TLP and have restarted the system many times over and tried different things but my google-fu is failing me.

I can open chrome and settings, and few other programs but if I try selecting software sources or root terminal or sometimes any app, the system freezes and i have to force a hard reboot.

I've added pictures, just in case. Here is what it looks like right now. You can see the lonesome conky widget and the transparent terminal that closes if I type exit and/or click where the x should be. https://i.imgur.com/OaopLBf.png
This is what it should hopefully go back to looking like: [url] https://i.imgur.com/5hkf696.jpg
[/url]

I tried googling different forums already but can't really find an answer, and nor can I try any of the terminal commands suggested in some other topics because I can't really type blindly into a terminal.

Thanks for your help in advance. If I should add more details, please let me know what.

MrBob22
Level 3
Level 3
Posts: 189
Joined: Mon Mar 26, 2012 8:05 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby MrBob22 » Sat Mar 14, 2015 7:33 pm

Sounds like something is interfering with your Conky/windows set up. Did the PPA program that you installed have some settings regarding the desktop? Might that have hijacked your desktop icons in some way? You stated that the only thing you added was the PPA program, to fix some issues. (Could one of those programs have reset your desktop?) I would remove the PPA manager to see if that is in some way the problem. If not, the next thing I would try would be to log out of your current desktop and log in with another desktop (like maybe Mate or Cinnamon if you can select those) See if the problem is islolated to your current settings on your current desktop. If the problems are deeper then maybe the x-windows file was corrupted. As you can see, I dont really have a fix on why your machine is acting up, but I have had a similar problem with missing icons and each case had a different answer. Conky itself has some odd bugs that show up from time to time. Hope this helps....MrBob22

bengalitiger89
Level 1
Level 1
Posts: 3
Joined: Wed Jan 08, 2014 8:19 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby bengalitiger89 » Sun Mar 15, 2015 4:44 am

Hi MrBob,

I removed Y PPA Manager, as well as disabled conky, as well as tried logging in through different desktop sessions. I am now thinking of a fresh install, but the thought of having to re-downloading everything and re-configuring all my programs is such a headache, especially since I have a FUP and would rather not waste bandwidth!

I remember now that I also downloaded Pinta, will remove that and see if there is any change.

This might be a driver issue, but I can't see how it would crop up suddenly, and just affect certain system programs like Terminal, System Monitor, and the desktop icons, and some, but not all conky widgets.

MrBob22
Level 3
Level 3
Posts: 189
Joined: Mon Mar 26, 2012 8:05 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby MrBob22 » Sun Mar 15, 2015 7:41 pm

Yes a fresh install is a royal PITA. But on the other hand, if you need to move ahead, at least this is a clear path toward a solution. I too am a bit perplexed about why this happened. Good luck with your issue...MrBob22

KajMagnus
Level 1
Level 1
Posts: 6
Joined: Wed Aug 06, 2014 3:13 am

Re: No desktop icons/terminal is blank(transparent) after re

Postby KajMagnus » Tue Mar 17, 2015 9:14 pm

Hi bengalitiger89, I might have encountered the same issue (a transparent/blank Terminal window, but typing in it, e.g. "exit" then Enter, works). This happened after installing the latest patches in 17.1. Switching from my computer's Intel GPU to its Nvidia GPU solved / worked-around the problem for me. More details in this thread: viewtopic.php?f=47&t=192133

adrian8888
Level 1
Level 1
Posts: 7
Joined: Mon Mar 23, 2015 4:27 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby adrian8888 » Mon Mar 23, 2015 4:34 pm

Hello, the same problem here. Icons invisible, but they are on the desktop (blind clicking can activate them)+terminal invisible+some icons in tray don`t work.

Screenshot: http://oi57.tinypic.com/34qvb.jpg

ko5tik
Level 1
Level 1
Posts: 6
Joined: Mon Mar 23, 2015 5:26 am

Re: No desktop icons/terminal is blank(transparent) after re

Postby ko5tik » Tue Mar 24, 2015 4:24 am

Yes I got the same problem. Terminals are fully functional though. At the moment I help myself with XTerm, but they are not real replacement for gnome terminal.
I have latest broadwell chipset with QHD. Reseting cinnamon settings did not help.

This is definitely not a problem with my user session - I created another user and it had the same problem

adrian8888
Level 1
Level 1
Posts: 7
Joined: Mon Mar 23, 2015 4:27 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby adrian8888 » Tue Mar 24, 2015 6:10 am

I got the solution! I found out that some of packages provided by ppa/xorg-edgers weren`t updated and were hold with the previous version.
So I did sudo apt-get install --reinstall libegl1-mesa and it reinstalled for me these packages and everything started working normally. I hope it will help you.

ko5tik
Level 1
Level 1
Posts: 6
Joined: Mon Mar 23, 2015 5:26 am

Re: No desktop icons/terminal is blank(transparent) after re

Postby ko5tik » Tue Mar 24, 2015 8:59 am

adrian8888 wrote:I got the solution! I found out that some of packages provided by ppa/xorg-edgers weren`t updated and were hold with the previous version.
So I did sudo apt-get install --reinstall libegl1-mesa and it reinstalled for me these packages and everything started working normally. I hope it will help you.


Works! Kudos!

MrBob22
Level 3
Level 3
Posts: 189
Joined: Mon Mar 26, 2012 8:05 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby MrBob22 » Tue Mar 24, 2015 1:56 pm

When you find a solution, its recommended to edit the title to include the word [Solved]. MrBob22

adrian8888
Level 1
Level 1
Posts: 7
Joined: Mon Mar 23, 2015 4:27 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby adrian8888 » Tue Mar 24, 2015 5:21 pm

It`s not my thread so I can`t do it.

allyouracid
Level 1
Level 1
Posts: 1
Joined: Tue Apr 07, 2015 3:38 am

Re: No desktop icons/terminal is blank(transparent) after re

Postby allyouracid » Tue Apr 07, 2015 3:47 am

adrian8888 wrote:I got the solution!
[...]
sudo apt-get install --reinstall libegl1-mesa

Hey there,

thanks for the solution. I was searching the web almost in vain, trying to find a solution for that problem. I mean, what to search for? "Transparent terminal"? At the end of the day, I landed here and registered for a) saying thank you and b) that this solution caused some other problems, so in case anybody else runs into them, I can maybe help solving.

Problem was that the xserver did not start, giving the known warning message (something like "X-Server could not be started, press OK for detailed information" - I don't have the exact error message, anymore) where the login window was supposed to appear. I did a backup of my xorg.conf (just in case) and ran

Code: Select all

sudo apt-get install --reinstall xserver-xorg


Then, after a reboot, a message

Code: Select all

Unable to launch "cinnamon-session-cinnamon" X session. 'cinnamon-session-cinnamon' not found.

Somehow, cinnamon got lost during the reinstall of libegl1-mesa, so I did

Code: Select all

sudo apt-get install --reinstall cinnamon

…and everything was fine, again. Including my terminals, desktop icons and no-more-transparent programs.

Thanks!

15joeybloom
Level 1
Level 1
Posts: 1
Joined: Thu Jan 26, 2017 3:03 pm

Re: No desktop icons/terminal is blank(transparent) after re

Postby 15joeybloom » Thu Jan 26, 2017 3:04 pm

ko5tik wrote:
adrian8888 wrote:I got the solution! I found out that some of packages provided by ppa/xorg-edgers weren`t updated and were hold with the previous version.
So I did sudo apt-get install --reinstall libegl1-mesa and it reinstalled for me these packages and everything started working normally. I hope it will help you.


Works! Kudos!



Worked for me too! Thanks!


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 3 guests