[Solved] Black screen after upgrade with Intel graphics card

Archived topics about LMDE 1
Forum rules
LMDE 2 support ends on 1-1-2019
Locked
IgnatiusReilly
Level 1
Level 1
Posts: 16
Joined: Thu Jun 09, 2011 5:44 pm
Location: Milan, Italy

[Solved] Black screen after upgrade with Intel graphics card

Post by IgnatiusReilly » Mon Jul 13, 2015 3:34 pm

Hi,

I updated to LMDE 2.

After the reboot, in normal mode I can read messages in large fonts and then my screen becomes almost completely black (although I can see the terminal pressing ALT+CTRL+F1/F2/...)

However, if in grub I choose the safe mode, all works perfectly (also the graphic effects are enabled and work).

My problem is different from this one: http://forums.linuxmint.com/viewtopic.p ... 9&t=194748
But rather similar to this: http://forums.linuxmint.com/viewtopic.p ... s#p1028406

My laptop has got an Intel Corporation 2nd Generation Core Graphics Controller [8086:0116]

Code: Select all

    gius@glmde:~$ lspci -vnn | grep VGA -A 12
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
       Subsystem: CLEVO/KAPOK Computer Device [1558:4140]
       Flags: bus master, fast devsel, latency 0, IRQ 40
       Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
       Memory at e0000000 (64-bit, prefetchable) [size=256M]
       I/O ports at f000 [size=64]
       Expansion ROM at <unassigned> [disabled]
       Capabilities: <access denied>
       Kernel driver in use: i915

    00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
       Subsystem: CLEVO/KAPOK Computer Device [1558:4140]
       Flags: bus master, fast devsel, latency 0, IRQ 43
I do not have any NVIDIA driver installed.
Any suggestion?

Thanks
Last edited by IgnatiusReilly on Mon Jul 13, 2015 4:27 pm, edited 1 time in total.

IgnatiusReilly
Level 1
Level 1
Posts: 16
Joined: Thu Jun 09, 2011 5:44 pm
Location: Milan, Italy

Re: Black screen after upgrade with Intel graphics card

Post by IgnatiusReilly » Mon Jul 13, 2015 4:26 pm

Ok. I solved it...
The issue was produced by the option "splash" in the grub default setting.
To solve the issue you can simply remove the option.

Edit the /etc/default/grub:
change
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
in
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
save the file, run the sudo update-grub command and reboot.

martin_kirch
Level 1
Level 1
Posts: 1
Joined: Sun May 11, 2014 10:25 am

Re: [Solved] Black screen after upgrade with Intel graphics

Post by martin_kirch » Tue Jan 26, 2016 4:21 am

Hello,
I had similar problems. The screen was zoomed on the upper left corner of the desktop. It also affected the terminal: when pressing ALT+CTRL+F1 I could only see the upper left quarter.

Intel Core Controller, 3rd generation, and the same driver:

Code: Select all

$ lspci -vnn | grep VGA -A 8
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:0584]
	Flags: bus master, fast devsel, latency 0, IRQ 42
	Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
removing "splash" in grub fixed it, too. Thanks Ignatius !

Locked

Return to “LMDE 1 Archive”