[Solved]GTX 960M with bumblebee not working [NVidia drivers]

Archived topics about LMDE 1 and LMDE 2
Locked
Marandil

[Solved]GTX 960M with bumblebee not working [NVidia drivers]

Post by Marandil »

Hi all

I have a Lenovo Y50-70 laptop with i7-4720HQ and GTX 960M and I'm trying to get the Optimus technology running.

I have the following nvidia- and bumblebee-related packages installed:

Code: Select all

bumblebee                                    3.2.1-9                             
bumblebee-nvidia                             3.2.1-9                             
glx-alternative-nvidia                       0.5.1                               
libegl1-nvidia:amd64                         340.76-5                            
libgl1-nvidia-glx:amd64                      340.76-5                            
libnvidia-eglcore:amd64                      340.76-5                            
libnvidia-ml1:amd64                          340.76-5                            
nvidia-alternative                           340.76-5                            
nvidia-cuda-dev                              6.0.37-5                            
nvidia-cuda-gdb                              6.0.37-5                            
nvidia-cuda-toolkit                          6.0.37-5                            
nvidia-detect                                340.76-5                            
nvidia-driver                                340.76-5                            
nvidia-driver-bin                            340.76-5                            
nvidia-installer-cleanup                     20141201+1                          
nvidia-kernel-common                         20141201+1                          
nvidia-kernel-dkms                           340.76-5                            
nvidia-libopencl1:amd64                      340.76-5                            
nvidia-modprobe                              349.16-1                            
nvidia-opencl-dev:amd64                      6.0.37-5                            
nvidia-profiler                              6.0.37-5                            
nvidia-settings                              340.46-2                            
nvidia-support                               20141201+1                          
nvidia-vdpau-driver:amd64                    340.76-5                            
nvidia-visual-profiler                       6.0.37-5                            
nvidia-xconfig                               340.46-1                            
xserver-xorg-video-nvidia                    340.76-5  
I'm using kernel version 4.1.0-1 from Debian testing repository, but I'm also testing all solutions on the default 3.16.0-4.

When I try to run optirun, I get the following error:

Code: Select all

marandillenovo marandil # optirun -vv glxgears
[ 1118.418731] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1118.419185] [INFO]Configured driver: nvidia
[ 1118.419541] [DEBUG]optirun version 3.2.1 starting...
[ 1118.419586] [DEBUG]Active configuration:
[ 1118.419600] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1118.419616] [DEBUG] X display: :8
[ 1118.419631] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[ 1118.419646] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1118.419662] [DEBUG] Accel/display bridge: auto
[ 1118.419675] [DEBUG] VGL Compression: proxy
[ 1118.419691] [DEBUG] VGLrun extra options: 
[ 1118.419704] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[ 1118.419777] [DEBUG]Using auto-detected bridge primus
[ 1118.459529] [INFO]Response: No - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

[ 1118.459554] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

[ 1118.459560] [DEBUG]Socket closed.
[ 1118.459570] [ERROR]Aborting because fallback start is disabled.
[ 1118.459575] [DEBUG]Killing all remaining processes.
/var/log/Xorg.8.log:

Code: Select all

[  1297.662] 
X.Org X Server 1.17.2
Release Date: 2015-06-16
[  1297.662] X Protocol Version 11, Revision 0
[  1297.662] Build Operating System: Linux 4.1.0 x86_64 Debian
[  1297.662] Current Operating System: Linux marandillenovo 4.1.0-1-amd64 #1 SMP Debian 4.1.3-1 (2015-08-03) x86_64
[  1297.662] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.1.0-1-amd64 root=UUID=4ffea8ca-bf6e-4e33-80a6-2e42630cd3d1 ro quiet splash
[  1297.662] Build Date: 11 August 2015  10:51:15AM
[  1297.662] xorg-server 2:1.17.2-1.1 (http://www.debian.org/support) 
[  1297.662] Current version of pixman: 0.32.6
[  1297.662] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  1297.662] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1297.663] (==) Log file: "/var/log/Xorg.8.log", Time: Thu Aug 20 10:25:10 2015
[  1297.663] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[  1297.663] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[  1297.663] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1297.663] (==) ServerLayout "Layout0"
[  1297.663] (**) |-->Screen "Default Screen" (0)
[  1297.663] (**) |   |-->Monitor "<default monitor>"
[  1297.664] (**) |   |-->Device "DiscreteNvidia"
[  1297.664] (==) No monitor specified for screen "Default Screen".
	Using a default monitor configuration.
[  1297.664] (**) Option "AutoAddDevices" "false"
[  1297.664] (**) Option "AutoAddGPU" "false"
[  1297.664] (**) Not automatically adding devices
[  1297.664] (==) Automatically enabling devices
[  1297.664] (**) Not automatically adding GPU devices
[  1297.664] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1297.664] 	Entry deleted from font path.
[  1297.664] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  1297.664] (++) ModulePath set to "/usr/lib/nvidia,/usr/lib/xorg/modules"
[  1297.664] (==) |-->Input Device "<default pointer>"
[  1297.664] (==) |-->Input Device "<default keyboard>"
[  1297.664] (==) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
[  1297.664] (==) The core keyboard device wasn't specified explicitly in the layout.
	Using the default keyboard configuration.
[  1297.664] (II) Loader magic: 0x564f29920d40
[  1297.664] (II) Module ABI versions:
[  1297.664] 	X.Org ANSI C Emulation: 0.4
[  1297.664] 	X.Org Video Driver: 19.0
[  1297.664] 	X.Org XInput driver : 21.0
[  1297.664] 	X.Org Server Extension : 9.0
[  1297.665] (II) xfree86: Adding drm device (/dev/dri/card1)
[  1297.665] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1297.665] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[  1297.667] (--) PCI:*(0:1:0:0) 10de:139b:17aa:3978 rev 162, Mem @ 0xd0000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  1297.667] (II) LoadModule: "glx"
[  1297.667] (II) Loading /usr/lib/nvidia/nvidia/libglx.so
[  1297.683] (II) Module glx: vendor="NVIDIA Corporation"
[  1297.683] 	compiled for 4.0.2, module version = 1.0.0
[  1297.683] 	Module class: X.Org Server Extension
[  1297.683] (II) NVIDIA GLX Module  340.76  Thu Jan 22 11:24:42 PST 2015
[  1297.683] (II) LoadModule: "nvidia"
[  1297.683] (II) Loading /usr/lib/nvidia/nvidia/nvidia_drv.so
[  1297.683] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1297.683] 	compiled for 4.0.2, module version = 1.0.0
[  1297.683] 	Module class: X.Org Video Driver
[  1297.683] (II) LoadModule: "mouse"
[  1297.684] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[  1297.684] (II) Module mouse: vendor="X.Org Foundation"
[  1297.684] 	compiled for 1.16.1, module version = 1.9.1
[  1297.684] 	Module class: X.Org XInput Driver
[  1297.684] 	ABI class: X.Org XInput driver, version 21.0
[  1297.684] (II) LoadModule: "kbd"
[  1297.684] (WW) Warning, couldn't open module kbd
[  1297.684] (II) UnloadModule: "kbd"
[  1297.684] (II) Unloading kbd
[  1297.684] (EE) Failed to load module "kbd" (module does not exist, 0)
[  1297.684] (II) NVIDIA dlloader X Driver  340.76  Thu Jan 22 11:03:05 PST 2015
[  1297.684] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1297.684] (--) using VT number 8

[  1297.685] (II) Loading sub module "fb"
[  1297.685] (II) LoadModule: "fb"
[  1297.685] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1297.685] (II) Module fb: vendor="X.Org Foundation"
[  1297.685] 	compiled for 1.17.2, module version = 1.0.0
[  1297.685] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1297.685] (WW) Unresolved symbol: fbGetGCPrivateKey
[  1297.685] (II) Loading sub module "wfb"
[  1297.685] (II) LoadModule: "wfb"
[  1297.685] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1297.685] (II) Module wfb: vendor="X.Org Foundation"
[  1297.685] 	compiled for 1.17.2, module version = 1.0.0
[  1297.685] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1297.685] (II) Loading sub module "ramdac"
[  1297.685] (II) LoadModule: "ramdac"
[  1297.685] (II) Module "ramdac" already built-in
[  1297.686] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen" for depth/fbbpp 24/32
[  1297.686] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1297.686] (==) NVIDIA(0): RGB weight 888
[  1297.686] (==) NVIDIA(0): Default visual is TrueColor
[  1297.686] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1297.686] (**) NVIDIA(0): Option "NoLogo" "true"
[  1297.686] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[  1297.686] (**) NVIDIA(0): Option "UseEDID" "false"
[  1297.686] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[  1297.686] (**) NVIDIA(0): Enabling 2D acceleration
[  1297.686] (**) NVIDIA(0): Ignoring EDIDs
[  1297.686] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[  1297.686] (**) NVIDIA(0):     mode
[  1297.718] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[  1297.718] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[  1297.718] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[  1297.718] (EE) NVIDIA(GPU-0):     README for additional information.
[  1297.718] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[  1297.718] (EE) NVIDIA(0): Failing initialization of X screen 0
[  1297.718] (II) UnloadModule: "nvidia"
[  1297.718] (II) UnloadSubModule: "wfb"
[  1297.718] (II) UnloadSubModule: "fb"
[  1297.718] (EE) Screen(s) found, but none have a usable configuration.
[  1297.718] (EE) 
Fatal server error:
[  1297.718] (EE) no screens found(EE) 
[  1297.718] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  1297.718] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[  1297.718] (EE) 
[  1297.718] (EE) Server terminated with error (1). Closing log file.
/etc/bumblebee/xorg.conf.nvidia:

Code: Select all

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#    BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "DiscreteNvidia"
EndSection
Some weird things I noticed:

nvidia-detect by default does not detect the GPU, even though it's clearly there in lsmod. After specifying the PCI, it claims that it's only supported by unsupported legacy drivers or that it is not YET supported (though I think this comes from Big Endian vs Little Endian naming of PCI lines or sth):

Code: Select all

marandillenovo marandil # lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
08:00.0 Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
0a:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5249 PCI Express Card Reader (rev 01)
marandillenovo marandil # nvidia-detect 
No NVIDIA GPU detected.
marandillenovo marandil # nvidia-detect 0010
Checking driver support for PCI ID [10de:0010]
Uh oh. Your card is not supported by any driver version up to 340.76.
A newer driver may add support for your card.
Newer driver releases may be available in backports.
marandillenovo marandil # nvidia-detect 0100
Checking driver support for PCI ID [10de:0100]
Uh oh. Your card is only supported by the 71.86 legacy drivers series, which is not in any current Debian suite.
Any Ideas?
Last edited by LockBot on Wed Dec 28, 2022 7:16 am, edited 2 times in total.
Reason: Topic automatically closed 6 months after creation. New replies are no longer allowed.
User avatar
kc1di
Level 18
Level 18
Posts: 8294
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: GTX 960M with bumblebee not working [NVidia drivers]

Post by kc1di »

Hello Marandil and welcome to Mint,
Nvidia drivers can be a pain, but most of the time you can get them working.

Nvidia says there better driver 346 you may want to give that one try.
I'm not familar enough with bumblebee to give you advice on that.
good luck.
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
Marandil

Re: GTX 960M with bumblebee not working [NVidia drivers]

Post by Marandil »

I think I solved it at some point, though I'm not entirely sure how, so I'll explain in detail what I have done (so if anyone else has a similar problem, he can try it himself)

I noticed, that - as kc1di pointed out - the drivers available in the repository are rather outdated, and since 9xxM series is (I think) the latest NVidia series (at the time of writing), it's probably not yet supported by those drivers. I went to NVidia for the drivers, but since everyone discourages taking their "Linux installer" (I also had an unpleasant experience with that) I googled for the version and found a package in the Debian experimental repository:
https://packages.debian.org/experimenta ... dia-driver

I decided to upgrade the drivers from the repo, I added "deb http://ftp.de.debian.org/debian experimental main contrib non-free" to my sources.list.d/... and run:

Code: Select all

apt update
apt upgrade nvidia-driver
# press yes, upgrade only drivers and dependencies to avoid unnecessary "experimental" packages
Next, I commented out the line with experimental from my sources and run apt update again (to avoid using the experimental packages in the foreseeable future).

Now, the optirun -vv glxgears was failing with yet another error: "Could not load GPU driver". I googled for that error and found this: https://github.com/Bumblebee-Project/Bu ... issues/604 issue on bumblebee github.
After issuing:

Code: Select all

modprobe nvidia-current nvidia-uvm
The optirun did actually run, but only once. After closing the window, the modules were unloaded and it wouldn't work again. As suggested in the issue, I also run:

Code: Select all

depmod -a
Though I'm not entirely sure whether this helped or not. Finally, I went back to bumblebee configuration files, and noticed that apparently, in my /etc/bumblebee/bumblebee.conf I had "KernelModule=nvidia" while I should have had "KernelModule=nvidia-current".
For now, it did the trick.

So, summing up:
1. Updated drivers to the ones in experimental
2. Manually loaded the kernel modules:

Code: Select all

modprobe nvidia-current nvidia-uvm
depmod -a
3. Checked whether in /etc/bumblebee/bumblebee.conf, "KernelModule=nvidia-current"

[by the way, 80% of solutions found on the web actually tells you to change from KernelModule=nvidia-current to KernelModule=nvidia. Check that via find /lib/modules/$(uname -r) -name 'nvidia*.ko*]

One more note: optirun works after reboot, so either the modprobe was unnecessary or just needed one-time
User avatar
kc1di
Level 18
Level 18
Posts: 8294
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by kc1di »

Glad you sorted it out :)
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
flynx
Level 1
Level 1
Posts: 12
Joined: Wed Aug 26, 2015 5:47 pm

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by flynx »

I am waging this same battle. I have an asus ux-501 with the same GTX 960M nvidia card. I agree the problem seems to be the need for newer drivers.

I first tried regular mint (ubuntu-based) and got the optimus working on nvidia-352. glxgears gave ~20000 fps.

I've now installed LMDE2, added the experimental deb, and installed bumblebee-nvidia and primus. I'm now getting the "failed to set DRM interface" error.

I tried adding the Screen section to xorg.conf.nvidia, and I specified nvidia driver in bumblebee.conf but I still get the same error.

When i look in /proc/driver/nvidia/version it says that I've got the newer 352.30 nvidia driver that worked in the ubuntu distro. But in that case I blacklisted and uninstalled the nouveau bits. Is that necessary here?

Im on vacation - this is all im doing right now. I take meticulous notes on what I do, so if I get this working I'll post all I have. I've spent the last three days looking for solutions. Any help would be great. This is a new system, I'm happy to do a fresh install for any new set of steps.

Thanks.
User avatar
kc1di
Level 18
Level 18
Posts: 8294
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by kc1di »

HI flynx,

If the nouveau driver is installed you need to blacklist it. it will interfere with any nvidia drivers.
If that is not the case you should start a new thread on this problem.
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
emmerich

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by emmerich »

Hi guys,

I have the same notebook, y50-70 and the same gpu but I haven't been able to install the driver as suggested.
My sources.list looks like this:

Code: Select all

/etc/apt/sources.list.d/official-package-repositories.list 
deb http://ftp.de.debian.org/debian experimental main contrib non-free

deb http://packages.linuxmint.com betsy main upstream import

deb http://ftp.us.debian.org/debian jessie main contrib non-free
deb http://ftp.us.debian.org/debian jessie-updates main contrib non-free
deb http://security.debian.org jessie/updates main contrib non-free

deb http://www.deb-multimedia.org jessie main non-free

deb http://extra.linuxmint.com betsy main
and the error I get is:

Code: Select all

apt install nvidia-driver=352.63-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver : Depends: libgl1-nvidia-glx (= 352.63-1) but 340.65-2 is to be installed
                 Depends: libegl1-nvidia (= 352.63-1) but 340.65-2 is to be installed
                 Depends: nvidia-driver-bin (= 352.63-1) but 340.65-2 is to be installed
                 Depends: xserver-xorg-video-nvidia (= 352.63-1) but 340.65-2 is to be installed
                 Depends: nvidia-vdpau-driver (= 352.63-1) but 340.65-2 is to be installed
                 Depends: nvidia-alternative (= 352.63-1)
                 Depends: nvidia-kernel-dkms (= 352.63-1) or
                          nvidia-kernel-352.63
E: Unable to correct problems, you have held broken packages.
I cannot do a apt upgrade since I've removed the original nvidia-driver (340). Anyhow, I've tried to also have installed the 340 and do an upgrade but the problem is the same.

Any ideas?

P.S. I've checked for held packages and I have none.
Also, tried to install the driver from the nvidia site but bumblebee does not work properly, I get the "/dev/dri/card0: failed to set DRM interface version 1.4: Permission denied" error; I've tried to add the "Screen" section to bumblebee.conf, also uncomment the BusID section, changed the driver name from nvidia-current to nvidia but nothing helped.

Thank you!
emmerich

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by emmerich »

I finally managed to install the whole experimental bunch (priorities/pinning, etc.) but the problem manifests in the same way:

Code: Select all

/dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
Tried different configurations of xorg.nvidia.conf (with BUS un/commented, with the "Screen" section and without) but no joy.

Any other ideas?
emmerich

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by emmerich »

Well, I've finally got it running, it was a true saga.

Here it is:

1. Had to install the nvidia driver (352 currently) from debian experimental (have fun with changing package priority/pinning)
2. Had to add the 'Section "Screen"' like described here https://wiki.debian.org/Bumblebee to the xorg.config.nvidia
3. Had to downgrade libdrm2 & libdrm-intel1 (both amd64 and i386) to 2.4.56 -- remember to apt-mark hold 'em
4. Had to change the kparam in /etc/default/grub to rcutree.rcu_idle_gp_delay=1 then update-grub
5. Reboot the bucket

Finally I've run a small benchmark comparing the performance with a W10 installation; seems that on W10 I get ~2fps more, of course the drivers 352 != 359
http://imgur.com/oExo5ak

Cheers!
bordeaux

Re: [Solved]GTX 960M with bumblebee not working [NVidia driv

Post by bordeaux »

I just wanted to thank you for describing the installation procedure - I was just about to give up when I found it, made my day.
I had to modify the /etc/bumblebee.conf LibraryPath for the nvidia drivers in order to get it work with wine. Also forgot to install some of the nvidia driver/gl[x] libraries for the i386-architecture at first, but now everything works (tried just for fun: Anno 1404 in max settings runs smoothly, and when nothing is run via optirun, power consumption drops from ~60W to ~16W).

So thanks again, the last few days were a rather painful experience.
Locked

Return to “LMDE Archive”