How to set up a D-Link DWA-130 Wireless USB Adapter

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
bzm
Level 1
Level 1
Posts: 1
Joined: Tue Dec 30, 2008 2:22 pm

How to set up a D-Link DWA-130 Wireless USB Adapter

Post by bzm » Tue Dec 30, 2008 5:00 pm

I just installed Mint 6 and set up a wireless network using WPA2 Personal. I used a D-Link DIR-615 wireless router and the DWA-130 USB (version B1, look at the label on yours) adapter. I hope somebody finds this useful.

The DWA-130 was not recognized by the installation process, so I just used ndiswrapper. As of this writing, the ndiswrapper list is not available, but somehow I got a link to a page on http://www.archive.org/web that had a cached copy of the list that was fairly recent. It recommended the Marvell Mrv driver. I'm only mentioning it because it did not work for me.

Here's what did work (some names and numbers have been sanitized for public viewing):

Navigated to the drivers folder on the D-Link installation CD-ROM:

Code: Select all

cd /media/cdrom0/setup/Drivers/Drivers/DriverXP_2K
Copied rt2870.inf and rt2870.sys to a new folder:

Code: Select all

mkdir /home/me/Desktop/D-Link_rt
cp rt2870.* /home/me/Desktop/D-Link_rt/
Then, to make snooping around later easier:

Code: Select all

cd /etc/ndiswrapper
Install the driver:

Code: Select all

sudo ndiswrapper -i /home/me/Desktop/D-Link_rt/rt2870.inf
installing rt2870 ...
sudo ndiswrapper -l
rt2870 : driver installed
Plug in adapter

Code: Select all

sudo ndiswrapper -l
rt2870 : driver installed
	device (07D1:3C13) present
ls -l
drwxr-xr-x 2 root root 4096 2008-12-30 01:28 rt2870
ls -l rt2870
...(bunch of entries)...
-rw-r--r-- 1 root root   1024 2008-12-30 01:28 07D1:3C13.F.conf
...(another bunch of entries)
-rw-r--r-- 1 root root  63793 2008-12-30 01:28 rt2870.inf
-rw-r--r-- 1 root root 560896 2008-12-30 01:28 rt2870.sys
Right-click on network icon in system tray
  • Check "Enable Networking"
  • Check "Enable Wireless"
  • Click "Edit Connections"
  • Click Wireless tab
  • Click Add
  • Enter your wireless information (here's mine):
    • Connection name: D-Link DWA-130
    • Connect automatically
    • System setting
    • SSID: my_nw
    • Mode: Infrastructure
    • >> No BSSID <<
    • >> No MAC address <<
    • MTU: automatic
    • Wireless Security: WPA & WPA2 Personal
    • Manual IP settings (192.168.0.20)
    • DNS: OpenDNS at 208.67.222.222 and 208.67.220.220
Boom, it worked.

Code: Select all

tail -f /var/log/messages

Dec 30 01:31:03  [ 4862.696024] usb 1-2: new full speed USB device using uhci_hcd and address 8
Dec 30 01:31:03  [ 4862.904905] usb 1-2: configuration #1 chosen from 1 choice
Dec 30 01:31:03  [ 4863.044598] usb 1-2: reset full speed USB device using uhci_hcd and address 8
Dec 30 01:31:03  [ 4863.223457] ndiswrapper: driver rt2870 (Ralink Technology, Corp.,01/31/2008, 1.01.01.0000) loaded
Dec 30 01:31:06  [ 4865.770411] wlan0: ethernet device 00:00:00:00:00:00 using NDIS driver: rt2870, version: 0x0, NDIS version: 0x500, vendor: 'IEEE 802.11n Wireless Card.', 07D1:3C13.F.conf
Dec 30 01:31:06  [ 4865.771497] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
Good luck!

DevanE
Level 1
Level 1
Posts: 2
Joined: Fri Oct 30, 2009 2:50 am

Re: How to set up a D-Link DWA-130 Wireless USB Adapter

Post by DevanE » Sun Sep 12, 2010 2:31 am

Thanks for the detailed instructions!
I'd just like to add one step that was required for it to work for me, in case anyone else has the problem I did. When I got to the "Enable Wireless Networking" point, I didn't have that option in the network manager. I also had no wlan0 in the output of ifconfig.
To fix this, I needed to have ndiswrapper start at boot; I did this by adding a line with "ndiswrapper" to /etc/modules. Also, I had run "sudo ndiswrapper -m" after installing the driver although I'm not sure if that step was needed.

Cheers!

Post Reply

Return to “Tutorials”