Laptop brightness not working, LM17 on an HP-15 notebook

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
olly1123
Level 1
Level 1
Posts: 1
Joined: Mon Oct 19, 2015 5:54 pm

Laptop brightness not working, LM17 on an HP-15 notebook

Post by olly1123 »

Hi, I've just installed LM17 on an HP-15 notebook. But I have two problems: first, I am unable to adjust screen brightness using the dimmer keys f2 and f3. Also, the f12 WiFi key is not functioning.

Here is the output of inxi -Fzi

Code: Select all

System:    Host: ollys-laptop Kernel: 3.13.0-24-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 17 Qiana
Machine:   System: Hewlett-Packard product: HP 15 Notebook PC version: 0975100000405F00001620180
           Mobo: Hewlett-Packard model: 22CD version: 93.15 Bios: Insyde version: F.16 date: 05/30/2014
CPU:       Quad core AMD A8-6410 APU with AMD Radeon R5 Graphics (-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) 
           Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz 3: 1000.00 MHz 4: 2000.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon APU A4-6000 with R2 Graphics] 
           X.Org: 1.15.1 drivers: ati (unloaded: vesa,radeon) FAILED: fbdev Resolution: 1366x768@76.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits) GLX Version: 2.1 Mesa 10.1.0
Audio:     Card-1: Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2: Advanced Micro Devices [AMD/ATI] Device 9840 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169 
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee 
           IF: wlan0 state: up mac: <filter>
           WAN IP: <filter> IF: eth0 ip: N/A IF: wlan0 ip: <filter> 
Drives:    HDD Total Size: 1000.2GB (0.5% used) 1: id: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB 
Partition: ID: / size: 910G used: 4.8G (1%) fs: ext4 ID: swap-1 size: 7.46GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 186 Uptime: 37 min Memory: 777.0/6922.6MB Client: Shell inxi: 1.8.4 
I have tried the usual fix for getting the screen brightness to work, namely editing the line in the GRUB file to read something like "quiet splash backlight=vendor" followed be update-grub and reboot. But this had no effect. Editing the line beneath that resulted in my laptop not booting: so I am weary of making any changes here.

As for getting the Wifi button working, I have no idea what to do!

I would really appreciate some help. My laptop screen's so bright its burning my eyeballs in their sockets!
User avatar
Cobber
Level 3
Level 3
Posts: 190
Joined: Wed Feb 26, 2014 5:15 am
Location: Australia

Re: Laptop brightness not working, LM17 on an HP-15 notebook

Post by Cobber »

This is a common problem with laptops.

See this post and the recommended guide for installing xbacklight
PC: Dual HDD: Mint 18.2 64-Bit KDE / Windows7 Professional
HP Dv7 Laptop Dual HDD: MX Linux / Windows 7 Home
Lenovo x230 Laptop Dual boot: Mint 18.1 64-Bit KDE / Windows7 Professional
Post Reply

Return to “Software & Applications”