problems installing latest owncloud client under 17.3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
cbrace
Level 2
Level 2
Posts: 75
Joined: Sun Jan 22, 2012 7:23 am
Location: Amsterdam
Contact:

problems installing latest owncloud client under 17.3

Post by cbrace »

Hi all,

I have ownCloud installed on my server and have various clients syncing files.

Because the ownCloud clients in the Ubuntu repo tend to be rather old, I have been using the SUSE-maintained Ubuntu repo which offers the (much more) recent client versions.

On my desktop system, running LM 17.2, the latest ownCloud client is installed from that repo and everything is working fine.

On my laptop, I have just done a clean install of LM 17.3.

The version of the ownCloud client in the Ubuntu repo, v1.5, can't log in to my ownCloud server.

So I've installed the SUSE repo and try to install the much more recent v2.1 client.

But this cannot be installed:

Code: Select all

$ sudo apt-get install owncloud-client
...
The following packages have unmet dependencies:
 owncloud-client : Depends: libowncloudsync0 (= 2.1.0-1.1) but it is not going to be installed
                   Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04 is to be installed
                   Depends: owncloud-client-l10n but it is not going to be installed
As far as I can tell here, the client is built against libstdc++6, but only an earlier version is available in the repos.

Am I understanding this correctly?

Why then does the v2.1 OC client run fine under 17.2?

On my 17.2 system:

Code: Select all

$ apt version  libstdc++6
4.8.4-2ubuntu1~14.04
colin@ares ~ $ apt version  owncloud-client
2.1.0-1.1
I'm kinda perplexed. What am I missing here?

Thanks
Laurent85
Level 16
Level 16
Posts: 6952
Joined: Tue May 26, 2015 10:11 am

Re: problems installing latest owncloud client under 17.3

Post by Laurent85 »

I guess you mistakenly set up the 15.10 repository instead of the 14.04 one. Check Software Sources > Additional repositories > Opensuse.
Image
dgrb00
Level 1
Level 1
Posts: 1
Joined: Fri Jan 08, 2016 4:43 pm

Re: problems installing latest owncloud client under 17.3

Post by dgrb00 »

I had exactly the same problem - using the 14.04 repo.

Works on 17.2 not on 17.3, HOWEVER:

sudo apt-get install libowncloudsync0

did the trick.
Post Reply

Return to “Software & Applications”