Enter password on encrypted drive, keyboard not working

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
amokpaule
Level 1
Level 1
Posts: 3
Joined: Thu May 17, 2012 8:24 am

Enter password on encrypted drive, keyboard not working

Postby amokpaule » Sun Dec 13, 2015 10:34 am

Hello,

I have a fresh installed Mint 17.3. The installations is encrypted using the installation disk.

The keyboard i use is a Logitech K800 connected either over usb or a "unified" receiver.

When I boot to my system the keyboard works in the bios and the grub menu but when i have to enter the pass to enter the encrypted installation it does not work.

I have to plug in a "normal" non wireless keyboard, type the pass in and after the drive is decrypted the other keyboard works again.

This behaviour is related to the cinnamon and mate edition, not sure about other mint flavours.

Its not related to any legacy usb entries in the bios.

Any help is much appreciated!

amokpaule
Level 1
Level 1
Posts: 3
Joined: Thu May 17, 2012 8:24 am

Re: Enter password on encrypted drive, keyboard not working

Postby amokpaule » Sun Dec 13, 2015 3:28 pm

I found the solution:


Hi,

I had the same problem with a K800 Keyboard from Logitech.

a better way would be to edit the file

/etc/initramfs-tools/modules

and add

hid-logitech-hidpp

there.

Then it is sufficiant to to

sudo update-initramfs -c -k $(uname -r)

for the running kernel (or "-k all" for all kernels).

Confirmed with Logitech K800, Ubuntu 14.04.3, 3.19.0-26-generic (64bit)
See full activity log


Found: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1448519

Trapper
Level 4
Level 4
Posts: 348
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: Enter password on encrypted drive, keyboard not working

Postby Trapper » Mon Dec 14, 2015 9:57 am

Your solution also worked for me too amokpaule. Unfortunately I am experiencing another problem with my K520 once I am booted up. Anytime I am doing something that presents a form, password box or other fill-in information my keyboard often goes goes crazy putting 5's into the boxes without any action on my part. It will continue filling in 5's until I take some sort of action to end it. At first I thought it was a keyboard problem but I do not experience this problem in 17.2, 13 or LMDE2. I also have several strange, unrelated things happening with apps in 17.3 that work fine in previous releases. We've elected to remain with 17.2 here. 'If it ain't broke don't fix it.' We have a list of issues with 17.3 that we do not experience in 17.2.
MSI 880GME35-455 MB, AMD Phenom II X4 B55 (-MCP-) CPU, 4GB DDR3 RAM, 500 GB SATA3 HD
Single FDE container holding LMDE 2, LM 17.2, LM 18.1 MATE & CINN, LM 18.2 MATE, Debian Jessie, swap, and shared data LV's.

quatzar
Level 1
Level 1
Posts: 9
Joined: Thu Oct 31, 2013 6:41 am

Re: Enter password on encrypted drive, keyboard not working

Postby quatzar » Tue Mar 01, 2016 10:04 am

This worked for me as well also logitech k800 on a fresh install of mint 17.3 kde 64-bit.

I would have been trapped outside a fresh install (made with the new k800) without so much as anything on a black screen had I not still had my old keyboard.
I only guessed that was the problem because it's a fresh swap out today.

Is there any way of knowing if this will be fixed for 17.4 or 18 or whatever is next?
It was quite beyond me, and as far as i can tell. Even if you could edit the /etc/initramfs-tools/modules (which is encrypted so you can't) from grub you would have no means of sudo update-initramfs -c -k all
So logitech people will be locked out on mass for the next cycle until they all abandon the encryption of the virtual disk.
may god have mercy on us all.


Return to “Installation & Boot”

Who is online

Users browsing this forum: robrenard, WillHK and 8 guests