[SOLVED- CAUTION] Setting resolution for large monitor

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

[SOLVED- CAUTION] Setting resolution for large monitor

Post by hatrack »

Greetings to all on this board --
I have a problem setting the resolution of a new monitor.

I am running a dual-boot system WinXP/(LinuxMint ver 17.3, Mate 1.12.0 desktop) on a Dell GX-520 with 2 GB memory. I have purchased a BenQ LED monitor (Model GL2250HM, Nominal 21.5 in) to be used for image processing. On start-up, a small splash-screen recommends a resolution of 1920x1080 @ 60 Hz but the highest setting available under LinuxMint is 1024x768. When running under WinXP, the recommended monitor resolution can be set without problems.

I have browsed several sites and understand that the following information is possibly needed --

Graphics: Card: Intel 82945G/GZ Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.org 1.15.1 drivers: intel (unloaded: fbdev,vesa)
tty size: 80x24 Advanced Data: N/A for root

I tackled a similar problem in 2009, (under Ubunutu 8.04) which was solved by editing etc/X11/xorg.conf. I have researched this matter today and have found that Mint ver:17.3 no longer uses xorg.conf but that this file CAN be generated by a user and that this will then be used.

I am a very aged OAP and this business of writing a new xorg.conf file is now 'way beyond my level of competence so I am not confident that I understand the info I find on-line. In particular, I really do not know what else should be included or the precise syntax required. In addition, I have also found from this Board a recommendation to edit the GRUB menu but, unfortunately the only instruction is to --

"Move to the end of that line where it says quiet splash and change it to read quiet splash vga=792 . Press the F10 key to finish booting with this change."

Presumably there are other values besides "vga=792" but what are they and how are they used ? Unfortunately, this quoted value apparently sets a monitor resolution of 1024x768 -- which is what I am getting now by default !

I am thoroughly confused and so I will be most grateful if someone could advise me how best to proceed.

Many thanks and best regards to all --
Last edited by hatrack on Fri Jan 15, 2016 3:01 pm, edited 3 times in total.

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: Setting resolution for large monitor (BenQ Nom. 22")

Post by hatrack »

I have been searching on-line and have found an excellent article which provides a complete solution to my problem.

The URL is:- http://www.computershowto.pro/2013/01/h ... th-xrandr/ --- This can be copied and pasted into the search box.

There are a couple of typos in the article, as follows --
[1] The command to create the new modeline should read xrdandr --newmode (Note TWO hyphens, not one as in original text)

[2] When writing the final instruction -- xrandr --addmode ---- etc "addmode" should have two letter 'd' and two hyphens, not as sown.

However, these little problems were easily resolved by experiment and the desired resolution of 1920 x 1080 is now set and operational.

I have therefore marked this matter closed and hope that others will find this extra info useful.

Best regards to all --

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: [SOLVED]Setting resolution for large monitor (BenQ Nom.

Post by hatrack »

WARNING

Yesterday evening I thought that I had found a method for setting the monitor resolution to 1920x1080, so as to use a new monitor for image processing and I posted accordingly (see above).

However, this method works just once but, after a reboot, the new resolution has been lost. More importantly, monitor settings are now scrambled, "1920 x 1080" is no longer available and only the settings originally listed (with max 1080 x 760) can now be set.

The "xrandr" command has apparently been corrupted and will not correctly parse any information entered. The only way I can find which is likely to recover correct setting information is to de-install Mint 17.3 and then re-install. The annoying thing is that the monitor setting required was immediately recognised by the now long-obsolete WinXP. This has been set and has persisted correctly over several reboots.

Why is it that there is no established and correctly-documented procedure to set monitor resolution higher that 1080x768 @60 Hz offered in Mint 17.3 ? After all, "1920 x 1080" vga has been available for about 10 yrs at least. Setting monitor resolution was dead easy in Ubuntu ver 8.04 (Hardy) several years ago.

My apologies to all for posting incorrect information but the fact that the method offered worked once completely foxed me. If anyone has a good solution, I would be most grateful to learn of it, before I junk Mint in disgust !

Best regards -

User avatar
roblm
Level 12
Level 12
Posts: 4300
Joined: Sun Feb 24, 2013 2:41 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by roblm »

You need to post some additional information.

1. Use this command in the Terminal: xrandr

2. How is the monitor connected, including any adapter.

3. Use this command to open the “Xorg.0.log” file, or open the Log File Viewer:

Code: Select all

pluma /var/log/Xorg.0.log
Press Ctrl+A to select the entire file contents. Right click on the screen and select “Copy”. Don't save it to a file. Open the Mint Forum reply window and select “Code” in the menu. Paste the copied lines between the two code words.

If you have problems posting that long file, then upload it to pastebin.com by using this command:

Code: Select all

pastebin /var/log/Xorg.0.log

Post the URL link that displays in the Terminal window.

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by hatrack »

Code: Select all

[ 37.765]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[ 37.765] X Protocol Version 11, Revision 0
[ 37.765] Build Operating System: Linux 3.2.0-75-generic i686 Ubuntu
[ 37.765] Current Operating System: Linux OptiPlex-GX520 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686
[ 37.765] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=c44ba411-6991-4933-9f99-0d700fba7e33 ro quiet splash vt.handoff=7
[ 37.765] Build Date: 12 February 2015 02:49:46PM
[ 37.765] xorg-server 2:1.15.1-0ubuntu2.7 (For technical support please see http://www.ubuntu.com/support)
[ 37.765] Current version of pixman: 0.30.2
[ 37.765] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 37.765] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 37.765] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 14 18:33:52 2016
[ 37.777] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 37.777] (==) No Layout section. Using the first Screen section.
[ 37.777] (==) No screen section available. Using defaults.
[ 37.777] (**) |-->Screen "Default Screen Section" (0)
[ 37.777] (**) | |-->Monitor "<default monitor>"
[ 37.778] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 37.778] (==) Automatically adding devices
[ 37.778] (==) Automatically enabling devices
[ 37.778] (==) Automatically adding GPU devices
[ 37.778] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 37.778] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 37.778] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 37.778] (II) Loader magic: 0xb77456c0
[ 37.778] (II) Module ABI versions:
[ 37.778] X.Org ANSI C Emulation: 0.4
[ 37.778] X.Org Video Driver: 15.0
[ 37.778] X.Org XInput driver : 20.0
[ 37.778] X.Org Server Extension : 8.0
[ 37.779] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 37.780] (--) PCI:*(0:0:2:0) 8086:2772:1028:01ad rev 2, Mem @ 0xfeb00000/524288, 0xe0000000/268435456, 0xfeac0000/262144, I/O @ 0x0000e898/8
[ 37.780] (--) PCI: (0:0:2:1) 8086:2776:1028:01ad rev 2, Mem @ 0xfeb80000/524288
[ 37.781] Initializing built-in extension Generic Event Extension
[ 37.781] Initializing built-in extension SHAPE
[ 37.781] Initializing built-in extension MIT-SHM
[ 37.781] Initializing built-in extension XInputExtension
[ 37.781] Initializing built-in extension XTEST
[ 37.781] Initializing built-in extension BIG-REQUESTS
[ 37.781] Initializing built-in extension SYNC
[ 37.781] Initializing built-in extension XKEYBOARD
[ 37.781] Initializing built-in extension XC-MISC
[ 37.781] Initializing built-in extension SECURITY
[ 37.781] Initializing built-in extension XINERAMA
[ 37.781] Initializing built-in extension XFIXES
[ 37.781] Initializing built-in extension RENDER
[ 37.781] Initializing built-in extension RANDR
[ 37.781] Initializing built-in extension COMPOSITE
[ 37.781] Initializing built-in extension DAMAGE
[ 37.781] Initializing built-in extension MIT-SCREEN-SAVER
[ 37.781] Initializing built-in extension DOUBLE-BUFFER
[ 37.781] Initializing built-in extension RECORD
[ 37.781] Initializing built-in extension DPMS
[ 37.781] Initializing built-in extension Present
[ 37.781] Initializing built-in extension DRI3
[ 37.781] Initializing built-in extension X-Resource
[ 37.781] Initializing built-in extension XVideo
[ 37.781] Initializing built-in extension XVideo-MotionCompensation
[ 37.781] Initializing built-in extension SELinux
[ 37.781] Initializing built-in extension XFree86-VidModeExtension
[ 37.781] Initializing built-in extension XFree86-DGA
[ 37.781] Initializing built-in extension XFree86-DRI
[ 37.781] Initializing built-in extension DRI2
[ 37.781] (II) LoadModule: "glx"
[ 37.801] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 37.853] (II) Module glx: vendor="X.Org Foundation"
[ 37.853] compiled for 1.15.1, module version = 1.0.0
[ 37.853] ABI class: X.Org Server Extension, version 8.0
[ 37.853] (==) AIGLX enabled
[ 37.853] Loading extension GLX
[ 37.853] (==) Matched intel as autoconfigured driver 0
[ 37.853] (==) Matched intel as autoconfigured driver 1
[ 37.853] (==) Matched modesetting as autoconfigured driver 2
[ 37.853] (==) Matched fbdev as autoconfigured driver 3
[ 37.853] (==) Matched vesa as autoconfigured driver 4
[ 37.853] (==) Assigned the driver to the xf86ConfigLayout
[ 37.853] (II) LoadModule: "intel"
[ 37.864] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 37.879] (II) Module intel: vendor="X.Org Foundation"
[ 37.879] compiled for 1.15.0, module version = 2.99.910
[ 37.879] Module class: X.Org Video Driver
[ 37.879] ABI class: X.Org Video Driver, version 15.0
[ 37.879] (II) LoadModule: "modesetting"
[ 37.879] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 37.879] (II) Module modesetting: vendor="X.Org Foundation"
[ 37.879] compiled for 1.15.0, module version = 0.8.1
[ 37.879] Module class: X.Org Video Driver
[ 37.879] ABI class: X.Org Video Driver, version 15.0
[ 37.879] (II) LoadModule: "fbdev"
[ 37.880] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 37.880] (II) Module fbdev: vendor="X.Org Foundation"
[ 37.880] compiled for 1.15.0, module version = 0.4.4
[ 37.880] Module class: X.Org Video Driver
[ 37.880] ABI class: X.Org Video Driver, version 15.0
[ 37.880] (II) LoadModule: "vesa"
[ 37.880] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 37.880] (II) Module vesa: vendor="X.Org Foundation"
[ 37.880] compiled for 1.15.0, module version = 2.3.3
[ 37.880] Module class: X.Org Video Driver
[ 37.880] ABI class: X.Org Video Driver, version 15.0
[ 37.880] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 37.881] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[ 37.881] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[ 37.881] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[ 37.881] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 37.881] (II) FBDEV: driver for framebuffer: fbdev
[ 37.881] (II) VESA: driver for VESA chipsets: vesa
[ 37.881] (++) using VT number 8

[ 37.885] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.910-0ubuntu1 (Timo Aaltonen <tjaalton@ubuntu.com>)
[ 37.886] (WW) Falling back to old probe method for modesetting
[ 37.886] (WW) Falling back to old probe method for fbdev
[ 37.886] (II) Loading sub module "fbdevhw"
[ 37.886] (II) LoadModule: "fbdevhw"
[ 37.886] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 37.886] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 37.886] compiled for 1.15.1, module version = 0.0.2
[ 37.886] ABI class: X.Org Video Driver, version 15.0
[ 37.886] (WW) Falling back to old probe method for vesa
[ 37.887] (--) intel(0): Integrated Graphics Chipset: Intel(R) 945G
[ 37.887] (--) intel(0): CPU: x86, sse2, sse3
[ 37.887] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 37.887] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 37.887] (==) intel(0): RGB weight 888
[ 37.887] (==) intel(0): Default visual is TrueColor
[ 37.888] (**) intel(0): Framebuffer tiled
[ 37.888] (**) intel(0): Pixmaps tiled
[ 37.888] (**) intel(0): "Tear free" disabled
[ 37.888] (**) intel(0): Forcing per-crtc-pixmaps? no
[ 37.888] (II) intel(0): Output VGA1 has no monitor section
[ 37.888] (II) intel(0): Output VIRTUAL1 has no monitor section
[ 37.888] (--) intel(0): Output VGA1 using initial mode 1024x768 on pipe 0
[ 37.888] (==) intel(0): DPI set to (96, 96)
[ 37.888] (II) Loading sub module "dri2"
[ 37.888] (II) LoadModule: "dri2"
[ 37.888] (II) Module "dri2" already built-in
[ 37.888] (II) UnloadModule: "modesetting"
[ 37.888] (II) Unloading modesetting
[ 37.888] (II) UnloadModule: "fbdev"
[ 37.888] (II) Unloading fbdev
[ 37.888] (II) UnloadSubModule: "fbdevhw"
[ 37.888] (II) Unloading fbdevhw
[ 37.888] (II) UnloadModule: "vesa"
[ 37.888] (II) Unloading vesa
[ 37.888] (==) Depth 24 pixmap format is 32 bpp
[ 37.889] (II) intel(0): SNA initialized with Alviso (gen3) backend
[ 37.889] (==) intel(0): Backing store enabled
[ 37.889] (==) intel(0): Silken mouse enabled
[ 37.889] (II) intel(0): HW Cursor enabled
[ 37.889] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 37.889] (==) intel(0): DPMS enabled
[ 37.889] (II) intel(0): [XvMC] i915_xvmc driver initialized.
[ 37.889] (II) intel(0): [DRI2] Setup complete
[ 37.889] (II) intel(0): [DRI2] DRI driver: i915
[ 37.889] (II) intel(0): [DRI2] VDPAU driver: i915
[ 37.889] (II) intel(0): direct rendering: DRI2 Enabled
[ 37.889] (==) intel(0): hotplug detection: "enabled"
[ 37.889] (--) RandR disabled
[ 37.901] (II) SELinux: Disabled on system
[ 37.924] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 37.924] (II) AIGLX: enabled GLX_ARB_create_context
[ 37.924] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 37.924] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[ 37.924] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 37.924] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 37.924] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[ 37.924] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[ 37.924] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 37.924] (II) AIGLX: Loaded and initialized i915
[ 37.924] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 37.931] (II) intel(0): switch to mode 1024x768@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 37.956] (II) intel(0): Setting screen physical size to 270 x 203
[ 37.968] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[ 37.973] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 37.973] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 37.973] (II) LoadModule: "evdev"
[ 37.973] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 37.980] (II) Module evdev: vendor="X.Org Foundation"
[ 37.980] compiled for 1.15.0, module version = 2.8.2
[ 37.980] Module class: X.Org XInput Driver
[ 37.980] ABI class: X.Org XInput driver, version 20.0
[ 37.980] (II) Using input driver 'evdev' for 'Power Button'
[ 37.980] (**) Power Button: always reports core events
[ 37.981] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 37.981] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 37.981] (--) evdev: Power Button: Found keys
[ 37.981] (II) evdev: Power Button: Configuring as keyboard
[ 37.981] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[ 37.981] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 37.981] (**) Option "xkb_rules" "evdev"
[ 37.981] (**) Option "xkb_model" "pc105"
[ 37.981] (**) Option "xkb_layout" "gb"
[ 37.981] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.985] (II) XKB: reuse xkmfile /var/lib/xkb/server-7996F6726817F73651B9DE0FDA11E35FC4524568.xkm
[ 37.986] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 37.986] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 37.986] (II) Using input driver 'evdev' for 'Power Button'
[ 37.986] (**) Power Button: always reports core events
[ 37.986] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 37.986] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 37.986] (--) evdev: Power Button: Found keys
[ 37.986] (II) evdev: Power Button: Configuring as keyboard
[ 37.986] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 37.986] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 37.986] (**) Option "xkb_rules" "evdev"
[ 37.986] (**) Option "xkb_model" "pc105"
[ 37.986] (**) Option "xkb_layout" "gb"
[ 37.986] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.986] (II) config/udev: Adding drm device (/dev/dri/card0) card0 /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[ 37.987] (II) config/udev: Ignoring already known drm device (/dev/dri/card0)
[ 37.987] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/event2)
[ 37.987] (**) Logitech Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[ 37.987] (II) Using input driver 'evdev' for 'Logitech Optical USB Mouse'
[ 37.987] (**) Logitech Optical USB Mouse: always reports core events
[ 37.987] (**) evdev: Logitech Optical USB Mouse: Device: "/dev/input/event2"
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Vendor 0x46d Product 0xc016
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found 3 mouse buttons
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found scroll wheel(s)
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found relative axes
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found x and y relative axes
[ 37.987] (II) evdev: Logitech Optical USB Mouse: Configuring as mouse
[ 37.987] (II) evdev: Logitech Optical USB Mouse: Adding scrollwheel support
[ 37.987] (**) evdev: Logitech Optical USB Mouse: YAxisMapping: buttons 4 and 5
[ 37.988] (**) evdev: Logitech Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 37.988] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/input/input7/event2"
[ 37.988] (II) XINPUT: Adding extended input device "Logitech Optical USB Mouse" (type: MOUSE, id 8)
[ 37.988] (II) evdev: Logitech Optical USB Mouse: initialized for relative axes.
[ 37.988] (**) Logitech Optical USB Mouse: (accel) keeping acceleration scheme 1
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration profile 0
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration factor: 2.000
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration threshold: 4
[ 37.988] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/mouse0)
[ 37.988] (II) No input driver specified, ignoring this device.
[ 37.988] (II) This device may have been added with another device file.
[ 37.989] (II) config/udev: Adding input device KB USB KB (/dev/input/event3)
[ 37.989] (**) KB USB KB: Applying InputClass "evdev keyboard catchall"
[ 37.989] (II) Using input driver 'evdev' for 'KB USB KB'
[ 37.989] (**) KB USB KB: always reports core events
[ 37.989] (**) evdev: KB USB KB: Device: "/dev/input/event3"
[ 37.989] (--) evdev: KB USB KB: Vendor 0x5d5 Product 0x624c
[ 37.989] (--) evdev: KB USB KB: Found keys
[ 37.989] (II) evdev: KB USB KB: Configuring as keyboard
[ 37.989] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/input/input8/event3"
[ 37.989] (II) XINPUT: Adding extended input device "KB USB KB" (type: KEYBOARD, id 9)
[ 37.989] (**) Option "xkb_rules" "evdev"
[ 37.989] (**) Option "xkb_model" "pc105"
[ 37.989] (**) Option "xkb_layout" "gb"
[ 37.989] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.990] (II) config/udev: Adding input device KB USB KB (/dev/input/event4)
[ 37.990] (**) KB USB KB: Applying InputClass "evdev keyboard catchall"
[ 37.990] (II) Using input driver 'evdev' for 'KB USB KB'
[ 37.990] (**) KB USB KB: always reports core events
[ 37.990] (**) evdev: KB USB KB: Device: "/dev/input/event4"
[ 37.990] (--) evdev: KB USB KB: Vendor 0x5d5 Product 0x624c
[ 37.990] (--) evdev: KB USB KB: Found 1 mouse buttons
[ 37.991] (--) evdev: KB USB KB: Found scroll wheel(s)
[ 37.991] (--) evdev: KB USB KB: Found relative axes
[ 37.991] (II) evdev: KB USB KB: Forcing relative x/y axes to exist.
[ 37.991] (--) evdev: KB USB KB: Found absolute axes
[ 37.991] (II) evdev: KB USB KB: Forcing absolute x/y axes to exist.
[ 37.991] (--) evdev: KB USB KB: Found keys
[ 37.991] (II) evdev: KB USB KB: Configuring as mouse
[ 37.991] (II) evdev: KB USB KB: Configuring as keyboard
[ 37.991] (II) evdev: KB USB KB: Adding scrollwheel support
[ 37.991] (**) evdev: KB USB KB: YAxisMapping: buttons 4 and 5
[ 37.991] (**) evdev: KB USB KB: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 37.991] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.1/input/input9/event4"
[ 37.991] (II) XINPUT: Adding extended input device "KB USB KB" (type: KEYBOARD, id 10)
[ 37.991] (**) Option "xkb_rules" "evdev"
[ 37.991] (**) Option "xkb_model" "pc105"
[ 37.991] (**) Option "xkb_layout" "gb"
[ 37.991] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.991] (II) evdev: KB USB KB: initialized for relative axes.
[ 37.991] (WW) evdev: KB USB KB: ignoring absolute axes.
[ 37.991] (**) KB USB KB: (accel) keeping acceleration scheme 1
[ 37.991] (**) KB USB KB: (accel) acceleration profile 0
[ 37.991] (**) KB USB KB: (accel) acceleration factor: 2.000
[ 37.991] (**) KB USB KB: (accel) acceleration threshold: 4
[ 54.692] (II) XKB: reuse xkmfile /var/lib/xkb/server-7996F6726817F73651B9DE0FDA11E35FC4524568.xkm
Hi Robin !

Thank you for picking up on my problem. In reply --

[1] The connection monitor-to-computer is a plain vga cable, using the "d-sub" socket and no other adaptors are used.

Please note that this system is dual boot so the same cable/monitor combination works satisfactorily in WinXP. I have rebooted several times over the course of the past 16-24 hrs, moving back and forth between Mint and WinXP. Whatever conditions that may be current are stable either side of the reboot.

[2] I have discovered a further abnormality which has been generated -- In Mint, when using the new monitor set at maximum obtainable (1024x768) any attempt to "Minimise" a window by clicking on the "minus" sign at the top right corner exits the application immediately. This applies to applications (E.G. Firefox) and also to the Terminal window. This does NOT happen when running WinXP (at 1920x1080).

[3] When the computer boots into either Linux or WinXP, a small splash-screen is displayed recommending that a resolution of 1920x1080 should be set. The implication is that the monitor is correctly sending its information to the computer but that Linxux Mint does not recognise this whilst WinXP does.

[4] xrandr --
So as to work more comfortably, I have removed the new large monitor and reverted to my old one, set to 1024x768. In that configuration, the output from "xrandr" is --

-----------------------------
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 32767 x 32767
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
-----------------------------

I suspected that possibly xrandr might show a different result with the large monitor so I connected this but there is no difference in output between the two monitors.

[5] Output pluma/var/log/Xorg.0.log --
I have had to submit this as one long file because the fault mentioned above (Item2) means that I get disconnected from this forum when I try to move to another window so as to pick up more information.

Best regards and many thanks for looking into this matter -
Eric. (aka hatrack)


[ 37.765]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[ 37.765] X Protocol Version 11, Revision 0
[ 37.765] Build Operating System: Linux 3.2.0-75-generic i686 Ubuntu
[ 37.765] Current Operating System: Linux OptiPlex-GX520 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686
[ 37.765] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=c44ba411-6991-4933-9f99-0d700fba7e33 ro quiet splash vt.handoff=7
[ 37.765] Build Date: 12 February 2015 02:49:46PM
[ 37.765] xorg-server 2:1.15.1-0ubuntu2.7 (For technical support please see http://www.ubuntu.com/support)
[ 37.765] Current version of pixman: 0.30.2
[ 37.765] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 37.765] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 37.765] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 14 18:33:52 2016
[ 37.777] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 37.777] (==) No Layout section. Using the first Screen section.
[ 37.777] (==) No screen section available. Using defaults.
[ 37.777] (**) |-->Screen "Default Screen Section" (0)
[ 37.777] (**) | |-->Monitor "<default monitor>"
[ 37.778] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 37.778] (==) Automatically adding devices
[ 37.778] (==) Automatically enabling devices
[ 37.778] (==) Automatically adding GPU devices
[ 37.778] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 37.778] Entry deleted from font path.
[ 37.778] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 37.778] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 37.778] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 37.778] (II) Loader magic: 0xb77456c0
[ 37.778] (II) Module ABI versions:
[ 37.778] X.Org ANSI C Emulation: 0.4
[ 37.778] X.Org Video Driver: 15.0
[ 37.778] X.Org XInput driver : 20.0
[ 37.778] X.Org Server Extension : 8.0
[ 37.779] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 37.780] (--) PCI:*(0:0:2:0) 8086:2772:1028:01ad rev 2, Mem @ 0xfeb00000/524288, 0xe0000000/268435456, 0xfeac0000/262144, I/O @ 0x0000e898/8
[ 37.780] (--) PCI: (0:0:2:1) 8086:2776:1028:01ad rev 2, Mem @ 0xfeb80000/524288
[ 37.781] Initializing built-in extension Generic Event Extension
[ 37.781] Initializing built-in extension SHAPE
[ 37.781] Initializing built-in extension MIT-SHM
[ 37.781] Initializing built-in extension XInputExtension
[ 37.781] Initializing built-in extension XTEST
[ 37.781] Initializing built-in extension BIG-REQUESTS
[ 37.781] Initializing built-in extension SYNC
[ 37.781] Initializing built-in extension XKEYBOARD
[ 37.781] Initializing built-in extension XC-MISC
[ 37.781] Initializing built-in extension SECURITY
[ 37.781] Initializing built-in extension XINERAMA
[ 37.781] Initializing built-in extension XFIXES
[ 37.781] Initializing built-in extension RENDER
[ 37.781] Initializing built-in extension RANDR
[ 37.781] Initializing built-in extension COMPOSITE
[ 37.781] Initializing built-in extension DAMAGE
[ 37.781] Initializing built-in extension MIT-SCREEN-SAVER
[ 37.781] Initializing built-in extension DOUBLE-BUFFER
[ 37.781] Initializing built-in extension RECORD
[ 37.781] Initializing built-in extension DPMS
[ 37.781] Initializing built-in extension Present
[ 37.781] Initializing built-in extension DRI3
[ 37.781] Initializing built-in extension X-Resource
[ 37.781] Initializing built-in extension XVideo
[ 37.781] Initializing built-in extension XVideo-MotionCompensation
[ 37.781] Initializing built-in extension SELinux
[ 37.781] Initializing built-in extension XFree86-VidModeExtension
[ 37.781] Initializing built-in extension XFree86-DGA
[ 37.781] Initializing built-in extension XFree86-DRI
[ 37.781] Initializing built-in extension DRI2
[ 37.781] (II) LoadModule: "glx"
[ 37.801] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 37.853] (II) Module glx: vendor="X.Org Foundation"
[ 37.853] compiled for 1.15.1, module version = 1.0.0
[ 37.853] ABI class: X.Org Server Extension, version 8.0
[ 37.853] (==) AIGLX enabled
[ 37.853] Loading extension GLX
[ 37.853] (==) Matched intel as autoconfigured driver 0
[ 37.853] (==) Matched intel as autoconfigured driver 1
[ 37.853] (==) Matched modesetting as autoconfigured driver 2
[ 37.853] (==) Matched fbdev as autoconfigured driver 3
[ 37.853] (==) Matched vesa as autoconfigured driver 4
[ 37.853] (==) Assigned the driver to the xf86ConfigLayout
[ 37.853] (II) LoadModule: "intel"
[ 37.864] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 37.879] (II) Module intel: vendor="X.Org Foundation"
[ 37.879] compiled for 1.15.0, module version = 2.99.910
[ 37.879] Module class: X.Org Video Driver
[ 37.879] ABI class: X.Org Video Driver, version 15.0
[ 37.879] (II) LoadModule: "modesetting"
[ 37.879] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 37.879] (II) Module modesetting: vendor="X.Org Foundation"
[ 37.879] compiled for 1.15.0, module version = 0.8.1
[ 37.879] Module class: X.Org Video Driver
[ 37.879] ABI class: X.Org Video Driver, version 15.0
[ 37.879] (II) LoadModule: "fbdev"
[ 37.880] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 37.880] (II) Module fbdev: vendor="X.Org Foundation"
[ 37.880] compiled for 1.15.0, module version = 0.4.4
[ 37.880] Module class: X.Org Video Driver
[ 37.880] ABI class: X.Org Video Driver, version 15.0
[ 37.880] (II) LoadModule: "vesa"
[ 37.880] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 37.880] (II) Module vesa: vendor="X.Org Foundation"
[ 37.880] compiled for 1.15.0, module version = 2.3.3
[ 37.880] Module class: X.Org Video Driver
[ 37.880] ABI class: X.Org Video Driver, version 15.0
[ 37.880] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 37.881] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[ 37.881] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[ 37.881] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[ 37.881] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 37.881] (II) FBDEV: driver for framebuffer: fbdev
[ 37.881] (II) VESA: driver for VESA chipsets: vesa
[ 37.881] (++) using VT number 8

[ 37.885] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.910-0ubuntu1 (Timo Aaltonen <tjaalton@ubuntu.com>)
[ 37.886] (WW) Falling back to old probe method for modesetting
[ 37.886] (WW) Falling back to old probe method for fbdev
[ 37.886] (II) Loading sub module "fbdevhw"
[ 37.886] (II) LoadModule: "fbdevhw"
[ 37.886] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 37.886] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 37.886] compiled for 1.15.1, module version = 0.0.2
[ 37.886] ABI class: X.Org Video Driver, version 15.0
[ 37.886] (WW) Falling back to old probe method for vesa
[ 37.887] (--) intel(0): Integrated Graphics Chipset: Intel(R) 945G
[ 37.887] (--) intel(0): CPU: x86, sse2, sse3
[ 37.887] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 37.887] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 37.887] (==) intel(0): RGB weight 888
[ 37.887] (==) intel(0): Default visual is TrueColor
[ 37.888] (**) intel(0): Framebuffer tiled
[ 37.888] (**) intel(0): Pixmaps tiled
[ 37.888] (**) intel(0): "Tear free" disabled
[ 37.888] (**) intel(0): Forcing per-crtc-pixmaps? no
[ 37.888] (II) intel(0): Output VGA1 has no monitor section
[ 37.888] (II) intel(0): Output VIRTUAL1 has no monitor section
[ 37.888] (--) intel(0): Output VGA1 using initial mode 1024x768 on pipe 0
[ 37.888] (==) intel(0): DPI set to (96, 96)
[ 37.888] (II) Loading sub module "dri2"
[ 37.888] (II) LoadModule: "dri2"
[ 37.888] (II) Module "dri2" already built-in
[ 37.888] (II) UnloadModule: "modesetting"
[ 37.888] (II) Unloading modesetting
[ 37.888] (II) UnloadModule: "fbdev"
[ 37.888] (II) Unloading fbdev
[ 37.888] (II) UnloadSubModule: "fbdevhw"
[ 37.888] (II) Unloading fbdevhw
[ 37.888] (II) UnloadModule: "vesa"
[ 37.888] (II) Unloading vesa
[ 37.888] (==) Depth 24 pixmap format is 32 bpp
[ 37.889] (II) intel(0): SNA initialized with Alviso (gen3) backend
[ 37.889] (==) intel(0): Backing store enabled
[ 37.889] (==) intel(0): Silken mouse enabled
[ 37.889] (II) intel(0): HW Cursor enabled
[ 37.889] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 37.889] (==) intel(0): DPMS enabled
[ 37.889] (II) intel(0): [XvMC] i915_xvmc driver initialized.
[ 37.889] (II) intel(0): [DRI2] Setup complete
[ 37.889] (II) intel(0): [DRI2] DRI driver: i915
[ 37.889] (II) intel(0): [DRI2] VDPAU driver: i915
[ 37.889] (II) intel(0): direct rendering: DRI2 Enabled
[ 37.889] (==) intel(0): hotplug detection: "enabled"
[ 37.889] (--) RandR disabled
[ 37.901] (II) SELinux: Disabled on system
[ 37.924] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 37.924] (II) AIGLX: enabled GLX_ARB_create_context
[ 37.924] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 37.924] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[ 37.924] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 37.924] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 37.924] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[ 37.924] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[ 37.924] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 37.924] (II) AIGLX: Loaded and initialized i915
[ 37.924] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 37.931] (II) intel(0): switch to mode 1024x768@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 37.956] (II) intel(0): Setting screen physical size to 270 x 203
[ 37.968] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[ 37.973] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 37.973] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 37.973] (II) LoadModule: "evdev"
[ 37.973] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 37.980] (II) Module evdev: vendor="X.Org Foundation"
[ 37.980] compiled for 1.15.0, module version = 2.8.2
[ 37.980] Module class: X.Org XInput Driver
[ 37.980] ABI class: X.Org XInput driver, version 20.0
[ 37.980] (II) Using input driver 'evdev' for 'Power Button'
[ 37.980] (**) Power Button: always reports core events
[ 37.981] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 37.981] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 37.981] (--) evdev: Power Button: Found keys
[ 37.981] (II) evdev: Power Button: Configuring as keyboard
[ 37.981] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[ 37.981] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 37.981] (**) Option "xkb_rules" "evdev"
[ 37.981] (**) Option "xkb_model" "pc105"
[ 37.981] (**) Option "xkb_layout" "gb"
[ 37.981] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.985] (II) XKB: reuse xkmfile /var/lib/xkb/server-7996F6726817F73651B9DE0FDA11E35FC4524568.xkm
[ 37.986] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 37.986] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 37.986] (II) Using input driver 'evdev' for 'Power Button'
[ 37.986] (**) Power Button: always reports core events
[ 37.986] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 37.986] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 37.986] (--) evdev: Power Button: Found keys
[ 37.986] (II) evdev: Power Button: Configuring as keyboard
[ 37.986] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 37.986] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 37.986] (**) Option "xkb_rules" "evdev"
[ 37.986] (**) Option "xkb_model" "pc105"
[ 37.986] (**) Option "xkb_layout" "gb"
[ 37.986] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.986] (II) config/udev: Adding drm device (/dev/dri/card0) card0 /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[ 37.987] (II) config/udev: Ignoring already known drm device (/dev/dri/card0)
[ 37.987] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/event2)
[ 37.987] (**) Logitech Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[ 37.987] (II) Using input driver 'evdev' for 'Logitech Optical USB Mouse'
[ 37.987] (**) Logitech Optical USB Mouse: always reports core events
[ 37.987] (**) evdev: Logitech Optical USB Mouse: Device: "/dev/input/event2"
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Vendor 0x46d Product 0xc016
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found 3 mouse buttons
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found scroll wheel(s)
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found relative axes
[ 37.987] (--) evdev: Logitech Optical USB Mouse: Found x and y relative axes
[ 37.987] (II) evdev: Logitech Optical USB Mouse: Configuring as mouse
[ 37.987] (II) evdev: Logitech Optical USB Mouse: Adding scrollwheel support
[ 37.987] (**) evdev: Logitech Optical USB Mouse: YAxisMapping: buttons 4 and 5
[ 37.988] (**) evdev: Logitech Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 37.988] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/input/input7/event2"
[ 37.988] (II) XINPUT: Adding extended input device "Logitech Optical USB Mouse" (type: MOUSE, id 8)
[ 37.988] (II) evdev: Logitech Optical USB Mouse: initialized for relative axes.
[ 37.988] (**) Logitech Optical USB Mouse: (accel) keeping acceleration scheme 1
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration profile 0
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration factor: 2.000
[ 37.988] (**) Logitech Optical USB Mouse: (accel) acceleration threshold: 4
[ 37.988] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/mouse0)
[ 37.988] (II) No input driver specified, ignoring this device.
[ 37.988] (II) This device may have been added with another device file.
[ 37.989] (II) config/udev: Adding input device KB USB KB (/dev/input/event3)
[ 37.989] (**) KB USB KB: Applying InputClass "evdev keyboard catchall"
[ 37.989] (II) Using input driver 'evdev' for 'KB USB KB'
[ 37.989] (**) KB USB KB: always reports core events
[ 37.989] (**) evdev: KB USB KB: Device: "/dev/input/event3"
[ 37.989] (--) evdev: KB USB KB: Vendor 0x5d5 Product 0x624c
[ 37.989] (--) evdev: KB USB KB: Found keys
[ 37.989] (II) evdev: KB USB KB: Configuring as keyboard
[ 37.989] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/input/input8/event3"
[ 37.989] (II) XINPUT: Adding extended input device "KB USB KB" (type: KEYBOARD, id 9)
[ 37.989] (**) Option "xkb_rules" "evdev"
[ 37.989] (**) Option "xkb_model" "pc105"
[ 37.989] (**) Option "xkb_layout" "gb"
[ 37.989] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.990] (II) config/udev: Adding input device KB USB KB (/dev/input/event4)
[ 37.990] (**) KB USB KB: Applying InputClass "evdev keyboard catchall"
[ 37.990] (II) Using input driver 'evdev' for 'KB USB KB'
[ 37.990] (**) KB USB KB: always reports core events
[ 37.990] (**) evdev: KB USB KB: Device: "/dev/input/event4"
[ 37.990] (--) evdev: KB USB KB: Vendor 0x5d5 Product 0x624c
[ 37.990] (--) evdev: KB USB KB: Found 1 mouse buttons
[ 37.991] (--) evdev: KB USB KB: Found scroll wheel(s)
[ 37.991] (--) evdev: KB USB KB: Found relative axes
[ 37.991] (II) evdev: KB USB KB: Forcing relative x/y axes to exist.
[ 37.991] (--) evdev: KB USB KB: Found absolute axes
[ 37.991] (II) evdev: KB USB KB: Forcing absolute x/y axes to exist.
[ 37.991] (--) evdev: KB USB KB: Found keys
[ 37.991] (II) evdev: KB USB KB: Configuring as mouse
[ 37.991] (II) evdev: KB USB KB: Configuring as keyboard
[ 37.991] (II) evdev: KB USB KB: Adding scrollwheel support
[ 37.991] (**) evdev: KB USB KB: YAxisMapping: buttons 4 and 5
[ 37.991] (**) evdev: KB USB KB: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 37.991] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.1/input/input9/event4"
[ 37.991] (II) XINPUT: Adding extended input device "KB USB KB" (type: KEYBOARD, id 10)
[ 37.991] (**) Option "xkb_rules" "evdev"
[ 37.991] (**) Option "xkb_model" "pc105"
[ 37.991] (**) Option "xkb_layout" "gb"
[ 37.991] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 37.991] (II) evdev: KB USB KB: initialized for relative axes.
[ 37.991] (WW) evdev: KB USB KB: ignoring absolute axes.
[ 37.991] (**) KB USB KB: (accel) keeping acceleration scheme 1
[ 37.991] (**) KB USB KB: (accel) acceleration profile 0
[ 37.991] (**) KB USB KB: (accel) acceleration factor: 2.000
[ 37.991] (**) KB USB KB: (accel) acceleration threshold: 4
[ 54.692] (II) XKB: reuse xkmfile /var/lib/xkb/server-7996F6726817F73651B9DE0FDA11E35FC4524568.xkm
Last edited by hatrack on Thu Jan 14, 2016 6:09 pm, edited 2 times in total.

User avatar
roblm
Level 12
Level 12
Posts: 4300
Joined: Sun Feb 24, 2013 2:41 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by roblm »

Would you edit your last post by highlighting all the lines in the Xorg.0.log file and then clicking the “Code” button in the menu, so the lines are added to a smaller Code window. Then other users won't have to scroll through all those lines to read the next post.
The Xorg.0.log file may not be the same from two different connected monitors, even if they are displaying the same resolution, but I don't think I'll need to look at it.

Type these xrandr commands in the Terminal one at a time, pressing ENTER after each one:

Code: Select all

xrandr --newmode  "1920x1080_60.00"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync   
xrandr --addmode VGA1 1920x1080_60 
xrandr --output VGA1 --mode 1920x1080

If you get an error message, then use this command to create an xorg.conf file:

Code: Select all

gksudo pluma /etc/X11/xorg.conf
In the empty opened file, add these lines:

Code: Select all

Section "Monitor"			
   Identifier    "Monitor0"
   HorizSync       24.0 - 94.0   
   VertRefresh     24.0 - 87.0
EndSection
Logout and back in. Then try using those 3 xrandr commands again. If that fails, then open the xorg.conf file:

Code: Select all

gksudo pluma /etc/X11/xorg.conf
Remove all the lines and then add these:

Code: Select all

Section "Monitor"			
   Identifier    "Monitor0"
   HorizSync       24.0 - 94.0   
   VertRefresh     24.0 - 87.0
   Modeline "1920x1080_60.00"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync   
   Option "PreferredMode" "1920x1080"
EndSection

Section "Device"
   Identifier   "Device0"
   Driver   "intel"   
   Option "Monitor-VGA1" "Monitor0"
EndSection

Section "Screen"
   Identifier   "Screen0"
   DefaultDepth   24
   SubSection     "Display"
      Depth       24
      Modes "1920x1080" 
   EndSubSection
EndSection
Logout and back in.

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by hatrack »

Hi Robin !

Thank you for a quick reply.

[1] I tried to delete the mass of output I had collected from Xorg.0.log after inserting this as "Code" but could not find a way to do this --- possibly an artefact of my misbehaving monitor ?

[2] Re your suggestions using xrandr --newmode and xrandr -- addmode, I employed the suggested lines of code multiple times yesterday evening. The first time through, I managed to generate the required resolution and it was this result which lead me to write my post claiming "Problem solved". When, later, I found that the resolution setting had been lost, I worked for many hours (until 0500 today ! ), repeating the processes with sensible variations but, the desired resolution has never since been set. I.E. One attempt seemingly "scrambled" the software somehow. With that said, in the interests of completeness, I will work through ALL the steps which you recommend and will report my findings.

One way and another, I have been researching and struggling with this problem almost continuously for the better part of 36 hrs with very little sleep so I am not going to attempt anything until tomorrow morning. I should be able to report progress/results by about midday UK time so, I'll leave matters there for now.

Many thanks,
Eric.

User avatar
roblm
Level 12
Level 12
Posts: 4300
Joined: Sun Feb 24, 2013 2:41 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by roblm »

You probably used this command to create the modeline:

Code: Select all

cvt 1920 1080
I used this command:

Code: Select all

cvt -r 1920 1080
This creates a mode with reduced blanking, which is needed for digital displays, which need a lower pixel clock and timing values. The cvt command without reduced blanking is for older CRT displays.
Note the differences in the pixel clock (173.00 vs 138.50) and the other timing values:

Code: Select all

cvt 1920 1080
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

cvt -r 1920 1080
Modeline "1920x1080R"       138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by hatrack »

Hi roblm (I apologise that I misread your on-line name previously - my 82 yr old eyes are not as sharp as they used to be so I misread the chrs "lm" as "in").

Further to your last message, I did indeed form my first Modeline using the bare command "cvt 1920 1080" because (a) I knew nothing about monitors or timing and (b) I was following the procedure described. I now understand how this lead to errors but I must remark that this is a somewhat specialised field. Normal users cannot be expected to know as much as do the developers and so it is incumbent upon these experts to document the matter so that non-specialised users can use the system intelligently.

As promised, I have worked through your latest proposals and report the details below. The resolution problem is solved but I still can only open one application at a time so my working practice of minimising one so as to open and edit in another is no longer easily possible. See Item [10], below.

Apart from that, I am now very happy with the results you have lead me to achieve and thank you for the time and effort which when into devising the procedure you proposed.

Very best regards to you --
Eric (aka hatrack)
---------------------------------------

Application & Testing of revised procedure --

[1] -- xrandr --newmode "1920x1080_60.00" 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
Accepted OK
[2] -- xrandr --addmode VGA1 1920x1080_60
Msg = xrandr: cannot find mode "1920x1080_60"
[2a] -- xrandr --addmode VGA1 1920x1080_60.00
Accepted OK -- full description of refresh-rate was needed
[3] xrandr --output VGA1 1920x1080_60.00
Msg = xrandr: unrecognized option '1920x1080_60.00'
[3a] -- Tried various combinations with and without inverted comma or commas
Msg = xrandr: unrecognized option, etc.
Oviously there is no point in continuing this line of testing.

[4] As instructed, created empty xorg.conf and entered -
Section "Monitor"
Identifier "Monitor0"
HorizSync 24.0 - 94.0
VertRefresh 24.0 - 87.0
EndSection

Logged out and in again -

[5] As instructed, tried first of previous three lines -

xrandr --newmode "1920x1080_60.00" 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync

Msg = X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 28
Current serial number in output stream: 28

Obviously there is no point in trying two other lines so tried to open xorg.conf --

[6] gksudo pluma /etc/X11/xorg.conf
Msg = No protocol specified

(gksudo:3611): Gtk-WARNING **: cannot open display: :0.0

[6a] Attempted to reach xorg.conf via Caja so as to edit from there -
gksudo caja
Msg = No protocol specified

This is ridiculous ! - reboot computer and start again --

[7] After reboot --
Open Terminal
gksudo caja --- OK, opens as usual without problems
Manually find - /etc/X11/xorg.conf and check "Permissions" - OK as am at root
Back-up existing xorg.conf via "Copy as" to xorg.conf.bak - checked OK
Return to original xorg.conf, delete lines previously inserted and then add --

Code: Select all

Section "Monitor"         
       Identifier    "Monitor0"
       HorizSync       24.0 - 94.0   
       VertRefresh     24.0 - 87.0
       Modeline "1920x1080_60.00"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync   
       Option "PreferredMode" "1920x1080"
    EndSection

    Section "Device"
       Identifier   "Device0"
       Driver   "intel"   
       Option "Monitor-VGA1" "Monitor0"
    EndSection

    Section "Screen"
       Identifier   "Screen0"
       DefaultDepth   24
       SubSection     "Display"
          Depth       24
          Modes "1920x1080"
       EndSubSection
    EndSection
Save file, then re-open to check editing/insertion has worked correctly ("Copy&Paste" used to avoid typos).

[8] Exit Caja and Terminal and then reboot.
Screen resolution has not changed from previous 1024x768

In Terninal -- xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 32767 x 32767
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920x1080_60.00 59.9
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

NB - CURRENT resolution is correctly shown. Desired resolution of 1920x1080 is now listed in this output and can be correctly selected from --
System > Preferences > Hardware > Displays

Monitor resolution changes correctly after selecting "Apply" and this is confirmed --
xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
VGA1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920x1080 59.9*+
1920x1080_60.00 59.9
1024x768 60.0
800x600 60.3 56.2
848x480 60.0
640x480 59.9
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Proper resolution is shown as "Current"

[9] Exit Terminal mode and reboot to test whether or not new setting remains in effect.

During the boot, monitor setting to 1920x1080 can be seen by the changed size of logon screen display and is correctly set when monitor is fully operational.

[10] Whilst the problem of monitor resolution has now been solved, an annoying artefact still remains -- only one application can be in use at any one time so, it is not possible to minimise a running application and open another. This computer has 2 GB of RAM so it seems very strange that I now cannot open say Firefox and a simple text editor (like Pluma or Gedit) which I have always been able to do before these changes.

User avatar
roblm
Level 12
Level 12
Posts: 4300
Joined: Sun Feb 24, 2013 2:41 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by roblm »

hatrack wrote:an annoying artefact still remains -- only one application can be in use at any one time so, it is not possible to minimise a running application and open another.
Right click on the bottom panel and select “Add to Panel”. Click on the item “Window List”, and then click the “Add” button.

hatrack
Level 1
Level 1
Posts: 46
Joined: Sun Nov 16, 2008 6:49 pm

Re: [NOT SOLVED-DANGEROUS] Setting resolution for large moni

Post by hatrack »

Hi roblm

Thank you for your info re setting "Windows List" to be active --- Ain't things easy when you know how !

I've been using Linux for several years now and my Desktop has a heavily customised layout of top and bottom panels plus iconised short cuts to the various apps which I use regularly -- it looks rather like the old OS/2 layout. I even run the Amazon Kindle reader app under WINE (which neatly placed an icon on my Desktop when I installed this application although, theoretically, this will only run in a Windows environment -- it can't even be downloaded from Amazon to a Linux system -- this must be running (say) WinXP to even get the installer *.exe).

With all that said, I have never needed to customise the way the bottom panel operates -- it's always been automatic on the smaller monitors.

Thank you again for all your advice. All our traffic is securely filed away. I'll now edit the subject line back to "SOLVED" but I will keep the warning, since there are snags for the unwary in all this business so the thread needs to be studied carefully by anyone else setting up one of these large LED monitors.

Best regards,
Eric (aka hatrack)

Post Reply

Return to “Graphics Cards & Monitors”